Previous 1 2 3 Next 30 Replies Latest reply: May 6, 2014 3:07 PM by Frank Caggiano
denis119 Level 1 Level 1 (0 points)

Adjusting a raw photo use to create a stack with the new version. Any other change to the existing version would create another version.

 

This stopped working. I checked the two entries in the Preference and there are ok. I restarted my MBP, I removed the Adjustment reset Plist..etc.

 

How can I solve this? 

 

I wonder if it is related to my new Sony raw format.


MacBook Pro with Retina display, OS X Mavericks (10.9.1)
  • Frank Caggiano Level 7 Level 7 (25,715 points)

    Just double checked and it works for me with 3.5.1 and 10.9.2, The format of the image you are editing should not make a difference.

     

    As a test try making a new library and see if it works there and also try it in a different user account, the Guest user will work fine as a test.

     

    Just to be clear make new version when making adjustments only has an effect when the version selected isthe original version Aperture created on import. It will not make (and never did make) a new version each time you added an adjustment to subsequent versions.

     

    regards

  • denis119 Level 1 Level 1 (0 points)

    Thank you for your support.

    I made the tests you suggested.

     

    With a new library, a new stack is not created with the new version.

     

    With a different Gest user it works ok,  as it used to do.

     

    Does it lead to something being corrupted? I  will verify the disk, permissions and all.

     

    One week ago I did have a special problem with Mail. It has been solved with the help of an Apple support person - His diagnostic has been that a file was corrupted. As I have a SSD HD may be it is linked to this.

     

    Any other idea?

    PS: I hope I do not make to many mistakes. My mother language is french

  • Frank Caggiano Level 7 Level 7 (25,715 points)

    Did you remove the Aperture preference file that is located in your home library preference folder?  If Aperture works ok in a new account there is a good chance that the problem is your preference file.

     

    And your English is very good.

     

     

    Regards

  • denis119 Level 1 Level 1 (0 points)

    Yes I removed the preference  and I re-did it - Same issue

    I also checked the permissions - many related to Itune needed to be repaired, which I did, but none to IPhoto library or Aperture

  • léonie Level 9 Level 9 (79,535 points)

    Did you log off and on again, after removing the preferences? Otherwise the removal may not take effect.

     

    If you did not log off, before starting Aperture again, try again.

     

    It may be necessary, to remove also the mirrored preferences in the sandbox "Containers".

     

    ~/Library/Preferences/com.apple.Aperture.plist

     

    ~/Library/Containers/com.apple.Aperture

  • denis119 Level 1 Level 1 (0 points)

    Good morning Léonie

     

    The answer is yes I had logged off. But to make sure I did it again.

     

    I also removed these two files

    ~/Library/Preferences/com.apple.Aperture.plist

     

    ~/Library/Containers/com.apple.Aperture

     

    But the problem remains.

     

    It looks like a bug in Aperture

  • Frank Caggiano Level 7 Level 7 (25,715 points)
    It looks like a bug in Aperture

     

    Just to be sure, there is a difference in what you see when you do this in a library logged in as yourself and when you do this in a library logged in as the Guest user?

     

    If so then this can only be something in your environment, not an Aperture issue.

     

    With the new OS getting rid of preferences can be a real problem. As a test now I just tried it and I had to reboot. Just logging off did not do it.

     

    If after you have removed the preference file (com.apple.Aperture.plist) and the Aperture folder in the Containers folder when you log into Aperture you do not get the Welcome To Aperture splash screen then the preferences for Aperture have not been reset.

     

    As I said to get this to happen for me I had to

    1. Quit Aperture
    2. delete the file and the folder
    3. Re-boot

     

    Then I got the Welcome to Aperture splash screen.

     

    So basically if the preferences have been remove when you start Aperture it should appear as if Aperture is running for the first time.

     

    Message was edited by: Frank Caggiano - Note this also means that if your library is named something other then the default name (Aperture Library.aplibrary) i the default location (Pictures) Aperture will not find your library and will create a default library. Don;t worry you can reconnect to your library by closing Aperture, finding your library in the Finder and double clicking it.

  • léonie Level 9 Level 9 (79,535 points)

    It looks like in Mavericks even log-off does no longer suffice, when trashing Preferences. I hope, Frank's recommendation to restart the computer will solve this for you.

  • Frank Caggiano Level 7 Level 7 (25,715 points)

    Looks like more-and-more OS X is becoming a memory based OS. I was pretty surprised when logging off and back on did not bring up the splash screen.

     

    I suppose if another user had logged on in between the log off and log on of my account then it might have forced the memory to clear.

     

    On well just another minor inconvenience

     

    regards

     

    Message was edited by: Frank Caggiano - The old windows troubleshooting tip 'Turn it off and back on' is starting to look good for Apple now.

  • léonie Level 9 Level 9 (79,535 points)
    The old windows troubleshooting tip 'Turn it off and back on' is starting to look good for Apple now.

      In Snow Leopard I have system up times of more than a year, but since Lion this went down!

     

    I noticed, that I do not need to log off and on, if I force-quit Aperture or GarageBand, but that may be a coincidence. And usually we would not want to force-quit Aperture, if it can be avoided.

  • denis119 Level 1 Level 1 (0 points)

    Hi everybody,

     

    I implemented carefully all suggestions which were made but.... new version does not create a stack anymore. I will contact Apple support and if I get a solution I will inform you. Thank you for your time.

    Have a good day

  • Frank Caggiano Level 7 Level 7 (25,715 points)

    Ok maybe we re having a language problem.

     

    First trust both Léonie and myself, the preferences you are refering to still work, there is no  bug or problem with Aperture.

     

    Second you wrote that Aperture worked as you expected when you ran it as the Guest User. If this is the case how can you think that there is a problem in Aperture?

     

    If the first thing is correct, it ran as you expected in the Guest Account,  when you removed the preferences and reboothed the machine did you get the Welcome to Aperture Splash screen?  If not then Aperture did not reset.

     

    I hope you have better luck with Aperture but as the feature still works I'm not sure what they will be able to do for you.

     

    regards

  • léonie Level 9 Level 9 (79,535 points)

    I forgot to mention - have you reset your Preferences in Aperture after trashing the Preferences?

     

    Trashing this file will reset everything to factory settings. So, have you reenabled the option "Automatically Stack New Versions" in the Aperture preferences, after you trashed the files?

     

    If yes, and it still does not work, launch the Terminal.app (from the folder Applications > Utilities) and enter this command  (copy and paste it, exactly as it is into the Terminal window):

     

    defaults read com.apple.Aperture | grep StackNewVersions

     

    This will read the Preferences file, and we will know, if setting the preferences works.

    The result should be

        StackNewVersions = 1;

     

    If it is different, post back, please.

  • denis119 Level 1 Level 1 (0 points)

    Please be assured that I fully trust both of you and appreciate your support.

     

    When I rebooted after I had removed the files, I got the Aperture Splash screen. The first time I had to reconnect Aperture to my Iphoto library, the second time it reconnected by itself?

    In all test I made sure the two entries in Preference were ok.

     

    As I have written when I created a new library, Aperture worked ok.

     

    Obviously I dont know where is the bug. The only thing I am sure is that there is a malfunction somewhere. If you have other suggestions I am very open to try them.

     

    My experience with Apple Support is that when you are transfered to a high level specialist they either solve your problem or conclude it is a bug they need to work upon. But they do not commit to a time to have it repaired.

    Merci


Previous 1 2 3 Next