10 Replies Latest reply: Jun 3, 2014 3:57 PM by John Blanchard1
grbenny Level 1 Level 1 (0 points)

Hi.  Recently got my first Mac, iMac equipped with Mavericks, and  I have an issue using an Epson R200 printer. The printer works most of the time, but each time I print, the printer icon displays the "!" symbol, and if I click on it the following error is displayed:

 

Screen Shot 2014-04-13 at 7.56.55 PM.png

 

If I choose "Install" it appears to be installing but I still get the same error each time I print.

 

Also, sometimes erronious errors are displayed such as "paper not installed correctly", even though the printer seems to be functioning.

 

Thanks a lot for any help.

 

Gary


iMac, OS X Mavericks (10.9.1)
  • Carolyn Samit Level 10 Level 10 (95,975 points)

    Gary ..    congrats on your first Mac 

     

     

     

     

    Your proflie indicates your new iMac has v10.9.1 installed?

     

    If that is correct, update your software to v10.9.2.

     

    Click your Apple  menu (top left in your screen). 

     

    From the drop down menu click Software Update.

     

    Restart your iMac after the update(s) are installed then download and the driver for you printer > Epson Stylus Photo R200, Drivers & Downloads - Technical Support - Epson America, Inc.

     

    Then open System Preferences > Printers & Scanners > Print then click + to add the printer.

     

     

     

    BTW, there's an easy way to make sure OS X updates are downloaded and installed when available.

     

    Open System Preferences > App Store then select:  

     

    Automatically check for updates

     

    Download newly available updates in the background

     

    Install system data files and security updates

     

     


  • grbenny Level 1 Level 1 (0 points)

    Hi Carolyn,

     

    Thanks for the help and the congrats. I really am enjoying the iMac. Having been a Windows user since the mid-90's, using the PC was always sort of a utilitarian experience. The Mac actually seems to be fun! 

     

    I thought I had kept up on all the updates, and when i checked I found that I do have 10.9.2 Installed.  I also have the Preferences options selected that you recommend.

     

    This is sort of a strange problem.  It has persisted since I first attached the printer shortly after I purchased the iMac mid January, and hasn't changed through all of the software updates. 

     

    Maybe I should try uninstalling the drivers and starting over?

     

    Thanks a lot,

    Gary

  • John Blanchard1 Level 5 Level 5 (5,030 points)

    To get past the software update issue, delete the printer, the /Library/Printer/EPSON and the /Library/Caches/Epson/ folders and then try software update again. If that fails, download the entire Epson software package here:

     

    http://support.apple.com/kb/DL1398

     

    Hope this helps.

  • grbenny Level 1 Level 1 (0 points)

    Thanks everyone for the help.  I have deleted the printer and reinstalled but still have the same issue.  i'm thinking maybe this printer is so old the drivers aren't supported anymore.  I recently heard on one of the Mac podcasts other people were having trouble with getting drivers for older printers. 

     

    At least the printer works for the most part.  Just annoying errors.  May resort to getting a new printer. Could use a new scanner anyway. Might be a good excuse!

     

    I'm kind of hesitant to install the whole epson package.  I had trouble with that on the Windows system when I first purchased the printer, and it was fairly new technology at the time.

     

    Thanks again.

  • John Blanchard1 Level 5 Level 5 (5,030 points)

    The printer is supported:

     

    http://support.apple.com/kb/HT3669?viewlocale=en_US

     

    There's a file in the /Library/Printer/EPSON that's not getting overwritten when you install. Deleting that folder allows the installer to install everything needed. Deleting the printer is not sufficient. If you don't want to install the whole package, delete that folder and rerun software update.

  • grbenny Level 1 Level 1 (0 points)

    Thanks for the help.  I deleted the printer from library>printers> and restarted the printer again.  I didn't actually see any software update options and didn't have to install anything, but this time the thing worked! No weird errors, no more continual software updates. 

     

    So you know, I did attempt to access the folders you suggested, but in library>printers there were no folders, just the two icons for the available printers.  I moved the R200 to the trash.  I then attempted to access the Epson folder in library>caches>epson, but there were no Epson folders there.  Possibly was removed when I deleted the printer again?

     

    Anyway, third - or fourth or fifth - attempt seemed to get it done. 

     

    Thanks a lot,

    Gary

  • John Blanchard1 Level 5 Level 5 (5,030 points)

    grbenny wrote:

     

     

    So you know, I did attempt to access the folders you suggested, but in library>printers there were no folders, just the two icons for the available printers.

    I am glad you got it working.

     

    There is a difference between ~/Library/Printers and /Library/Printers.

     

    /Library/Printers is where the drivers are stored. ~/Library/Printers is in your home directory, and this is where the printer proxies (available printers that have been opened) are stored.

  • grbenny Level 1 Level 1 (0 points)

    Hi John,

     

    I still don't know my way around the Mac file system all that well.  Not sure what I'm navigating to exactly!  "~/Library"?

     

    If I start at "Macintosh HD", I can see the following:

     

    Macintosh HD/System/Library/Printers/Libraries

    Screen Shot 2014-06-03 at 3.34.53 PM.png
    This doesn't appear to be the correct folder based on what's in it.  Can you show the entire filepath to get to the files/libraries that would need to be deleted?
    Thanks,
    Gary
  • John Blanchard1 Level 5 Level 5 (5,030 points)

    Hi Gary,

     

    The difference in paths can be shown by using Terminal. At the prompt in Terminal:

     

    1) open ~/Library/Printers

     

    vs

     

    2) open /Library/Printers

     

    The path you used above is /System/Library.

     

    I hope this helps.