8 Replies Latest reply: May 5, 2014 4:58 AM by PeterBreis0807
everchris Level 1 Level 1

I tried to install the font ubuntu for my macbook air and it works great on email... but it won't recognize ' and ".

 

When I type ' or " I get a superscript 8 or 9.

 

help please.

Solved by PeterBreis0807 on May 5, 2014 4:58 AM Solved

To turn the keyboard inch and foot marks, the "straight" quotes, into typographically correct "curly" quotes.

 

Curly quotes are the correct form in English punctuation. You can actually type them using the option & shift keys in conjunction with the angle bracket keys. The problem is very few people directly type the correct quotes because they are awkward to do, and to remember the combination.

 

Further other languages use different bracketing methods, and it is simpler to use the same method to achieve them all, by using an auto-replace method to take the correct substitution for whatever language is set in the System Preferences.

 

For some reason Pages 5 is taking the wrong Unicode characters instead of the curly quote glyphs.

 

There is obviously something wrong in the new Pages coding, it is not simply taking the Unicode addresses, because it is substituting the same wrong glyphs for both the double and single quotes.

 

This is not happening in TextEdit, Pages '09 or any other word processing app I can find. So quite evidently there is a very odd error in Pages 5.

 

Peter

Reply by VikingOSX on May 4, 2014 9:25 AM Helpful

Ok. Now I am curious.

 

I have the Ubuntu Mono font family installed in my local Library/Fonts location. In System Preferences > Keyboard > Text, I have smart quotes disabled, and there is no replace/with pair to auto-correct quotes. I do have Smart Quotes enabled in the Pages v5.2 > Edit > Substitutions sub-menu. OS X install is 10.9.2.

 

WIth this font selection, routine typing of single and double-quotes (without keyboard assist) produce the expected smart quotes. I am using a North American Apple keyboard with numeric keypad. All languages set to English.

Reply by PeterBreis0807 on May 5, 2014 4:04 AM Helpful

Yes.

 

Provide full details and steps to reproduce the problem.

 

Peter

All replies

  • Tom Gewecke Level 9 Level 9

    It sounds like the font is broken in some way, or a bug in iWork, you will presumably just have to use something else.

     

    Do you have this problem with any other font?

  • PeterBreis0807 Level 7 Level 7
    expertise.iwork
    iWork

    Confirmed.

     

    There is something wrong with Pages 5 Auto-substitution.

     

    The same text and font in TextEdit & Pages '09 does not have the bug.

     

    Menu > Pages > Provide Pages Feedback

     

    Peter

  • VikingOSX Level 6 Level 6
    expertise.macosx
    Mac OS X

    Ok. Now I am curious.

     

    I have the Ubuntu Mono font family installed in my local Library/Fonts location. In System Preferences > Keyboard > Text, I have smart quotes disabled, and there is no replace/with pair to auto-correct quotes. I do have Smart Quotes enabled in the Pages v5.2 > Edit > Substitutions sub-menu. OS X install is 10.9.2.

     

    WIth this font selection, routine typing of single and double-quotes (without keyboard assist) produce the expected smart quotes. I am using a North American Apple keyboard with numeric keypad. All languages set to English.

  • PeterBreis0807 Level 7 Level 7
    expertise.iwork
    iWork

    Not Ubunto Mono.

     

    All weights of Ubuntu and Ubunto Condensed exhibit the problem.

     

    Peter

  • everchris Level 1 Level 1

    Do I need to follow that path to alert them of this problem?

  • PeterBreis0807 Level 7 Level 7
    expertise.iwork
    iWork

    Yes.

     

    Provide full details and steps to reproduce the problem.

     

    Peter

  • everchris Level 1 Level 1

    I turned off the "smart quotes" and that seemed to fix the problem.

     

    What is the purpose of the smart quotes?

  • PeterBreis0807 Level 7 Level 7
    expertise.iwork
    iWork

    To turn the keyboard inch and foot marks, the "straight" quotes, into typographically correct "curly" quotes.

     

    Curly quotes are the correct form in English punctuation. You can actually type them using the option & shift keys in conjunction with the angle bracket keys. The problem is very few people directly type the correct quotes because they are awkward to do, and to remember the combination.

     

    Further other languages use different bracketing methods, and it is simpler to use the same method to achieve them all, by using an auto-replace method to take the correct substitution for whatever language is set in the System Preferences.

     

    For some reason Pages 5 is taking the wrong Unicode characters instead of the curly quote glyphs.

     

    There is obviously something wrong in the new Pages coding, it is not simply taking the Unicode addresses, because it is substituting the same wrong glyphs for both the double and single quotes.

     

    This is not happening in TextEdit, Pages '09 or any other word processing app I can find. So quite evidently there is a very odd error in Pages 5.

     

    Peter