8 Replies Latest reply: May 6, 2014 9:53 AM by Melophage
Chong007 Level 1 Level 1 (0 points)

Enabling the parental control function has changed the admin status to a managed one which was not intended.

How can I recover the admin status? I have tried to follow a few instructions found in the internet that suggested to use the single mode, but I could not find the necessary admin files that needed to be removed so that the Admin Assistant program would start at booting. Instead, the system is not starting at all.

How can I solve this problem?


MacBook Pro, Mac OS X (10.3.x)
  • Melophage Level 5 Level 5 (7,130 points)

    Chong007,

     

    which model MacBook Pro do you have, and which version of OS X is installed on it? (It’s most certainly not Mac OS X 10.3.x.)

  • Chong007 Level 1 Level 1 (0 points)

    Melophage,

     

    thanks for the query. You are mostly right re the OS X version.

     

    After rechecking via the serial no. I have found that I have a 13 inches A1278 model from early 2011.

    One of the support sites suggests that it might be then OS X 10.6.6.

    It could be even up to version 10.7.2 if it was a later model.

    Thanks in advance.

  • Chong007 Level 1 Level 1 (0 points)

    Melophage,

     

    Pls disregard my previous comment.

    The version is OS X 10.9.2.

    Model A1278.

  • Melophage Level 5 Level 5 (7,130 points)

    Chong007,

     

    boot into Recovery mode by holding down ⌘R as your MacBook Pro starts up. When the OS X Utilities menu appears on your desktop, select Utilities from your menu bar, and from there select Terminal. In Terminal, run the following command:

     

    resetpassword

     

    Follow its instructions, and your administrative user’s password will be changed accordingly. Exit Terminal, then select Restart from the Apple menu to reboot into normal mode. When the login screen appears, log in as your administrative user, and then reset your administrative user’s password keychain so that it won’t constantly ask you for your administrative user’s password when you need to do administrative tasks.

     

    If you  find that your administrative user is still parentally managed, you could reboot into Single User mode, and enter the following commands there:


    /sbin/mount -uw /

    /bin/rm -f /var/db/.AppleSetupDone

    /sbin/reboot

     

    These should allow you to create a new administrative user, from which you should be able to reset your original administrative user to a non-managed state.

  • Chong007 Level 1 Level 1 (0 points)

    Dear Melophage,

     

    I have tried both options, but neither worked for me.

    In the first option, there was no user account to select from.

    And the second option has obviously removed the setup file, but it did not reboot into the setup assistant program afterwards.

    After a short booting sequence/noise the Mac shuts off.

     

    I am thinking of reinstalling the system...

    Is there anything I still can try?

  • Melophage Level 5 Level 5 (7,130 points)

    Chong007,

     

    given the results of the first option, making a backup and then booting into Recovery mode to reïnstall OS X would be your best bet.

  • Chong007 Level 1 Level 1 (0 points)

    Melophage,

     

    Thanks anyhow for your advices...

     

    One last question...

     

    How can I get an backup without having a time machine back up done?

  • Melophage Level 5 Level 5 (7,130 points)

    Chong007,

     

    you can use the “Instructions for backing up to an external hard disk via Disk Utility” on this Apple page.