6 Replies Latest reply: May 4, 2014 9:10 PM by SGIII
James Thomson Level 1 Level 1 (85 points)

Something seems to be corrupting my Numbers.  It won't respond when I try to open a document, the wheel just spins and when I force quit it says Numbers Not Responding.  Then I just tried and I got a message outright telling me that Numbers can not be openned.  What do I do to correct this?


iMac, OS X Mavericks (10.9.1)
  • SGIII Level 5 Level 5 (5,725 points)

    One thing you can try is force quit and then hold down the shift key and launch Numbers.  Holding down the shift key tells Numbers not to try to open the last opened document, which may be corrupted.

     

    SG

  • James Thomson Level 1 Level 1 (85 points)

    Thanks.  That may help.  I've been having problems with opening numbers for a week or two, intermitantly.  I think you may be right about a document being corrupted.  But at this point I was able to get it open and I'm leaving it open long term right now because I use it the document and update it frequently (so I also printed it out on hard copy).  My iMac is 7 years old and is starting to having issues with speed on many operations.  It's scaring me and I may be looking at a new computer soon.  What do you think:  Is there anything wrong with leaving the computer on 24/7, just because I feel safer that it's on and functioning.  I am backed up.  (Well, actually my external drive is full and also corrupted and in the process right now of being thrice wiped over with permanant delete...and then my Time Machine will back it all up...).  Is there any thing wrong with leaving a computer on 24/7?

  • SGIII Level 5 Level 5 (5,725 points)

    Is there any thing wrong with leaving a computer on 24/7?

     

    I guess that depends on the computer and the settings in your System Preferences. I generally use a MacBook Air and usually just put it to "sleep."  I rarely shut it down or quit Numbers.  That may not work as well with older computers.

     

    If you do leave yours "on" you might want to have a look at System Preferences > Energy Saver.

     

    SG

  • James Thomson Level 1 Level 1 (85 points)

    I'm not a spring chicken so I think back to the idea that you are supposed to turn things off.....So I'm glad to hear that you leave your computer on most of the time and don't quit number either much and that this I assume is common practice.  

     

    What were you suggesting though about energy saver settings?  I have my iMac set so that it never goes to sleep and only the display sleeps after the set time.  Is my computer "sleep deprived" to its detriment, or is this just a matter of saving energy?

  • James Thomson Level 1 Level 1 (85 points)

    umm...somehow I clicked that my own reply "solved my question."  That was not intentional, but I'm surpised that it even allows you to click solve for one's own thread reply.

  • SGIII Level 5 Level 5 (5,725 points)

    I have my iMac set so that it never goes to sleep and only the display sleeps after the set time.  Is my computer "sleep deprived" to its detriment, or is this just a matter of saving energy?

     

    That probably depends on your particular setup and the programs you have running. I generally have mine set so the computer sleeps after a certain period of time.  If you leave it on, and not sleeping, you may want to make sure an app is not causing the fans to run constantly. If the fans are not running constantly you should be ok.

     

    SG