Previous 1 2 Next 26 Replies Latest reply: Sep 24, 2006 5:08 AM by a.schmidt
domim Level 1 Level 1 (25 points)
I am having the problem that mail does not display HTML mails properly but shows them als plain text. Well, at least kind of. I went through all settings in Mail and Safari and whatever I might think of but no success.

Not even HTML mails from Apple are displayed correctly.

Any idea what could wrong?

MacBook Pro 2,16 GHz, Mac OS X (10.4.7), 120GB HD, 2GB RAM
  • Allan Sampson Level 10 Level 10 (123,370 points)
    The Mail.app does not include a setting to automatically view or change HTML formatted messages to Plain Text.

    If a spam message or any message is automatically marked as Junk when received that was composed in HTML and includes embedded images or objects that must be rendered from a remote server to be viewed, any such objects will not be automatically rendered as a safety feature.

    As protection from spammers in case a spam message is not automatically marked as Junk when received that contains embedded images or objects that must be rendered from a remote server to be viewed, you should not automatically render all HTML received as additional protection.

    What is your setting at Mail > Preferences > Viewing for "Display remote images in HTML messages"?
  • domim Level 1 Level 1 (25 points)
    It is checked. But the mails with problems are not marked as spam. They also don't even show as HTML mails with images not downloaded but as plain text. Something must be screwed with my Mail.app.
  • Allan Sampson Level 10 Level 10 (123,370 points)
    What type of email account - .Mac, IMAP or POP?
  • domim Level 1 Level 1 (25 points)
    Both POP and IMAP. Does not seem to make a difference. To verify that the mail is actually ok I have checked it in Webmail where it is displayed normally and when I download it in e.g. Outlook it displays fine. Very strange.

    Can I send you a screenshot somewhere?
  • Allan Sampson Level 10 Level 10 (123,370 points)
    Since the same occurs with both email accounts, this may be a cache problem so to rule this out along with any other system problems, as a first step check Resolving Disk, Permission, and Cache Corruption for system troubleshooting procedures and when doing so, follow all steps/instructions in the order provided.
  • domim Level 1 Level 1 (25 points)
    I repaired all disk permissions and cleaned all caches with Onyx and rebooted but no luck, problem still persists. Funny enough the problem does not happen with all HTML mails. The Versiontracker newsletter e.g. displays correctly.
  • Allan Sampson Level 10 Level 10 (123,370 points)
    Try using the Rebuild Mailbox function on the Inbox mailbox for each account.
  • domim Level 1 Level 1 (25 points)
    No luck either.
  • Kevin Horn Level 4 Level 4 (1,825 points)
    I find this kind of funny because I just turned off all HTML in Mail on purpose with a Terminal command.

    Has anyone else been messing with your computer?

    I don't have the Terminal commands to redo HTML here at the office , will have to wait until I get home, but if you trash the preferences for Mail that should fix it.

    Quit Mail then go to user/Library/Preferences and delete com.apple.mail.plist

    Then restart Mail and see what happens.

    There is another one with the same name in /Library/Preferences that you can trash as well if that doesn't work but it's most likely your user preference. If no one was messing with your computer probably just a corrupt preference because there is no way to turn HTML off in Mail other than through a Terminal command line that changes your user preference file. You can't have done it by accident.
  • domim Level 1 Level 1 (25 points)
    So it seems you are right, it must be an issues with the prefs.

    Now is there a way to move all my settings and numerous accounts to new file or even better repair my old file as this would cause me quite some hazzle?
  • albertob Level 1 Level 1 (0 points)
    Me too!!!

    Some months ago I noticed this problem. There is a couple of info I can add:

    1. the problem happen only with MS Exchange server
    2. Torn off and then on (via terminal) the html rendering, do nothing useful

    So, I think it isn't related ti defect in preferences, but may be is a problem in the format of exchange html mail.
    This is a very bad problem, 'cause Exchange servers are everywhere in the professional world (in this poor world...)
  • domim Level 1 Level 1 (25 points)
    For me it was definitely a prefs problem. The problem does not seem to be related to Exchange servers, at least not in my case.
  • albertob Level 1 Level 1 (0 points)
    This is a very strange problem: I asked one of my collegues to resend the incriminated mail on another of my address (one that is not on Exchange) and the html formatting as reborn. The original sending server is still Exchange.
    You say "it was definitely a prefs problem" because the server you are connected is surely not an Exchange or for other reason?
  • domim Level 1 Level 1 (25 points)
    Because my problem was there no matter if Exchange was involved or not. As soon I trashed my mail prefs everything was fine again, also mails from/to Exchange servers.
Previous 1 2 Next