2 Replies Latest reply: May 13, 2014 11:19 AM by Carolyn Samit
dskdesigns Level 1 Level 1 (0 points)

why can't I go to adobe.com with safari? I have a legitimate copy of adobe cs5.5 and I want to download a trial version of cs6, but I can't go there. I have also turned off the firewall but that didn't help.

 

I have a 2010 iMac 27 inch running system 10.9.2

 

I also tried with firefox and same thing.


iMac, Mac OS X (10.6.8)
  • Linc Davis Level 10 Level 10 (147,285 points)
    You, or someone using your computer, may have hacked the system to redirect queries to certain servers. The file modified is /etc/hosts.
       
    The easiest way to fix the hosts file is to restore it from a backup that predates the modification, or to copy the unmodified file from another Mac. If you can't do that, then do as below.

    Back up all data.

    If you have more than one user account, you must be logged in as an administrator.

    Triple-click anywhere in the line below on this page to select it:

    open -e /etc/hosts

    Copy the selected text to the Clipboard by pressing the key combination command-C.

    Launch the built-in Terminal application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window by pressing command-V. I've tested these instructions only with the Safari web browser. If you use another browser, you may have to press the return key after pasting. A TextEdit window should open. At the top of the window, you should see this:

    ##
    # Host Database
    #
    # localhost is used to configure the loopback interface
    # when the system is booting.  Do not change this entry.
    ##
    127.0.0.1                              localhost
    255.255.255.255          broadcasthost
    ::1                                        localhost
    fe80::1%lo0                    localhost

    Below that, you'll see some other lines. There should be nothing above the first line "##". If you have any doubt about that, STOP and ask for guidance. Make sure you scroll all the way to the bottom. Scroll bars are hidden by default until you actually start scrolling, so you may not realize that you’re not seeing the whole document.

    If the contents of the TextEdit window are as described, close it, then enter the following command in the Terminal window in the same way as before (by copy and paste):

    sudo sed -i~ '11,$d' /etc/hosts

    This time, you'll be prompted for your login password, which won't be displayed when you type it. If you don’t have a login password, you’ll need to set one before you can run the command. You may get a one-time warning to be careful. Confirm. Quit Terminal.

    If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator. Log in as one and start over.

    That will fix the hosts file. There is now a copy of the old hosts file with the name "hosts~" in the same folder as "hosts". You can delete the copy if you wish. Don't delete the file named "hosts".

  • Carolyn Samit Level 10 Level 10 (95,950 points)

    Make sure Gatekeeper is enabled.

     

    Open System Preferences > Security & Privacy then select the General tab.

     

    Make sure either Mac App Store or Mac App Store and identified developers is selected. If that area is grayed out, click the padlock icon to proceed.

     

    OS X: About Gatekeeper

     

     

    If you have Little Snitch installed, that can prevent access to websites.