7 Replies Latest reply: May 14, 2014 3:34 PM by Roger Barre
Roger Barre Level 2 Level 2 (240 points)

I usually have letterhead paper in my printer tray. And everything used to work fine: if I were printing single-sided or duplex, the printer always printed the first page properly, on the side with the letterhead.

 

But ever since I upgraded to Mavericks, it will print single-sided on one side, and page one of duplex printing on the other.

 

If I load the paper face up, duplex printing puts page one properly on the letterhead side.  But if keep the paper face up and print single-sided, it will print page one on the back of the page.

 

Anyone else experiencing this? Anyone have any dieas how I can fix this?

 

Thanks in advance.


MacBook Pro with Retina display, OS X Mavericks (10.9.1)
  • PAHU Level 6 Level 6 (15,710 points)

    Hello Roger,

     

    I just tested your symptom on a Canon MG6150 and it appears to be working fine for me.

     

    I loaded a letterhead sheet face-up into the printers cassette. I then selected to print a single page from TextEdit. The text printed on the correct side.

     

    I then created a second page in TextEdit document and selected to print. From the print dialog I enabled the duplex setting in the Duplex Print & Margin menu of the Canon driver. With the letterhead sheet loaded as face-up, page 2 printed on the blank reverse side first, and then paper was pulled back into the printer and page 1 was printed on the letterhead side.

     

    So can you reply with what application you are having the issue with.

     

    Can you also reply what driver version you are using. I am using v10.89.1.0 which was a recent update. You can check this by opening Printers & Scanners, selecting the MX870 and clicking on Options & Supplies. The General tab will show the version.

  • Roger Barre Level 2 Level 2 (240 points)

    Hi, and thanks for the thoughtful reply.

     

    The driver I am using is v10.84.2.0, which is the latest one available for my printer on the Canon website.

     

    This is occurring no matter what app I use: TextEdit, Preview, whatever,

     

    So as an attempted workaround, I went into Duplex Printing and Margins, and changed left-side stapling to right-side stapling. I get exactly the same results. Nothing seems to fix this except manually taking the paper out and turning it upside down when I want to switch from one-sided to duplex printing.

     

    And it didn't use to be that way.  Hmm ...

  • Roger Barre Level 2 Level 2 (240 points)

    Further info: I just called Canon support, and they had me re-install all the Canon drivers and software. The problem remains.  We couldn't find any setting that is doing this, so they (of course) now say it's an OSX problem. But if it's not happening to others, then I don't see how it can be.

     

    So I'm left with my manual workaround of flipping the pages for duplex printing.  Sigh.

  • greg sahli Level 7 Level 7 (24,925 points)

    Roger,

    (I'd listen to PAHU before anyone at Canon, and look/ask about the newer version)

    Apple has changed the way OS X gets printer drivers. Manufacturers give the most recent drivers to Apple to put on Apple's servers (in theory). OS X maintains an index to drivers on the server as well as those already installed. When you Add a printer, the driver is installed or used.

     

    So, it may be the driver, or, it may be something else wrong/corrupted in your OS X install. There are literally hundreds of individual pieces of software in the printing subsytem, so it's not unimaginable.

  • Roger Barre Level 2 Level 2 (240 points)

    Thanks, Greg.

     

    I certainly take your point, but cannot figure out how to get the newer driver. It's not listed on the Canon website. Perhaps I need to uninstall the priunter from OSX and re-install it. I'll try it ..

  • PAHU Level 6 Level 6 (15,710 points)

    Hi Roger,

     

    Thanks for the reply. Yes, v10.84.2.0 is the latest for your model so I wonder if this version has the issue. I will see if I can locate an older model that uses this driver version and test.

     

    In the meantime, a test for you. Can you select to print your document from TextEdit or Preview and switch to the Paper Handling menu in the print dialog (shown below).

     

    Paper Handling.png

    You can see the entry of Page Order. Automatic is working for me and I would also assume that it is what your driver is currently set to. If you try selecting one of the other settings in Page Order, such as Normal or Reverse, does this help with the letterhead issue?

  • Roger Barre Level 2 Level 2 (240 points)

    PAHU, you're a genius.

     

    Paper Handling: Automatic was giving me the wrong output (the same as reverse). Normal fixed it. So I've now added Normal to my saved pre-set, tried it out with several different apps, and the problem has been solved.

     

    Many thanks.