3 Replies Latest reply: May 18, 2014 11:02 PM by kevin_
FEWLE Level 1 Level 1 (0 points)

Greetings,

 

I have two MacBook Air's in my home and an extremely strong WI-FI network (Netgear Nighthawk AC1900 Smart WiFi, model R7000 with ample cable bandwidth).  For both books I have removed all but the Wi Fi configuration in the "Network" settings page.  This seems to have helped a bit, but when the books sleep for more than few minutes they both lose the signal and I must reconnect them to the network.

 

It is very annoying :-( and no other devices in my home have this issue including my iPhones.

 

Help please!

 

 

Thank you for any advice :-)


MacBook Air, OS X Mavericks (10.9.2)
  • Linc Davis Level 10 Level 10 (173,520 points)

    Test after taking each of the following steps that you haven't already tried. Back up all data before making any changes.

    1. Make sure the network is on the preferred list by following these instructions. It's important to read the article carefully, as it's the starting point for any further efforts to solve the problem. If you skip any of the steps, the problem may not be solved. Make sure the box marked

    Remember networks this computer has joined

    is checked.

    2. Follow the instructions in this support article under the heading

    Symptom: After restarting or waking from sleep, my computer might not connect to the Internet

    3. Reset the PRAM.

    4. Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

    5. From the Location menu at the top of the Network preference pane, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

    6. Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first.

    7. Repair permissions on the startup volume.

    8. Turn off Bluetooth and test.

    9. Reset the System Management Controller.

    10. This step shouldn't be necessary, but has been advised by Apple Support in some cases, apparently as a workaround for a bug. Open the Energy Saver pane in System Preferences. If applicable, click the padlock icon in the lower left corner to unlock the settings. Enter your administrator login password when prompted.

    Select the Power Adapter tab and uncheck the boxes marked

    Wake for Wi-Fi network access

    and

    Enable Power Nap...

    if present. Then, if the computer is a MacBook, select the Battery tab and uncheck

    Enable Power Nap...

    11. Reinstall OS X.

  • Jonathon1312 Level 1 Level 1 (5 points)

    Mine has done that before my solution is to press the power button, then you have three options sleep shutdown and restart click restart then wait for it to load then type in your password and then turn on your wifi and it should stayeven when in sleep.

  • kevin_ Level 4 Level 4 (1,535 points)

    Easiest solution is if you do not use Bluetooth then turn Bluetooth Off.

     

    If you do use Bluetooth then many times running this command in the Terminal will fix it.

     

    sudo defaults delete /Library/Preferences/com.apple.Bluetooth LastA2DPDevice

     

    If neither of these solutions work, there are other more complex solutions that you can use till Apple resolves this issue.