12 Replies Latest reply: May 26, 2014 9:10 AM by dianeoforegon
Rob Hill Level 1 Level 1 (10 points)

Wiped hard drive and installed 10.9 plus 10.9.3 combo updater.

90% of my email accounts cannot connect to their smtp servers.

Created a new user account and setup Mail with an account with the same result.


iMac, OS X Mavericks (10.9.3)
  • dianeoforegon Level 4 Level 4 (3,840 points)

    Open the Connection Doctor under Window in the Menu bar when Mail is active.

    Do you see red or green lights? Click on Show Details for more info if you see red lights.

     

    Most likely you need to re-enter your passwords on both receiving and sending (SMTP servers).

     

    Make sure you are using the latest settings for security.

     

    Check your provider's website for exact info on authentication, SSL and ports.

     

     

        Some ISPs require SSL for receiving

        Most ISPs require advanced settings now for SMTP

  • Rob Hill Level 1 Level 1 (10 points)

    Did all that before I posted.

    Nothing changed in my mail accounts between my last access to my accounts under 10.9.2 and my first access under 10.9.3.

    I am opening Mail with all my accounts and their credentials untouched, except for re-entering the passwords. Validated my credentials by using the webmail accounts.

    Obviously 10.9.3 has broken something.

  • dianeoforegon Level 4 Level 4 (3,840 points)

    Since you are seeing the same behavior in a new User, this is puzzling. Who is your email provider? Comcast.com, Yahoo.com, Gmail.com, iCloud.com Outlook.com etc.

     

    To cover all the bases see:

     

    OS X Mail: Troubleshooting sending and receiving email messages

     

    http://support.apple.com/kb/TS3276

     

    If you wanted to contact me off list, I would be happy to test here on OS X 10.9.3.

     

    http://www.officeformachelp.com/contact/contact-diane/

  • Rob Hill Level 1 Level 1 (10 points)

    Diane, thanks for the offer, but problem solved.

    Reinstalled a clean 10.9.2.

  • dianeoforegon Level 4 Level 4 (3,840 points)

    Glad the re-install of OS X fixed it for you. When the issue happens in a new User it indicates the problem is at the base level. That doesn't always require a re-install of the system but now you know for future troubleshooting.

     

    OS X 10.9.3 came out yesterday. There were a few odd issues where the User's folder is hidden, but easy to work around. However, I do advise you to backup first not only to Time Machine but to a clone backup before updating. This way if you have problems with the update, you can easily revert.

  • Rob Hill Level 1 Level 1 (10 points)

    Thanks for your advice - much appreciated.

     

    I have deep scars when it comes to backup - that's why I have four levels.

    I have been using a strategy to minimise hassles that has worked successfully since 10.1 - I have 2 parittions. The first is where I install the system. I can blow this away at a whim, and reinstall in about 30 minutes. The second partition is where my user directory resides. So when I do a reinstall I always delete the system partition and use combo updates. I then don't need to do a special backup - all my backups are current before I reinstall/upgrade.

    It's also saved me a couple of times when the system crashed on earlier versions of OS 10 corrupting the system partition but leaving the user partition intact.

  • Charmskool Level 1 Level 1 (0 points)

    There is definitely a problem with 10.9.3 and outgoing servers but it's not only in Mail... also Thunderbird. This points to an OSX issue. I have had the same problem on both my MacBook Air and Mac Pro that were upgraded to 10.9.3.  My MacBook Pro however was not upgraded from 10.9.2 and it sends mail fine.  Also seems to only be an issue with my personal domain (Yay) as all my other accounts sent fine:

     

    Gmail

    Hotmail

    iCloud

    Yahoo

  • dianeoforegon Level 4 Level 4 (3,840 points)

    It could be a certificate issue. Make sure your domain certificate is updated.

     

    Open Keychain Access

    Select Certificates

    Look for your host certificate.

     

    For example, my domain is hosted on Hostmonster. I have a hostmonster.com certificate.

     

    The Heartbeat bug recently has resulted in increased security. We see this reflected in OS X 10.9.3 with added security requirements.

     

    As a result you might need a new certificate and to change your passwords and verify you are using the latest mail settings. Since it's receiving that is giving you problems, check under Advanced tab in your Mail > Preferences > Accounts. Do you have SSL checked?

     

    TidBITS: The Normal Person’s Guide to the Heartbleed Vulnerability

  • imabastard Level 1 Level 1 (0 points)

    I had the exact same problem not being able to connect Apple Mail with GoDaddy's SMTP server--after updating to OSX 10.9.3. The problem occured only with attachments--of any size, small or large. Would receive an error message from the server of "(null)".

     

    Changing the port from defaults (25, 80, 465, 587, etc.) to 3535 seems to have fixed the problem. Not sure why. You want to experiment with port options as well.

  • Yellek Level 1 Level 1 (0 points)

    This is quite the conundrum.

     

    I just spent two hours on the phone with a Saint at Time Warner working through the process of transition from POP3 to IMAP. That, was painful enough. However, I have also had the delight of flakey service from OS X 10.9.3. Mail quits at its discretion... even while trouble shooting with the TWC Tech. I stand amazed at the ineptness of Apple's current government of its software. It feels like I am working with Adobe and or Microsoft. They are a work!

     

    Issues that I have experienced within the past week:

    • Mail quits.
    • Mail is sluggish.
    • Mail operates as if it lost DNA.
    • Gmail set up while converting from POP3 to IMAP (one very important account, the minor accounts were less painful) is a major screw job.
    • Outgoing and incoming server issues as stated from others.

    I really do not want to resort tom wiping hard drive and reinstalling the OS or any other software. That is painful.

     

    Come on Apple, you are better than this.

  • MacSingh Level 1 Level 1 (0 points)

    Confirmed.

     

    At my University, I have a locally produced .mobileconfig file that is used to set up network, mail and all other access on a new Mac / Macbook. Further, the University uses a self-signed certificate to authenticate all connections.

     

    Up until 10.9.2, Mail worked normally as it should.

     

    After 10.9.3, Mail works for the imap server (and I can receive email fine) but sending email via the smtp server fails at all times except the ones noted below (read on). Connection doctor says that smtp server rejected authentication and advises me to recheck my username and password (needless to add - they are correct).

     

    smtp connections work if:

     

    1. I delete all Mail accounts.

    2. Use the University-supplied .mobileconfig file to recreate all accounts (LDAP, mail, wifi, etc.).

     

    If however, I close my macbook to sleep it, or change network settings (go from proxied to non-proxied mode, or vice versa - which was never a problem until now), smtp stops working.

     

    Upshot - smtp works only if I delete my accounts everytime I wake up the macbook and redo steps 1 and 2 above. I have taken to saving contents of the outbox to the drafts folder, and then logging in through the webmail interface to actually send the email.

     

    This is nuts.

     

    Apple's engineers need their heads examined if they think that rolling out an inadequately tested update is acceptable.

  • dianeoforegon Level 4 Level 4 (3,840 points)

    Try the following demos. This would determine if it's Mail or something in the OS X 10.9.3 update causing the problem.

     

    Postbox  http://www.postbox-inc.com/

     

    If you have all IMAP accounts, check out the demo for MailMate. It imports all your Mail accounts so there is no setup.

     

    MailMate  http://freron.com

     

    You also might want to test this free option:

     

    Thunderbird http://www.mozilla.org/en-US/thunderbird/

     

    If your problems go away with the other app, be sure to send Apple feedback.

     

    Send Apple feedback:

     

    http://www.apple.com/feedback/macosx.html