Previous 1 2 Next 16 Replies Latest reply: Jun 4, 2014 1:22 PM by bekah99
bowdle Level 1 Level 1 (0 points)

I have just updated to 10.9.3 and my Iphoto, Mail, Photobooth,System Preferences no longer open. When I click on for example,  Mail,  the error message says "You cannot use this version of the application with this version of OSX. You have Mail 4.6".

 

Clearly these apps have missed the updating process (I suspect that is because my son has been dragging the icons around and dropping them in random places). I understand that the apps need to be in the applications folder in order to be included in the update but if I try to drag them in there  I get a message saying that  the "app cannot be modified or deleted because it is required by OS X". Any suggestions please?


iMac (27-inch Mid 2011), OS X Mavericks (10.9.3)
Previous 1 2 Next