10 Replies Latest reply: May 28, 2014 1:38 PM by putnik
multiseven Level 1 Level 1 (0 points)

My office have 6 iMacs. 2 uses ichat and 4 uses iMessage. We don’t have any problems with bonjour communication between 2 ichats but when using the macs with iMessage it is often hard to chat between boniour iMessage to ichat or iMessage to iMessage. The chats sometimes cannot be delivered and often online bonjour friends appear offline.

 

The temporary solution I’m using now is by quitting iMessage and turning it on again. But when the mac goes idle, the problem will appear again.

 

Are there any preferences that I can set on each iMac so that every iMac can chat/send files smoothly? Are there any sharing settings that I should change?


iMac, OS X Mountain Lion (10.8.5)
  • Ralph Johns (UK) Level 9 Level 9 (69,870 points)

    Hi,

     

    Just to be clear.

    The app is Messages once you get to Mountain Lion or above and one of the accounts it can do is iMessages.

    (The app on the iPhone is also called Messages and can send and Received iMessages as well as SMS).

     

    That said on a LAN with iChat and Messages capable machines Bonjour is the way to go.

     

    That said an iMessages account in Messages cannot connect to a Bonjour account in iChat.

     

    I have a Leopard (iChat 4) and a Snow Leopard (iChat 5) and a Mavericks (Messages 8) computer.

    Bonjour as text chats works between all of them.

     

    I  do have however, an issue myself sending files to and from the Messages 8 and iChat 5 computers and nothing I have tried has resolved this.

     

    I do not have another OS X 10.9 machine to compare Messages 8 to Messages 8 with.

     

    Idle is Messages and iChat is a specific thing.

    It is the time after the last Keyboard or Mouse input which then changes the Status  from Available to Idle (it also changes the Away to Away-Idle as well but iChat and Messages do not display this).

    Nominally the Status change is at the 10 minute mark.

     

    This is separate from any Energy Saving settings in the System Preferences or the times set for a Screen Saver to kick in which can be different again.

     

    Could you go into more detail about what you actually mean by idle ?

     

     

    3Sigcopy2.png

    7:43 pm      Friday; May 23, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • multiseven Level 1 Level 1 (0 points)

    Hi Ralph, thanks for your time answering the question.

     

    You are right, the app name is Messages. Sorry for misspelling it to iMessage.

    Like you said.. LAN communication between Messages to iChat is what I want.

     

    And sorry for not so clear at explaining things, what I really meant about idle is the idle time in using the apps, not the computer. This meant I'm still using the computers while Messages is still standby in the background.

     

    Is this app performance related to the settings in System Preferences? Such as "network", "sharing" or maybe "energy saver"

     

    However I also noticed sometime my computer is seen as invisible by the other macs, this makes the other macs unable to "connect" to my mac. My guess is this could be the culprit that is also affecting the iChat/Messages app to run properly. Relaunch the finder will solve the problem, but only as temporary solution because the problem will persist again in some minutes later.

  • Ralph Johns (UK) Level 9 Level 9 (69,870 points)

    Hi,

     

    The AIM account can be set to Invisible.

    Screen Shot 2014-05-26 at 19.06.31.png

     

    The Bonjour one cannot

    Screen Shot 2014-05-26 at 19.07.25.png

     

    My understanding is that one some Laptops you can set Application sleep, as I think it is called, to save power when using the battery.

     

    My iPhoto version has a tick box to prevent it in the Info Panel

    But Messages does not

    Screen Shot 2014-05-26 at 19.20.15.png

    I am not sure if the app has to be capable (i.e. there is an Off option) before it takes effect.

    My iPhoto has it as I said  but I have a iMac  which does not run on battery power.

     

    It would appear that Messages cannot be excluded if it effects all apps - but I don't think it does.

    The upshot of that is that Messages cannot be going Idle on it's own just because it is in the background.

     

    The "disappearance" of you  in other people's Buddy lists seems more to do with losing the network than a setting.

    Ask them if you also go missing from the Finder's side bar as a Bonjour Share.

     

     

    3Sigcopy2.png

    7:42 pm      Monday; May 26, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • multiseven Level 1 Level 1 (0 points)

    Yes, sometimes I dissapear from their Finder sidebar when doing a Bonjour Share.

     

    Is there something I can do to prevent this from happening? I'm sorry if the topic isn't related anymore to Message & iChat. I think maybe this might be the source of the problem that is affecting the iChat or Messages.

  • putnik Level 3 Level 3 (780 points)

    Maybe not the same problem as my inability to connect to the internet on waking the computer, but this too seems to be to do with Bonjour.  If I disconnect my AppleTV or quit iTunes, I have no problem.

  • Ralph Johns (UK) Level 9 Level 9 (69,870 points)

    Hi,

     

    Often a problem can change once we have more info.

    Like this one what seems like a Bonjour In Messages and iChat turns out to be an issue with you staying On line.

     

    Are you connected to the LAN via Wifi ?

    If so do this:-

    In System Preferences> Network > WiFi make sure the option to show the Menu Bar icon for Airport is active.

    Now right click and hold the Menu in the menu bar.

    Select the Network Diagnostics that appears  by doing this.

     

    Screen Shot 2014-05-28 at 19.34.05.png

     

    (Using the ALT whilst trying to grab a Screen Shot also show other details but you wnat the bottom item)

     

    After a dialogue asking for your Mac User Login Password you see this fisrt screen

    Screen Shot 2014-05-28 at 19.35.37.png

    Press continue (it will take a few minutes).

    Make sure the Monitor option is selected and minimise the item to the DOCK.

    Screen Shot 2014-05-28 at 19.37.24.png

    If there are breaks in the connection to the LAN this will tell you.

    Obviously you may have to wait some time for this to happen.

     

    In the mean time check every computer has a different name in System Preferences > Sharing.

    Follow that by checking the Contacts App/Address Book and that all have different info in the My Card.

     

     

    3Sigcopy2.png

    7:41 pm      Wednesday; May 28, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • Ralph Johns (UK) Level 9 Level 9 (69,870 points)

    Hi,

     

    Bonjour (or mDNS as it show in the Activity Monitor) is linked to the DNS actions of your computer.

     

    At OS X 10.6 Apple made a closed link between the action of DNS and Bonjour.

    effectively what had been an ON/Off mechanism in Directory Utility (no longer exists) was done away with in favour or changing a .plist

    http://support.apple.com/kb/HT3789

     

    However as you have Bonjour when you turn some things Off it suggests that either the Apple TV and a computer are trying to use the Same IP or there is something about the Name of each that is causing the issue.

     

     

    3Sigcopy2.png

    8:01 pm      Wednesday; May 28, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • putnik Level 3 Level 3 (780 points)

    Thanks Ralph, My problem is getting an internet connection on wake up first thing in the morning.  It can be solved by disconnecting the AppleTV.

     

    I checked the IP and MAC addresses on the router webpage and they seem discrete and ok.  The computer name has not changed and the AppleTV has no name.

     

    I took a package trace and pinged the router during these periods.  The pings go out ok but the computer never gets a reply.  I have also used wifi diagnostics and scanned the local environment, but think posting the results here may be a security risk.

     

    For academic interest, the commands were as follows:

     

    1. netstat -nralW for the routing table dump

     

    2.packet capture if the above output outgoing interface is en0.

     

    sudo tcpdump -i en0 -w ~/Desktop/tcpdump.pcap "arp || icmp"

     

    3. To ping to the gateway IP address:   ping 192.168.1.254

     

    4. To kill the processes, Cmd + period

     

    The only thing I see in the Share section of Finder is the router. Should I not see the AppleTV as well?

  • Ralph Johns (UK) Level 9 Level 9 (69,870 points)

    Hi,

     

    The Apple TV might not show up if it is not Named.

    Or it may only show up as an icon in the Shares section of the Finder's Side Bar.

     

    If Stealth is on in the Mac Firewall (If that is On) then you will not see Pings.

    Messages will also not do Video, Audio Only or Screen Sharing in AIM and Jabber accounts.

    FaceTime may also not connect.

     

    Also check the router is allowing responses to Pings.

     

     

     

     

    3Sigcopy2.png

    9:32 pm      Wednesday; May 28, 2014

     

      iMac 2.5Ghz i5 2011 (Mavericks 10.9)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad
  • putnik Level 3 Level 3 (780 points)

    Thanks, The pings are normally fine, just not first thing in the morning.  I will turn off Stealth mode and see what happens.

     

    My apologies to the OP for the digression.