8 Replies Latest reply: May 26, 2014 8:01 PM by BDAqua
KC Tom Level 1 Level 1 (0 points)

My G5 tower running 10.5.8 (let's call it "Mac 1") is sporadically inaccessible and then only partly accessible via personal file sharing on my local network (all ethernet).


First, I enabled the checkmark in Accounts / Guest user: "Allow guests to connect to shared folders" (the checkmark above it, "Allow guests to log in to this computer", is unchecked). Firewall is set to its default: allow all incoming connections.


In the Sharing pane of system settings, I enabled three folders on Mac 1 with rights that include read/write for Everyone (I believe this equates to guest access). In the options button of the sharing pane, I have checked "Share files and folders using AFP".


On my newer Mac running Mavericks (Mac 2), I then go to the finder and hit Command-K to bring up the "Connect to Server" pane. I click Browse, and a window appears showing the name of Mac 1, but when I click on it it just says I'm connected as a guest--yet no folder names are shown, and I apparently can't copy to or from the empty file list below its title. When I attempt to drag something into this name-of-computer file list, it says "Modifying "Mac 1" requires an administrator name and password. To move [filename], click Authenticate [and there's an OK button]." Huh? Mac 1 clearly has guest access enabled. I also ran Disk First Aid and hit both repair disk (it said it didn't need it) and repair permissions (it indicated it did fix a few permissions, but it didn't fix this sharing problem).


As a test, I went to yet another G5 (running 10.4) on my network (let's call it Mac 3). It can easily connect to one of the three folders on Mac 1 as a guest, but it can't see the other two folders, which are set up with identical permissions. In addition, the guest-shared folder on Mac 3 is visible and accessible from both Mac 1 (10.5) and Mac 2 (Mavericks). Also, an Airport Express with a hard drive attached has a hard drive that is equally accessible to all three machines, so it appears my network is okay. Any ideas?

Power Mac G5, Mac OS X (10.5.8)
  • BDAqua Level 10 Level 10 (121,165 points)



    In Sharing Pref Pane on Mac 1, have you added the folders there, the Users there, & checked what the Options button says?

    To move [filename], click Authenticate [and there's an OK button]." Huh?

    Have you tried Mac 1's admin credentials there?


    Are the 3 folders in another folder?


    Have you done a Get Info on those Folders, unlocked the lock, used the little gear to Apply to enclosed items?

  • KC Tom Level 1 Level 1 (0 points)

    Thanks for your reply. Yes, Mac 1's file sharing pane clearly shows the three folders (I personally hit "+" and added them one by one), and each has users listed next to them--most importantly the user "Everyone," with full read/write privs. Two of these folders are on the desktop and one is on the root of the startup drive. Each shows the "shared folder" (white on reverse type) up at the top of it when you view it in the Finder. Each folder's "get info" window clearly has a checkmark on "shared folder" (under General Info) and shows the proper share privileges at the buttom.


    As I noted in my original description, In the options button of the sharing pane, I have checked "Share files and folders using AFP". And that's the only thing that's checked there.


    Your expression of surprise ("Huh?") at the error message I described is well-justified! It is an exceedingly odd error message, particularly when it admonishes you to "click Authenticate" but the only button on the dialog message is (as I noted) "OK". The whole sharing situations is very odd in that it shows the name of Mac 1 over under the "SHARED" sidebar (below favorites) in the Finder windows of Mac 2, just as it shows my Airport (correctly) as a shared item. But it indicates only the whole Mac 1 name as the shared item, not the three folders that are shared ON it. And when I attempted to drag a file from Mac 2 into this shared file list window (a Finder window), I get the error message listed earlier, and the file doesn't copy.


    A few days ago, before this sharing started acting really weird, I could in fact log in to Mac 1 from Mac 2 using Mac 1's startup user credentials. (But, of course, I could see the entire hard drive, and what I'm really wanting to do is grant guest read/write access on a few shared project folders. (System 7 did this so easily and reliably--I sure miss it!)) Now, I don't even see how to disconnect Mac 2 from being a (fairly useless) client of Mac 1 as a server. Its icon is not shown on the desktop as a server (though "show servers on desktop" is selected as a Finder pref), and there's nothing on the opened Finder window that shows eject, unmount, or anything else to "break" the connection. I suppose I could just restart Mac 2, but I'm not sure why that would be necessary.

  • KC Tom Level 1 Level 1 (0 points)

    I did restart Mac 2, and upon restart one of the three folders is showing up under Mac 1 (below "Shared items" in the Finder window) as a folder that I can copy to and from.


    It appears (I am very new to Mavericks) that the way Mavericks shows a shared Mac on the network (in a Finder window's left pane) is as the Mac name. When you click it and it opens, you can see the white-on-black "Connected as: Guest" phrase and any shared folders in the file list below it. If you drag something from the Mac you're on to the shared folder, it copies right over. If you drag it to the entire file list window as a whole, it "highlights" (i.e.: gets that blue line around it, indicating you're dragging something into the region), but then kicks u the error message I listed earlier. I guess that makes sense in that this gesture would indicate copying to a computer that you don't as a guest have privileges to put a new item on (outside the shared folder(s)). However, I find it odd that Mavericks even allows this gesture since it's clearly going to end in an error message.


    The mystery of why Mac 1 is allowing Mac 2 to see only one of its three folders remains. There is the factor of the two not showing up on the network being on Mac 1's Desktop (vs. root, for the one that's showing up), but--again, their sharing privileges are all the same.

  • BDAqua Level 10 Level 10 (121,165 points)

    I think a restart should be tried.


    Might try this...


    Safe Boot , (holding Shift key down at bootup), use Disk Utility from there to Repair Permissions, test if things work OK in Safe Mode.


    Then move these files to the Desktop for now...










    Reboot & test.


    PS. Safe boot may stay on the gray radian for a long time, let it go, it's trying to repair the Hard Drive.

  • BDAqua Level 10 Level 10 (121,165 points)

    Is the one folder showing, the one at root?


    Problem might be that Guest isn't alowed to see the Desktop in your User's folder.

  • KC Tom Level 1 Level 1 (0 points)

    My original post mentioned that I had indeed repaired permissions, but I forgot to mention in that recap that I also did a boot-up in safe mode before that.


    However, just now I removed the four plist files you mentioned to the desktop, and rebooted. Same result as before. Only the one on root is showing up.


    Good tip: "Problem might be that Guest isn't alowed to see the Desktop in your User's folder." In the Finder on M1, I did a get info on both the startup user (admin)'s desktop and guest's desktop. On admin, Everyone privs are listed as "custom." On Guest's desktop they are listed as "no access."


    Next logical step: Move one of the invisible folders from desktop to root (which I did AFTER making the folder unshared, just to be safe) and then make it shared again. Voila! It suddenly shows up on Mac 2.


    I suppose I could have changed the guest user's desktop privs to allow read and write, but that would seem to provide more access than I intended. I am assuming from this experiment that guest-shared folders have to for some reason be on root--in fact, this might apply anywhere a shared folder is within another folder. I am more accustomed to the looser (and admittedly less secure) version of folder sharing in System 7, where you could just stick (or make) a shared folder anywhere within the file system, and all that mattered were the privs on that item itself.

  • KC Tom Level 1 Level 1 (0 points)

    As a further experiment, I went ahead and changed user/guest/desktop's "everyone" access privileges to read/write. Then, realizing that alone probably wouldn't work, I checked "shared item" on its get info (which obviously then adds it into the sharing pane). On the bright side, it did not show (from Mac 2) "everything that's on the desktop" of the machine's admin user (doy--the guest hasn't put anything on the desktop--still hard for me to think in terms of multiple users on one Mac). On the other hand, it also didn't show the one guest-shared folder that's still on the desktop--weird. So it would appear there's no way to have a folder on the desktop that's guest-accessible.

  • BDAqua Level 10 Level 10 (121,165 points)

    Good work so far!


    I suspect you're right, folders in any other user's folder are protected.