2 Replies Latest reply: Jun 3, 2014 12:07 PM by rboyle
rboyle Level 1 Level 1 (0 points)

About a month ago I noticed Aperture started to have a hard time processing movies taken with my iPhone.  The thumbnails looked fragmented and sometimes didn't match the actual frames in the movie (like it was pulling an image from another to use as it's thumbnail).  When I clicked on the movies they would play so I didn't think too much about it.

 

Before all movie thumbnails and frames showed up correctly and there wasn't any problems.  But soon I noticed that it started to apply the same effect to all movies in my library. Even to the ones that never gave a problem and were working fine for years.

 

I tried to regenerate the thumbnails manually which worked temporally till Aperture converted it back to a distorted or black frame.  I also tried to repair library, rebuild library and fix permissions.  Nothing seemed to work.

 

Today I noticed that it wasn't reading movie files from my iPhone to import.  The files didn’t even show up.  I tried to use Image Capture and got the same results. They both showed all the photos but when in came to the movie files they just weren't there to select or import.  I launched iPhoto and it seems to be able to see the videos on my iPhone.  And now it turns out that Aperture hasn’t been importing movies from my iPhone for several weeks.

 

I did a erase and reinstall of OSX and Apeture and it's still having the same problem.

 

Has anyone ever had this problem or know what might cause this issue to occur?

Aperture_Problem2.png


Aperture 3, OS X Mavericks (10.9), 3.4 GHZ Intel Core i7 32GB memory
  • swandy Level 2 Level 2 (335 points)

    That is very strange because I am running latest version of Aperture (I assume you are also) and on Maverick 10.9 and don't have this issue. Matter of fact I just attached my iPhone 5 to my iMac to import a video that my daughter took on her iPhone 5 and texted to me. No issues with the thumbnail or playing the video.

    Sorry I could not be more helpful, but I don't think that your issue is actually an "aperture issue".

  • rboyle Level 1 Level 1 (0 points)

    Yes it's definitely a weird issue.  And it turns out it also effected even movies taken when our old iPhone 4S and other movies that have been in the library for 5 years without any problems.

     

    I tried to import the photos into the Aperture library through iPhoto since it was the only application that could see the video files.  But then it gave me an "unrecognizable format" error.  This seems really weird and I'm not sure where the root problem is coming from. I feel like it's missing a codec to support it's own movies.

    Aperture_Problem3.png

     

    I managed to get them off the phone and onto a hard drive.  When I get info on the videos QuickTime and a bunch of other apps can read the movies.  And if I drag and drop them from the hard drive into Aperture it seems to work but not through the import option.