13 Replies Latest reply: Dec 9, 2014 2:13 AM by grantjs
Alcazzar Level 1 Level 1 (0 points)

Hi,

 

since two weeks or so, my icloud email is not able to send any emails any more. I am not sure where this come from and why it happened now...

I tried to change the SMTP server and add some manually, but as already stated somewhere in the web, the icloud SMTP is _not_ listed in the listed of available server. I could imagine that the problem has something to do with my email address ending in "@me.com" and not "@icloud.com", but I do not know where to change all of this..

 

Can someone help? Thanks!


Mac Pro (Late 2013), OS X Mavericks (10.9.3)
  • Alcazzar Level 1 Level 1 (0 points)

    The NFSManager shareware tool says it seems my Mac seems to have a DNS problem (although I could successfully call some web pages in safari..). Could it be that the SMTP server cannot be reached properly. How could  I test and fix this?

  • Alcazzar Level 1 Level 1 (0 points)

    It also happens that email is asking for my icloud password again and again... It seems as if it does not remember it? Has this something to do with the "Extended" mail setting "Authentification => Password" ?

  • Alcazzar Level 1 Level 1 (0 points)

    Btw: My wife on her MacBook has the same problems, but without changing anything on her configuration...

     

    The only thing I could think about is the fact that I got an new DSL Router and needed to configure it from scratch. But as webpages are displayed properly in safari I suppose that the DNS is properly working on my router. And on my mac I setup the router as DNS. That should be fine, right?

  • Linc Davis Level 10 Level 10 (169,395 points)

    Back up all data. Uncheck the box marked Mail in the iCloud preference pane and check it again. Test.

  • Alcazzar Level 1 Level 1 (0 points)

    Hi Linc,

     

    Thanks for the support! But did nit work unfortunately:

    When enabling the mail preference again it says "configuring"... and in mail I was provided one "@me.com" server and one "@icloud.com" server in the list of available server ... I choose the both of them buit it did not help.

     

    Btw:

    Sending email via google works fine ...

  • Linc Davis Level 10 Level 10 (169,395 points)

    Sign out of iCloud and sign back in with the ID you want to use. Try again.

  • Eric Root Level 8 Level 8 (36,825 points)

    Try setting the SMPT Authentification to Apple Token instead of Password. Mail/Preferences/Accounts/iCloud/Advanced.

  • Alcazzar Level 1 Level 1 (0 points)

    Sorry, I already used the AppleToken (Port 993 with SSL)

  • Alcazzar Level 1 Level 1 (0 points)

    Hi Link,

     

    I removed my icloud account and created an new one. I was not able to send a mail because the account did not have a default server assigned a warning says (btw: at this time I could choose between an @me.com and @icloud.com account to be used as sender). I went to the server list and choose the icloud.com server and saved the settings. When I opened the mail draft I could only choose the @me.com server address. The @icloud.com disappeared.... Why is there still an @me.com server in my list ?

  • Alcazzar Level 1 Level 1 (0 points)

    What is also strange: In the @icloud.com account settings of mail I choose the AppleToken as authentification method. But when I try to send the mail via the @me.com server an error message is shown from which I can edit the list of server. When I choose my @icloud.com server the method is set to password ...

     

    I am still wondering where this  @me.com server comes from. Does OS X remember the list of used servers?

  • Linc Davis Level 10 Level 10 (169,395 points)

    Apple still uses the me.com domain for iCloud mail servers. You should not have a choice of servers. If you've completely deleted the account and recreated it, and it still doesn't work, then I suggest you contact iCloud Support. There's a link at the top of this page.

  • Alcazzar Level 1 Level 1 (0 points)

    So finally I called the Apple Support: He could help me as follows:

     

    We set up a hotspot connection from my iphone to my mac. The phone was not in my local WiFi network! Then sending emails from and to icloud worked fine. As my wife had the same problems from her MacBook it could not be a setting of my mac - it must have something to do with my (new, I admit) router, a Speedport W724V from German Telekom. The Support advised to ask them as he did not know the router hardware well.

     

    Short time afterwards he called me again, saying that a colleague of him heard about a whitelist of "allowed SMT servers" that is kept on the Speedport W724V router . I should have a look there.

     

    In fact, the router the mail had issues with, namely "p01-smtp.mail.me.com“, was not listed in that list. After I added it, everything worked fine again. Stupid Telekom I thought. But after a second look, I found the entry "smtp.mail.me.com“ in the whitelist, to Telekom _did_ think about Apple, but Apple decided to use a different SMTP server in the mail app than it used to used. That is stupid, I think.

     

    What is more annoying is the fact that on the page http://support.apple.com/kb/HT4864?viewlocale=de_DE the old SMTP server is the listed as the proper one. I already tried to change the SMTP server in the Mail settings to be either one of the two, but that of course did also not work, as Mail _always_ uses its own icloud server, in this case "p01-smtp.mail.me.com“....

     

    Grrrr....

     


  • grantjs Level 1 Level 1 (0 points)

    Yes, this solved my problem as well. The Speedport W 724V setting is under Internet->E-mail abuse detection->List of allowed e-email servers.