7 Replies Latest reply: Oct 6, 2006 6:41 AM by Andy Kynerd
MetaDesign Level 1 (0 points)

I’m using a dual 2.3 GHz G5, and it’s been working flawlessly since I bought it about a year ago. Until yesterday, I was running OS 10.4.5. Yesterday I upgraded to 10.4.7, and as soon as I booted up after the install, I started having a maddening problem with my computer randomly shutting down. (Not sleeping, but a complete power down.)

At first, the shutdown would happen immediately after powering up; my computer wouldn’t even make it to the blue progress bar. I zapped the PRAM and tried something I found online about unplugging the computer for 15 seconds, then plugging it back in. It now boots up, and I can log in, but the computer still shuts down randomly.

There seems to be no pattern to the shutdowns. I tried taxing the processor by opening and resampling huge Photoshop files while lots of other apps were open, and things were fine. Then it would conk out while I was composing an email.

I’ve heard of this random shutdown problem affecting Macbooks, but I have yet to find anything about G5 towers and OS 10.4.7. Does anyone have any info/advice?

Many thanks.

G5 dual 2.3 GHz Mac OS X (10.4.7) 2.5 GB RAM, 250 GB HD

G5 dual 2.3 GHz Mac OS X (10.4.7) 2.5 GB RAM, 250 GB HD

G5 dual 2.3 GHz, Mac OS X (10.4.7), 2.5 GB RAM, 250 GB HD
  • Mac Medic (be@MacOSG.com) Level 6 (17,290 points)
    Check system.log in your Console application for lines like "Power Management received an overtemp signal. Going to sleep." or "localhost kernel: PowerMac7,3 Thermal Manager: Thermal Runaway Detected: System Will Sleep. You may have a processor(s) overheating and putting the G5 in thermal shutdown.

    Mac Owners Support Group
    Join Us @ MacOSG.com
    ITMS: MacOSG Podcast
     An Apple User Group 
  • MetaDesign Level 1 (0 points)
    Thanks for the advice. I did check the system.log in Console and found the following altert:


    Now, since my computer is just over a year old, and since this problem happened immediately after applying the 10.4.7 OS update, I found it hard to believe that my hardware could be responsible. After 2 days of troubleshooting, I was stumped; after a 2-hour service call, so was Apple tech support. I ended up doing an archive and install back down to 10.4.5, and all is well.

    I tested this issue on other machines running 10.4.7 and had no problems. It seems that the following specific combination of elements triggered the problem:

    • PowerMac G5 dual 2.3 GHz (dual 1.8 machines did not exhibit the same problem)
    • OS 10.4.7
    • Logging in with Open Directory/Active Directory mobile profiles
    • iTunes 7

    Bottom line: if you’re using a dual 2.3 GHz PowerMac with mobile OD/AD profiles, do not update to 10.4.7, and steer clear of iTunes 7, at least until there is a patch update available.

    (And Apple wants to be taken seriously in the enterprise market?)

    G5 dual 2.3 GHz Mac OS X (10.4.7) 2.5 GB RAM, 250 GB HD
  • Nan in San Level 1 (15 points)
    I am having the same issue with my non-dual G5. For the last week, I have unexpected random shutdowns. I checked the console log and there is a line that says
    SMUNeo2PlatformPlugin::initThermalProfile - calilng adjust

    That is the only line that has the word "thermal" in it and I have no idea how to interpret it.

    Another odd thing in the last week - my system seems to be renaming Word docs - giving them names of other files (some are pdfs) but none of which are open at the time. I haven't renamed them either so I have no idea why this is going on.

    Are they related? How shall I remedy each of them?

    iMac G5   Mac OS X (10.4.2)  
  • Andy Kynerd Level 1 (0 points)
    I have a similar problem. Over the last couple of days, my (three-month-old)G5 display goes black and the CPU either starts making this loud clicking noise or it sounds like a plane about to take off. At this point, I press and hold the power button on the CPU until the system shuts down completely. I wait a few minutes before restart, and so far, the system starts back up wihtout any problems. I just checked the system log (after restarting a few moments ago) and found this:

    Oct 5 12:20:42 localhost kernel[0]: PowerMac112ThermalProfile::start 1
    Oct 5 12:20:42 localhost kernel[0]: PowerMac112ThermalProfile::end 1
    Oct 5 12:20:42 localhost kernel[0]: SMUNeo2PlatformPlugin::initThermalProfile - entry
    Oct 5 12:20:42 localhost kernel[0]: SMUNeo2PlatformPlugin::initThermalProfile - calling adjust

    But I have no idea what any of this means. Anyone have any ideas on what could be going wrong? I'm definitely not digging the noises coming out of this thing. Should I be concerned?
  • Andy Kynerd Level 1 (0 points)
    OK, I have to amend that last post. I just did a "test" to observe exactly what's going on and here's what I know:
    System is set to run the screensaver after 15 minutes (and it does so without any problems). Energy saver is set to put the system and display to sleep at 20 minutes. This is where we have the problems. The system appears to go into sleep mode (diplay goes dark), but immediately starts making the awful clicking sound. It continues making this sound until I push the power button on the front of the CPU. Pushing the power button (just once)causes the clicking noise to stop and the system appears to be sleeping normally. After a minute or so, the loud fan noise begins (sounds like the whole thing's about to take off) and continues until I press and hold the power button (force shutdown). So far, these results appear to be consistent.
    I have no clue as to what this could be. As I mentioned, this is a relatively new G5 (three months old) and barely used at that. Any ideas on what I might be dealing with here?

  • MetaDesign Level 1 (0 points)
    If you're seeing anything with "thermal" in the system.log, you should probably take your computer in for service.

    My problem, on the other hand, has never generated any "thermal" system.log entries, just random PMU shutdowns. All this, plus the fact that this problem only happens with OS 10.4.7 and 10.4.8 convinces me that it's software related.

    Very frustrating.
  • Andy Kynerd Level 1 (0 points)
    Well, I called AppleCare, and they had me shut everything down and disconnect all of the cables. After a couple of minutes, I connected everything back up and powered her back on. So far, this seems to have corrected the problem. We'll keep an eye on it...