9 Replies Latest reply: Jun 20, 2014 5:38 AM by mns579
branchport Level 1 Level 1 (0 points)

Hello!

I have a 2006 Macbook running 10.6.8. Recently I was trying to run an older application, which does not work in Snow Leopard, I noticed the problem for running it lied somewhere in the "CoreServices.framework" folder, located in under /Untitled 1 (which is the hard drive)/System/Library/Frameworks/CoreServices.framework

So, I decided I would try to replace the "CoreServices.framework" folder with one from an older computer. Before I got to do this, I made a copy of the Macbook's "CoreServices.framework", placed it in a separate folder, and dragged the original to the trash, (I did not delete it). I figured I could just place back the folder after I tested to see if this worked or not, but foolishly, I did not realize that removing the frameworks for CoreSevices from they're location would mean that the whole system would no longer work at all!

Well, what happened was I tried to import some files, they didn't import. I tried to restart the computer, but it said something like "Finder cannot be quit". From there I tried to relaunch the Finder, the whole screen turned blue as usual, but stayed there with the little spinning circle until the CPU over heated and the fan kicked on, so I shut it off. I turned it on again and the same thing happened, gray screen with the apple symbol and spinning circle until it heated up.


Well, that about sums it up. I moved "CoreServices.framework" from it's location and now the whole system doesn't work!

 

Does anyone have any ideas how I can fix my computer?

Could I use single-user mode, or something similar? I don't know much about single-user mode and how this would be done and I don't want to damage the computer any more then it is now.

 

Thank you all very much in advance!


MacBook, Mac OS X (10.6.8)