Previous 1 2 Next 26 Replies Latest reply: Jun 14, 2014 2:29 PM by ggungor2005
ggungor2005 Level 1 Level 1 (0 points)

I tried every method mentioned about iphoto..then eventually I had to uninstall and reinstall the app at the expense of my archive..How ever iphoto still screws up..It does not respond to any commands..I am using the latest OS X..and just downloaded the app from app store..What is wrong with apple nowadays?


MacBook Pro with Retina display
  • Carolyn Samit Level 10 Level 10 (95,950 points)
  • ggungor2005 Level 1 Level 1 (0 points)

    I tried, but still stops working after a minute..I also tried all other fix options but they were in vain..the apple logo turns into rainbow and whirls till I force quit..

  • Linc Davis Level 10 Level 10 (150,365 points)

    What versions of OS X and iPhoto do you have?

  • OGELTHORPE Level 7 Level 7 (32,700 points)

    I will request that your query be relocated to the iPhoto forum where knowledgeable iPhoto users will be able to assist you.

     

    Ciao.

  • ggungor2005 Level 1 Level 1 (0 points)

    OS X 10.9.3 Iphoto 9.5.1(902.17)

  • ggungor2005 Level 1 Level 1 (0 points)

    Sounds good..Thanks

  • Linc Davis Level 10 Level 10 (150,365 points)
    Back up all data.
      

    Quit iPhoto if it's running. Force quit if necessary.

     
    In the Finder, temporarily move the iPhoto library (usually located in the Pictures folder) to the Desktop. Relaunch the application. It should prompt you to select a library. Click the Create New... button. If a new, empty library is created successfully, try adding an image, such as one downloaded from the web.
       
    After the above test, quit iPhoto again and put the original library back where it was, overwriting the test library. Post your results.
  • léonie Level 9 Level 9 (65,215 points)

    I tried, but still stops working after a minute..I also tried all other fix options but they were in vain..the apple logo turns into rainbow and whirls till I force quit..

    Try to narrow down the problem. It would be good to know, if the problem is caused by your iPhoto library, by settings in your account, or a system wide problem.

     

    • First, try to launch iPhoto with the alt/option key held down. This will bring up the library chooser. Select to create a new iPhoto library.  Does iPhoto freeze on the new library as well?
    • If iPhoto does not work with a new library, test in a different user account.  Is iPhoto working well in the Guest account?

     

    Post back with the results.

  • ggungor2005 Level 1 Level 1 (0 points)

    I did all the work listed by you. The new library does freezes in two situations:

    1. When I tried to upload or add a pic, it starts the importing process that never ends(freezes)

    2. Whenever I activate Icloud in the iphotos tab, the app is locked in 5 seconds and I always apply to force quit.

    First, I thought that my apple account might be the reason and tried to operate new library without activating or linking it to my apple acount. However, whenever I tried to import pic., it freezed.

    Then, I created a new library again and linked it to apple account, and as soon as I did that, the iphoto was locked and freezed.

    I realized that new library not linked to apple account(icloud) works fine without freezing as long as I do not attempt to import a pic. Also, I became certain that the icloud(apple account linking) 100% freezes the app as soon as I click the to Connect to Icloud button under Icloud tab of Iphotos.

    P.S.: Since all my data has already been screwed up by this BS app, I easily erase and create new library without any hesitation. Also, I empty the trash in my every new attemp not to let the library dublicate itself with erazed one.. 

  • ggungor2005 Level 1 Level 1 (0 points)

    In addition to my reply to Linc Davis,

    I tried what you recommended, however I could not test it with a guest account b/c whenever I connect as a guest, the system only offers me safari as a work station. In system preferences under the Users&Groups tab, I tried to change the guest allowences but it did not work. So I could not test it as a guest user.

     

    Update: Just realized that FileVault causes this. So now I am deactivating FileVault. I am not sure but may be the encrypted data might also affect the iphotos. But I am not so much positive about this possibility. I will try the steps you and Linc suggested after the FileVault decrypt my data, and share the results.

    Thanks..

  • Old Toad Level 10 Level 10 (122,270 points)

    Create a test account that's a non-administrative account via the System/Accounts preference pane.  It makes a great troubleshooting tool  Don't add any 3rd party addons to it as you want it pristine.

     

     

    OT

  • léonie Level 9 Level 9 (65,215 points)
    Update: Just realized that FileVault causes this. So now I am deactivating FileVault. I am not sure but may be the encrypted data might also affect the iphotos. But I am not so much positive about this possibility. I will try the steps you and Linc suggested after the FileVault decrypt my data, and share the results.

     

    File vault is know to cause problems with photo libraries - it can interfere with the references between edited versions and original image files.

  • Linc Davis Level 10 Level 10 (150,365 points)

    FileVault should have no effect on iPhoto.

    Launch the Console application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.

    The title of the Console window should be All Messages. If it isn't, select

    SYSTEM LOG QUERIES All Messages

    from the log list on the left. If you don't see that list, select

    View Show Log List

    from the menu bar at the top of the screen.

    Click the Clear Display icon in the toolbar. Then try the action that you're having trouble with again. Select any messages that appear in the Console window. Copy them to the Clipboard by pressing the key combination command-C. Paste into a reply to this message by pressing command-V.

    ☞ The log contains a vast amount of information, almost all of which is irrelevant to solving any particular problem. When posting a log extract, be selective. A few dozen lines are almost always more than enough.

    Please don't indiscriminately dump thousands of lines from the log into this discussion.

    Please don't post screenshots of log messages—post the text.

    ☞ Some private information, such as your name, may appear in the log. Anonymize before posting.

  • ggungor2005 Level 1 Level 1 (0 points)

    The commands below show what I did in an order as follows:

    1. I created new lib.

    2. I tried to add pic.

    3. App freezed and I forced quit

    4. I opened the app again, and activated Icloud(Use Icloud button in the icloud tab)

    5. App freezed and I forced quit.

     

    6/14/14 10:39:53.674 AM com.apple.appkit.xpc.openAndSavePanelService[927]: assertion failed: 13D65: liblaunch.dylib + 25164 [38D1AB2C-A476-385F-8EA8-7AB604CA1F89]: 0x25

     

    6/14/14 10:39:53.835 AM com.apple.appkit.xpc.openAndSavePanelService[927]: Bogus event received by listener connection:

    <error: 0x10dffeb50> { count = 1, contents =

    "XPCErrorDescription" => <string: 0x10dffee60> { length = 18, contents = "Connection invalid" }

    }

     

    6/14/14 10:39:53.837 AM librariand[733]: client process 925 does not have a valid com.apple.developer.ubiquity-container-identifiers entitlement

     

    6/14/14 10:39:53.837 AM librariand[733]: error in handle_container_path_request: LibrarianErrorDomain/9/The client process does not have a valid com.apple.developer.ubiquity-container-identifiers entitlement

     

    6/14/14 10:39:58.359 AM iPhoto[925]: view service marshal for <NSRemoteView: 0x7fe729441960> failed to forget accessibility connection due to Error Domain=NSCocoaErrorDomain Code=4099 "Couldn’t communicate with a helper application." (The connection was invalidated from this process.) UserInfo=0x60000026ee80 {NSDebugDescription=The connection was invalidated from this process.}

    timestamp: 10:39:58.358 Saturday 14 June 2014

    process/thread/queue: iPhoto (925) / 0x117294000 / com.apple.NSXPCConnection.user.endpoint

    code: line 2972 of /SourceCache/ViewBridge/ViewBridge-46.2/NSRemoteView.m in __57-[NSRemoteView viewServiceMarshalProxy:withErrorHandler:]_block_invoke

    domain: communications-failure

     

    6/14/14 10:40:01.138 AM iPhoto[925]: NSProButtonCell: attempt to decode an unrecognized element (0)

    6/14/14 10:40:01.139 AM iPhoto[925]: NSProButtonCell: attempt to decode an unrecognized element (0)

    6/14/14 10:40:01.191 AM com.apple.SecurityServer[14]: Killing auth hosts

    6/14/14 10:40:01.191 AM com.apple.SecurityServer[14]: Session 100030 destroyed

    6/14/14 10:40:01.194 AM com.apple.SecurityServer[14]: Session 100031 created

    6/14/14 10:40:30.126 AM com.apple.launchd.peruser.501[161]: (com.apple.iPhoto.26608[925]) Exited: Terminated: 15

    6/14/14 10:40:30.247 AM UserNotificationCenter[943]: *** WARNING: Method userSpaceScaleFactor in class NSWindow is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.

    6/14/14 10:40:33.633 AM spindump[938]: Saved hang report for iPhoto version 9.5.1 (902.17) to /Library/Logs/DiagnosticReports/iPhoto_2014-06-14-104033_Goktugs-MacBook-Pro.ha ng

     

    6/14/14 10:40:43.028 AM iPhoto[963]: NSProButtonCell: attempt to decode an unrecognized element (0)

     

    6/14/14 10:40:43.028 AM iPhoto[963]: NSProButtonCell: attempt to decode an unrecognized element (0)

     

    6/14/14 10:40:43.083 AM com.apple.SecurityServer[14]: Killing auth hosts

     

    6/14/14 10:40:43.083 AM com.apple.SecurityServer[14]: Session 100031 destroyed

     

    6/14/14 10:40:43.086 AM com.apple.SecurityServer[14]: Session 100032 created

     

    6/14/14 10:41:06.000 AM kernel[0]: The USB device Apple Internal Keyboard / Trackpad (Port 5 of Hub at 0x14000000) may have caused a wake by issuing a remote wakeup (2)

     

    6/14/14 10:41:09.021 AM acwebsecagent[251]: Connection : Auth key is not provided or is invalid, applying connection failure policy. CMode : 2 TMode : 1

     

    6/14/14 10:41:09.021 AM acwebsecagent[251]: OnConnectionFailure : Fail Open - Reason = Unable to verify the license key

     

    6/14/14 10:41:30.727 AM com.apple.launchd.peruser.501[161]: (com.apple.iPhoto.26608[963]) Exited: Terminated: 15

     

    6/14/14 10:41:30.846 AM UserNotificationCenter[974]: *** WARNING: Method userSpaceScaleFactor in class NSWindow is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.

    6/14/14 10:41:33.282 AM spindump[970]: Saved hang report for iPhoto version 9.5.1 (902.17) to /Library/Logs/DiagnosticReports/iPhoto_2014-06-14-104133_...........-MacBook-Pr o.hang

Previous 1 2 Next