2 Replies Latest reply: Oct 18, 2015 6:46 PM by Skywoolf
Skywoolf Level 1 (0 points)

I have about 6 external USB drives that are mostly 1TB or 1.5TB.  I have been trying to copy files from old ones to new ones but if I plug in more than two they keep  unmounting with the message that the drive was not unmounted properly and may now be damaged.  I have two so far that are corrupted.  I have tried three different powered USB hubs thinking it was lack of power but it made no difference.  This problem occurs on my 26" iMac Running Lion and on my new PowerBookPro running Mavericks.


Can anyone please advise what to do.  I am afraid that if I keep pulling plugs in and out to change drives I will end up with damaged USB ports.

  • Skywoolf Level 1 (0 points)

    I have heard others with this problem so I am really surprised none here can help.  My iMac has just crashed for the third time with corrupted disks because of this problem.

    I will try Macfixit or something.  Thanks

  • Skywoolf Level 1 (0 points)

    I found the solution.  The problem was caused by the USB interface on many drives.  Buying better quality cases and interfaces solved the problem.  The drives themselves seem OK