13 Replies Latest reply: Jun 25, 2014 6:00 PM by alaz0
alaz0 Level 1 (5 points)

Long term problem, so far.  iMac, mid2010, Mavericks 10.9.3.  Issue existed in Lion and Mountain Lion.  Under energy saver settings, on boot-up, iMac will go to sleep as programmed.  After a while, it will not go to sleep under energy saver, even with no running programs.  Unplugging wired network, shutting off wireless network -- no help, it's not a network wake up.  Unplugging all USB devices and Firewire disk drives -- no help.  Symantec anti-virus is installed,  and all functions turned off (also this problem existed before anti-virus was installed) -- no help.  Manually setting sleep mode, works fine.    Activity monitor shows exactly the same daemons and programs running when auto sleep works as when auto sleep does not work.


I'm baffled, and don't know what to look for next.  Any advice?  Thanks!

  • Linc Davis Level 10 (184,680 points)

    This procedure is a diagnostic test. It makes no changes to your data.

    Please triple-click anywhere in the line below on this page to select it:


    pmset -g assertions | pbcopy 

    Copy the selected text to the Clipboard by pressing the key combination command-C.

    Launch the built-in Terminal application in any of the following ways:

    • Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)
    • In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.
    • Open LaunchPad. Click Utilities, then Terminal in the icon grid.

    Paste into the Terminal window by pressing the key combination command-V. I've tested these instructions only with the Safari web browser. If you use another browser, you may have to press the return key after pasting.

    Wait for a new line ending in a dollar sign ($) to appear below what you entered.

    The output of the command will be automatically copied to the Clipboard. If the command produced no output, the Clipboard will be empty. Paste into a reply to this message.

    The Terminal window doesn't show the output. Please don't copy anything from there.

  • alaz0 Level 1 (5 points)

    Thank you!  That is a new command for me....  :-)


    6/22/14, 10:51:58 AM EDT

    Assertion status system-wide:

       BackgroundTask                 1

       PreventDiskIdle                0

       ApplePushServiceTask           0

       UserIsActive                   1

       PreventUserIdleDisplaySleep    0

       InteractivePushServiceTask     0

       PreventSystemSleep             0

       ExternalMedia                  1

       PreventUserIdleSystemSleep     0

       NetworkClientActive            0

    Listed by owning process:

       pid 49(hidd): [0x0000000a00000a1f] 00:01:10 UserIsActive named: "com.apple.iohideventsystem.queue.tickle"

      Timeout will fire in 590 secs Action=TimeoutActionRelease

       pid 16(powerd): [0x000000090000012c] 21:02:05 ExternalMedia named: "com.apple.powermanagement.externalmediamounted"

       pid 11(UserEventAgent): [0x0000000c00000365] 11:42:25 BackgroundTask named: "com.apple.metadata.mds_stores.maintenance"

    Kernel Assertions: 0x10c=USB,BT-HID,MAGICWAKE

       id=500  level=255 0x4=USB mod=6/21/14, 1:59 PM description=EHC2 owner=AppleUSBEHCI

       id=501  level=255 0x4=USB mod=6/21/14, 1:59 PM description=EHC1 owner=AppleUSBEHCI

       id=502  level=255 0x100=MAGICWAKE mod=6/22/14, 9:16 AM description=en0 owner=en0

       id=503  level=255 0x8=BT-HID mod=12/31/69, 7:00 PM description=com.apple.driver.IOBluetoothHIDDriver owner=BNBTrackpadDevice

  • alaz0 Level 1 (5 points)

    Additional info.  Prior to following your instructions, I started a anti-virus file scan, as it's been off for a very long time.  I don't think the anti-virus is worth the effort, but thought running it would be a good idea before my subscription ends.  I see no evidence of it in the pmset output that I sent you.


    Thank you again! 

  • Linc Davis Level 10 (184,680 points)

    Was sleep working when you ran the command?

  • alaz0 Level 1 (5 points)

    Energy Saver had sleep turned on for default values (10 min).  When I sat down at the terminal, sleep should have initiated, but didn't, and then I read your message.

  • Linc Davis Level 10 (184,680 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, by a peripheral device, by a font conflict, or by corruption of the file system or of certain system caches.

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards, if applicable. Start up in safe mode and log in to the account with the problem. You must hold down the shift key twice: once when you turn on the computer, and again when you log in.

    Note: If FileVault is enabled, or if a firmware password is set, or if the startup volume is a Fusion Drive or a software RAID, you can’t do this. Ask for further instructions.

    Safe mode is much slower to start up and run than normal, with limited graphics performance, and some things won’t work at all, including sound output and Wi-Fi on certain models. The next normal startup may also be somewhat slow.

    The login screen appears even if you usually login automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

    Test while in safe mode. Same problem?

    After testing, restart as usual (not in safe mode) and verify that you still have the problem. Post the results of the test.

  • alaz0 Level 1 (5 points)

    I didn't think of testing in safe mode either, but it's obvious when you note it.  This is an easy test to do, and I can easily meet the criteria, but as typically automatic sleep work after a reboot, then stops a half hour or more later, it will take time.  I need to leave for several hours, and will try this tonight, no later than tomorrow night, and will report back.  I'm grateful for your help, you've already shown me obvious and not obvious actions -- thank you.  I'll post results as soon as I have them.

  • alaz0 Level 1 (5 points)

    Update:  Booted in safe mode, per instructions.  Launched programs that didn't need network nor peripherals.  Ran for an hour or so, no problem going to sleep.  Rebooted into normal mode, running for about a day.  Sleep mode still working OK.  Let's see what happens in another day or two of normal use.


    If this fixed it, how can safe mode fix anything long term?  It only limits what the computer can do while in safe mode, giving the user a chance to fix problems.


    Thanks!  I'll return tomorrow with an update.

  • Linc Davis Level 10 (184,680 points)

    Safe booting forces some system caches to be rebuilt, and sometimes that's all it takes.

  • alaz0 Level 1 (5 points)

    Great -- it never ceases to amaze me that no matter how much experience one may have, there are always fundamental things to learn....  If sleep mode continues to work through this evening, I'll mark this as fixed.  Back to this thread tonight -- thank you!

  • alaz0 Level 1 (5 points)

    The conclusion is that this problem is resolved.  Apparently, the reboot to safe mode and back was the key to this issue.  The iMac now falls asleep properly, and gets woken up by key stroke or network call, just as it should.  Linc, thank you very much for your help and persistence; I will repay that to the next guy.  - Andy

  • Linc Davis Level 10 (184,680 points)

    I'm not sure you won't have a recurrence. If you do, I suggest you uninstall the Symantec product according to the developer's instructions. In fact, you should do that anyway, since it's worse than useless. All it will ever do is slow down and destabilize the computer. It will never protect you from any real threat.

  • alaz0 Level 1 (5 points)

    I bought Symantec to help debug a problem last August; it didn't help.  I agree with your assessment and advice.  Done.  It's gone today.  Thanks..