Previous 1 2 Next 16 Replies Latest reply: Jul 12, 2014 2:15 PM by brakka
ktadimeti Level 1 Level 1 (0 points)

Hello,

 

I recently updated my OS to 10.9.4 and started getting some Internet problems after the install. Before the update, my Internet was working fine, but afterwards, my browsers (Safari and Chrome) started restricting website access. Now, I can only access sites associated with Google (google.com, youtube.com, etc.). I can input searches into Google, but I cannot access any of the URLs upon clicking them.

 

When I try to access the non-Google web pages on Safari, I get a blank white page (the loading bar is already full by then). When I try to access the same non-Google web pages on Chrome, I get a "No data received" error. The error code on Chrome is  "Error code: ERR_EMPTY_RESPONSE". I can access mail through the built-in mail application, and Network Diagnostics has repeatedly told me that I am connected to a functional Wi-Fi and that my Internet should be working properly, so I know that I am connected to a functional router. I have already tried clearing the DNS cache, but nothing's changed. I see that port 80 is open, so I know http is working.

 

To make sure that this isn't a router problem, I've tried to connect to non-Google sites on my home network and work network (both on different routers) but got the same result on both.

 

Can someone please help me out and tell me what they think might be wrong with my network connection?

 

Thank you.

  • perayos.s Level 1 Level 1 (0 points)

    I have this problem too.

     

    only access website with "https". have problem with "http"

  • ktadimeti Level 1 Level 1 (0 points)

    I just tried accessing some of the "non-Google" websites and saw that if they do have the appropriate certificates (aka they're https), then only do they load. I tried looking through Safari preferences to see if there was a security setting that was preventing access to http websites, but I couldn't find it.

     

    I guess you and I are in the same boat then.

  • ktadimeti Level 1 Level 1 (0 points)

    I also forgot to mention that I booted into Safe Mode and had full access to all http and https websites. Since Safe Mode blocks startup applications, I had a look at the startup applications that were running on my account, and I here's what I have:

     

        - Dropbox

        - SpeechSynthesisSever - for telling when the hour rings

        - ESET Cyber Security (Anti-virus)

     

    I don't think DropBox would be blocking internet access and SpeechSynthesisServer should not be blocking access (since I've had it running even before the software installation, but for that matter, I've had all these applications running on startup before the installation and they haven't been causing any problems), so I disabled the real-time interface of the antivirus system. Unfortunately, nothing's changed.

     

    Could this be due to something that isn't within the startup? I don't know. I'm open to suggestions.

  • perayos.s Level 1 Level 1 (0 points)

    After read your analysis, I tried disable "Web Shield" in my Avast antivirus then I can connect to http website again.

     

    Same as you, Avast has been installed on my Mac before the problem pop up.

     

    Anyway, thanks for your comment. I am now can access an internet, with zero security.

     

    Hope apple can fix this soon if new patch 10.9.4 cause this.

  • John Galt Level 8 Level 8 (41,460 points)

    Hope apple can fix this soon if new patch 10.9.4 cause this.

     

    Apple cannot fix problems they did not create. Eset and Avast are capable of doing nothing beneficial and can only cause problems. Uninstall it and determine if the problems subside.

     

    Use Avast's uninstaller, which will remove it completely. Eset requires using the uninstaller included with its downloaded installation program (see screenshot):

     

    Unknown.png

     

    Eset will also require manual techniques to uninstall components its uninstaller leaves behind, a common characteristic of poorly written software.

     

    I am now can access an internet, with zero security.


    It's a common misconception that you have "zero security" without junk such as Eset or Avast. OS X already includes robust protections against viruses and malware. Use your Mac the way it was intended to be used - without burdening it with useless garbage.

  • ktadimeti Level 1 Level 1 (0 points)

    I haven't had issues with ESET's security system, so I don't see why issues would arise now. I've already tried disabling its real-time interface and changing its settings, but I haven't seen anything fruitful come out of that, so I don't think that the issue has something to do with the security application. I think the issue might have something to do with my network configuration. I've renewed my DHCP lease multiple times, so I don't think it's a problem with accessing the gateway or with any sort of IP problem.

  • cdv2007 Level 1 Level 1 (0 points)

    I have similar problems. After the 10.9.4 update Mail could not access any mail server. Internet was working, Safari was OK. Tried the 10.9.4 Combo update and that solved the problem until I shutdown. Next start took a long time and then Mail had the same problem. Did another Combo update and Mail is OK. Afraid to re start though. I use Intego Net Barrier.

  • joefromparkcity Level 1 Level 1 (0 points)

    I had the same issue but it occurred prior to me updating to 10.9.4. I thought that might fix it so I updated with same results. Could access internet in safe mode but not normal mode. Saw your post about Avast Web shield, disabled it and everything works fine.

  • davek4n6 Level 1 Level 1 (0 points)

    Confirmed - once disabling Avast! webshield, access to the interwebs comes back. Not clear on the conflict... and if someone has a resolution, please let me know

  • jfromelmgrove Level 1 Level 1 (0 points)

    I'm having similar issue but not using Avast! I have Kaspersky. I think this update was trying to solve the cannot connect to wireless after waking from sleep mode. But I think it just made it somewhat worse. Hopefully someone from Apple can help figure this out.

  • joefromparkcity Level 1 Level 1 (0 points)

    So you disabled and issue resolved?

  • John Galt Level 8 Level 8 (41,460 points)

    Kaspersky is equally worthless.

     

    The reason people continue their attempts to use such garbage on Macs after all these years continues to elude me.

  • jfromelmgrove Level 1 Level 1 (0 points)

    If that is the case John G, what sec soft do you use?

  • John Galt Level 8 Level 8 (41,460 points)

    Everyone's needs are different, and in my case I have Macs in three different US states, some of which are running 24/7. I also travel a lot and use public Wi-Fi networks on occasion, sometimes outside the US. All of them contain sensitive, proprietary information that could result in criminal prosecution if it were to be publicly released.

     

    Not everyone's requirements are that extensive, but I don't use anything other than what is already incorporated in OS X. A more secure consumer-grade computer operating system doesn't exist, and no third party product improves upon what it already does. There are no large corporate or educational deployments of Macs or iOS devices with which I've been affiliated that use Kaspersky, Avast, or any other ill-conceived trash. Their market strategy is to exploit the uninformed through any means necessary, primarily fearmongering, deception, or outright lies. It's an effective strategy, one not at all limited to the software market.

Previous 1 2 Next