6 Replies Latest reply: Dec 31, 2015 11:33 AM by etresoft
GvilleMills Level 1 (0 points)

Hello community,

 

I'm a student so don't have much experience programming in PHP much less on localhost.

with that been said, I have developed an email form with html5 and PHP that is been hosted on mylocalhost. When I tested, send email, I'd get the message(page) of confirmation but emails never make it to the inbox.

 

I have researched this for several days and have tried most of the recommendation I have ran into but still doesn't work.

My understanding is, it has to do something with php.ini.

 

Can someone guide me on how to resolve this issue please.

 

by the way I'm on MacBook Pro and running Mavericks OS

 

Thank you in advance....

  • etresoft Level 7 (27,813 points)

    That's not for the faint of heart. If you want to try, here is my user tip for setting up a local mail server: Local mail server for OS X

  • GvilleMills Level 1 (0 points)

    hello etresoft,

    thank you for helping...

     

    I am trying to follow your post on the link posted above. This is what i have done so far.....

     

    when I inputed this command in the terminal "make oxp SSLDIR=/usr SSLCERTS=/System/Library/OpenSSL/certs" a message popped asking me to install Xcode, which I understand its needed so I installed.

     

    I created a place to store the server:

    sudo mkdir -p /usr/local/libexec

     

    Copied the server into place:

    sudo mv ipopd/ipop3d /usr/local/libexec

    Here, I get the following message:

    mills$ sudo mv ipopd/ipop3d /usr/local/libexec

    mv: rename ipopd/ipop3d to /usr/local/libexec/ipop3d: No such file or directory

    mills$

     

    What am I doing wrong???

     

    P.S.

    in command lines i.e.:

    "Load the launchd config files:

    sudo launchctl load -w /Library/LaunchDaemons/edu.washington.pop3.plist"

    Does the commands need to be entered just as it states or the /edu.washington.po3.... needs to be modified???


    Thank you again for your help

  • GvilleMills Level 1 (0 points)

    By the way, when entered the command

    mills$ make oxp SSLDIR=/usr SSLCERTS=/System/Library/OpenSSL/certs

     

    I got this message. Is this an okayed message?

    make: *** No rule to make target `oxp'.  Stop.

  • etresoft Level 7 (27,813 points)

    I wasn't kidding above. If the commands in that User Tip don't make perfect sense, don't attempt them. You might want to try this instead: http://cutedgesystems.com/software/MailServeForMavericks/

  • VinceDaVinci Level 1 (0 points)

    Hi,

     

    I read your tips Local mail server for OS X .

    (mac os 10.40.11) it worked fine until (having done the previous instructions change Label to edu.washington.pop3s.plist)

    launchctl load -w /Library/launchDaemons/edu.washington.pop3s.plist

    I get this message:

    missing the Label key: /Library/launchDaemons/edu.washington.pop3s.plist ( I DID PUT THE LABEL edu.washington.pop3s.plist)

    Nothing Found to load.

    Any ideas why this isn't get throught?

    thank you,

    V

     

  • etresoft Level 7 (27,813 points)

    You would have to paste the contents of your plist file. Without that, we just have to take launchctl at its word.