5 Replies Latest reply: Oct 12, 2014 10:12 AM by BDAqua
Pat Schaefer Level 1 Level 1 (105 points)

Am thinking of finally migrating from eMac to something newer.

 

Migrated out of my eMac hard disk a long time ago,

Now am using OS X 10.5.8

booting from a 1 G Seagate external drive

Drive also has a Mac 9.2, OS X 10.3.9, and OS X 10.4.11 bootable partition.

 

Choices?

PowerMac - too much

laptops - not my style

iMacs - mehh

 

So that leaves me with a mini system.

upgrade the RAM

add the Thunderbolt display.

 

Boot it up to get it running,

then plug in my 1 G external disk

and option boot into my current sytem

That should work right? everything except the Mac 9.2 partition.

 

Of course, I will move on but want to set up link to past.

 

Have a few external drives,

miss my floppy, cd, zip disk, dvd, dual layer dvd.

So obviously I am thinking of adding a blue ray burner for data backup.

Want to have all my photos on one(ish) disk.

This should work on my new mini setup right?

plz not interested in debating cloud storage etc.

 

Finally, will my emac USB keyboard and mouse work with the mini?

 

OS X 10.5.8.

  • lllaass Level 10 Level 10 (160,565 points)

    Any OSX version prior to Mountain Lion will not work on the current, late 2012 MIni.

  • Pat Schaefer Level 1 Level 1 (105 points)

    So I can't go backward only forward.

     

    So that would leave out Macmini4,1 on

    as Macmini4,1 came with 10.6.3 Snow Leopard (6/2010)

     

    And best would be used Macmini3,1 (early 2009)

    which came out with 10.5.6 Leopard.

    which I could still upgrade to OS x 10.9 Mavericks.

     

    all according to wiki for what that's worth

     

    So back in the day I bought this eMac

    (last of the dual boot macs i.e. Mac 9.2 and OS X 10.xx)

    to save access to Mac 9.2.2

    (which of course did not really use)

     

    But today, I can only save my current system 10.5.9

    leaving the past partitions behind

    by finding and buying a 5 year old mini.

     

    What's the line

    I am getting too old for this sh...t.

  • BDAqua Level 10 Level 10 (120,055 points)

    A mini running 10.6.x should be able to Migrate the data & such from a 10.5.x mac.

     

    There are caveats migrating from PPC to Intel, I had no problems, but see Kappy's fine/detailed "A Basic Guide for Migrating to Intel-Macs"...

     

    https://discussions.apple.com/docs/DOC-2295

  • Pat Schaefer Level 1 Level 1 (105 points)

    Tried to give you helpful point but turns out I am broke : (

     

    I am on the other side

    "new" - Early 2009 mac mini

    "new" -apple refurbished cinema monitor

    old - keyboard, mouse, epson scanner, la cie dvd burner, several external hard drives with various connectors

     

    Mac OS 10.6.8 on mini hard dive

    la cie 1 Tb external hard drive, 3 partitions: Mac OS 10.9.5, Mac OS 10.6.8, non bootable partition

     

    PPC applications work with Rosetta on Mac 10.6.8 (last call for Rosetta and PPC apps)

    Many applications migrate to Mac OS 10.9.5

     

    For PPC to Intel migration

    migration assistant not so good

    Kappy comes up spades! Yeah!

    After migrated to one volume used CCC Carbon Copy Cloner

    to duplicate everywhere else

    as PPC 10.5.8 > Intel 10.6.8 ok but no luck going directly to Intel 10.9.5

     

    planned to go PPC 10.5.8 to Intel 10.5.8 but after some thought proved unnecessary 10.6.8 better

     

    Yosemite will probably be my last update

    but such is life at the trailing edge.

  • BDAqua Level 10 Level 10 (120,055 points)

    Thanks & good luck!

     

    OSXwhy holds no benefits for me, if I ever buy another Mac it'll have to run 10.6.8 or less.