12 Replies Latest reply: Jul 14, 2014 11:57 AM by BDAqua
LangMurf Level 1 Level 1 (15 points)

At my father-in-laws. Just updated his ISP (Road Runner/Time Warner) plan to 20Mbs down / 2 Mbs up.

 

MBP 2010, wireless, is getting the right speeds with much lower latency.

 

The PPC is getting >10Mbs down but is close to 2Mbs up. (Just ran the RR speed test on the PPC and got <4Mbs down...)

 

Latency on the PPC is in the three digits... just got 226ms.

 

PPC is 800Mhz, PowerMac3,5 with 1GB RAM, 74GB hd with 60GB's free.

 

Just tried the RR speed test on the PPC again and got 11down/2up with 142ms latency.

 

I know the throughput is going to vary, but the latency seems way too high.

 

Here are the network settings in System Preferences:

 

TCP/IP:

IPv4 is using DHCP and getting address from router

IPv6 is turned off

 

DNS Servers:

209.18.47.61 (assume these are RR DNS servers)

209.18.47.62

Search Domains: ec.rr.com

 

WINS:

Just has Netbios name

 

Appletalk:

Inactive

 

802.1X:

totally blank

 

Proxies:

Nothing chosen

Bypass proxy settings for these hosts and domains: *.local, 169.254/16

Use Passive FTP Mode (PASV) is checked

 

Ethernet:

Configure: Automatically

Speed: 100baseTX

Duplex: full-duplex, flow-control

MTU: Standard (1500)

 

TIA for any and all suggestions!

 

Lang

  • BDAqua Level 10 Level 10 (119,875 points)

    The QS 2002/800 is 802.11b only...

    The theoretical peak bandwidth of an 802.11b wireless connection is 11 Mbps.

     

    The typical peak throughput (sustained data rate) of an 802.11b wireless connection under ideal conditions for end user data is roughly 4-5 Mbps. This level of performance assumes a wireless client in very close proximity (within a few meters) of the base station or other communication endpoint. Due to the distance-sensitive nature of Wi-Fi signaling, 802.11b throughput numbers will decrease the client moves further away from the base station.

    http://compnetworking.about.com/od/wirelessfaqs/f/maxspeed80211b.htm

  • LangMurf Level 1 Level 1 (15 points)

    BDAqua:

     

    The Power Mac in question is not using wireless... it's wired directly into the router. The wireless computers here are getting the advertised speeds. There's something throwing the latency off on this Power Mac; I think the latency is the root cause for the slow speed, but I am no networking SME, so I've no clue where to start to try and isolate the cause of the latency. I turned off IPv6 and disabled Airport but those are the only two things I've done thus far.

     

    Thanks for the response; much appreciated!

     

    Lang

  • BDAqua Level 10 Level 10 (119,875 points)

    Can't see your last post until I post something, a not infrequent problem here.

  • BDAqua Level 10 Level 10 (119,875 points)

    Ah, In System Preferences>Network>Ethernet>Ethernet tab, try experimenting eith Manual & Full Duplex, Half Duplex, 10BT, etc.

     

    Also...

     

    Open Network Utility in Applications>Utilities>Info tab, select Ethernet & what is the Link Speed & are there any Errors/Collisions on the right?

  • a brody Level 9 Level 9 (64,300 points)

    The only reason to use Netbios is if you are networking with Windows machines.  Alternatively you can use FTP temporarily so you don't have the overhead of Netbios.

  • LangMurf Level 1 Level 1 (15 points)

    BDAqua,

     

    Tried all the different ethernet settings. No setting affected the triple digit latency.

     

    There are no send or recv errors but there are collisions. Sent packets: 159055, Recv packets: 293565, collisions: 2951

     

    Thanks again for your suggestions; much appreciated!

     

    Lang

  • LangMurf Level 1 Level 1 (15 points)

    a brody:

     

    The netbios name looks like it's self derived by the OS. It's greyed out; I can't change it. There are no workgroups or WINS servers listed.

     

    Thanks,

     

    Lang

  • BDAqua Level 10 Level 10 (119,875 points)

    Not too bad on the collisions actually, generally caused by more than one device using the Modem/Router, more info in last post here...

     

    http://www.mactalk.com.au/11/27451-network-utility-question.html

     

    In Network Utility?Ping tab, what do you get for google.com ?

    Ping has started ...

     

    PING google.com (173.194.33.0): 56 data bytes

    64 bytes from 173.194.33.0: icmp_seq=0 ttl=56 time=40.124 ms

    64 bytes from 173.194.33.0: icmp_seq=1 ttl=56 time=54.994 ms

    64 bytes from 173.194.33.0: icmp_seq=2 ttl=56 time=95.056 ms

    64 bytes from 173.194.33.0: icmp_seq=3 ttl=56 time=79.983 ms

    64 bytes from 173.194.33.0: icmp_seq=4 ttl=56 time=69.590 ms

    64 bytes from 173.194.33.0: icmp_seq=5 ttl=56 time=54.573 ms

    64 bytes from 173.194.33.0: icmp_seq=6 ttl=56 time=79.509 ms

    64 bytes from 173.194.33.0: icmp_seq=7 ttl=56 time=74.804 ms

    64 bytes from 173.194.33.0: icmp_seq=8 ttl=56 time=59.272 ms

    64 bytes from 173.194.33.0: icmp_seq=9 ttl=56 time=59.082 ms

     

    --- google.com ping statistics ---

    10 packets transmitted, 10 packets received, 0% packet loss

    round-trip min/avg/max/stddev = 40.124/66.699/95.056/15.239 ms

     

    Oh, might try an MTU of 1492 Bytes.

  • LangMurf Level 1 Level 1 (15 points)

    BDAqua:

     

    Changing the MTU from 1500 to 1492 appears to have "done the trick." Speed tests show much better latency and throughput.

     

    Thank you so very much for hanging in there and offering your expertise in fixing this problem; much appreciated!

     

    Lang

  • BDAqua Level 10 Level 10 (119,875 points)

    Great to hear, thanks Lang!

  • LangMurf Level 1 Level 1 (15 points)

    Is there no way to mark your post as an answer? The "Like" link?

  • BDAqua Level 10 Level 10 (119,875 points)

    There's "Like", which isn't all that useful here, then there should be a way to mark any reply as Solved, and or up to 2 Helpfuls.