4 Replies Latest reply: Jul 23, 2014 2:23 PM by gilly31
gilly31 Level 1 Level 1 (0 points)

iPhoto locked and will not open with password.


iMac, OS X Mavericks (10.9.4)
  • Old Toad Level 10 Level 10 (121,415 points)

    iPhoto doesn't have a password feature. With the amount of information you've provided it's impossible to offer a solution.  We can't see your computer so we need to know the details of your problem and setup, i.e.:

    • what version of iPhoto are you using?
    • what system version are you running?
    • what do you see when iPhoto opens? Can you post a screenshot of the message?
    • what fixes have you tried?
    • where is your library located?
    • did you apply any updates or upgrades just prior to the problem occurring?
    • are you running a "managed" or "referenced" library?

              iP11advprefs.png

    • what type of Mac?
    • how much free space on your boot drive?

    OTsig18.png

  • Terence Devlin Level 10 Level 10 (128,910 points)

    Guessing here but:

     

    Couple of things to try:

     

    Restart your mac and try launch iPhoto again.

     

    If that fails:

     

    Go to your Pictures Folder and find the iPhoto Library there. Right (or Control-) Click on the icon and select 'Show Package Contents'. A finder window will open with the Library exposed.

     

    Look there for a file called ‘iPhoto’Lock.data or similar. Drag it to the Desktop. Make no other changes. Start iPhoto. Does that help?

     

    If not: Where is your iPhoto Library stored? If it's on an External Disk, what format is that?

  • léonie Level 9 Level 9 (63,990 points)

    What do you mean by "locked"?

     

    Do you get the error message "The iPhoto library is locked, on a locked disk or you don't have permission to make changes on it"?

     

    Or are you seeing a "Lock" icon on the library?  Where are you trying to enter a password to "unlock"?

  • gilly31 Level 1 Level 1 (0 points)

    Hi. Yes the error message iPhoto locked and required password to repair/unlock. Tried a couple of times and still no joy.

    Have now fix iPhoto had to use finder to move file to desk screen, then remove and redownload iPhoto then drag and drop on to new download. This has

    not lost any pictures and working fine.