3 Replies Latest reply: Jul 26, 2014 9:35 AM by BDAqua
MJHall30 Level 1 Level 1 (0 points)


I have a Mac book Pro running 10.5.8 OSX.  I'm trying to use Time Machine (need to replace the hard drive), and I bought a 1TB Toshiba portable hard drive.  I read the instructions on the drive, which say that to use Time Machine, I'll need to reformat the drive as an HFS+.  I found instructions to do that through Disk Utility --> Erase, with selecting Mac OS Extended from the Volume Format option.  However, I keep getting the following message:  "Volume erase failed.  Could not unmount disk."  I'm new to most of this, and have no idea what unmounting the disk is, much less how to resolve this.  I found a thread that said to check my computer's name, which I did, but that didn't seem to help.


MacBook Pro, Mac OS X (10.5.8)
  • Loner T Level 6 Level 6 (8,825 points)

    If the Toshiba shows up in Disk Utility, you should be able to erase it. What is the error message you get when you try an erase? Make sure you are not trying to erase your OSX installation because it is mounted and such an operation will fail.

     

    A Disk Utility screen shot may also help. If not possible, can you provide the output of diskutil list from the OSX terminal with the Toshiba connected? Please remove any personal information like serial numbers, etc.

  • MJHall30 Level 1 Level 1 (0 points)

    I got it to work - ejected the drive and noticed that it had two instances open.  Once I ejected both, then everything worked fine.  I think I had tried the erase on both the drive and the secondary listing, which was really confusing. 

  • BDAqua Level 10 Level 10 (120,335 points)

    Likely where that second "Drive" came from, but may be gone now...

     

    In Finder's Menu, select Go menu>Go to Folder, and go to "/volumes". (no quotes)

     

    Volumes is where an alias to your hard drive ("/" at boot) is placed at startup, and where all the "mount points" for auxiliary drives are created for you to access them. This folder is normally hidden from view.

     

    Drives with an extra 1 on the end have a side-effect of mounting a drive with the same name as the system already think exists. Try trashing the duplicates with a 1 or 2 if there are no real files in them, and reboot.

     

    If it does contain data...

     

    http://support.apple.com/kb/TS2474