1 Reply Latest reply: Jul 29, 2014 1:34 PM by BDAqua
01Marshea Level 1 Level 1 (0 points)

I tried to update my Leopard software from 10.5 to 10.5.8, but it's giving an error message that the package cannot be validated


iMac, Mac OS X (10.5)