2 Replies Latest reply: Aug 2, 2014 9:39 AM by BDAqua
Filly7003 Level 1 Level 1 (0 points)

SO I'm having an unusual situation here and after spending 3 days researching everything on the internet and trying multiple solutions I can't seem to figure out what is wrong. *Do note, I have a general understanding of computers as machines... I get how and why they work, how to swap things in and out with some online guidance... What goes on tho in the inside of them, well thats where my knowledge generally starts. mechanically inclined, not software inclined.


Situation: I have been using a late 2008 MB with great success since I got it new. Upgraded the HD to a 750 hybrid drive about 1.5-2 years ago because I needed more space and speed and upgrade the RAM to the max 4 gb (2/2) I could do. Eventually got to the point when my photography work was taking way to slow and felt the need to upgrade to something with some power. Was going to go with a new MBP, but the price worried me, didn't like the fact that with a Retina models it was near impossible to upgrade, and overall wasn't very impressed. So I made the choice to search used, take my time, research. Found a 2012 MBP 750gb 8gb ram model a high school kid was selling for a very decent price. Took the plunge. Naturally we meet some place I could test the machine, everything ran fine. Whole thing had been cleaned, everything worked fine, battery was in good condition, ran disk utility to check the HD and everything. Looked like a decent machine. The kid had installed a Beta of Yosemite on, but I didn't care. I was simply going to migrate my old mac into the new one, keep the life going. SO I thought...


Issue: Got the new machine home, ran migration assistant and plugged my old machine into via ethernet and let it do it's thing. About halfway into the process the new MBP Shut down... No clue why. This then lead me to restart the machine, BUT it wouldn't load anything.... Which has started me down this road of pain I am in. I've been using everything from boot disk.


I started booting the computer in internet recovery mode (Command+R) and tried reinstalling the OS.. Naturally the computer was confused when it tried to download Yosemite and wasn't available in the App store to verify... Had to create a boot drive on a thumb drive to boot Maverick and installed Maverick.. Had a world of trouble doing so... eventually got it to work.


From there I ran into another problem.. once the OS was installed, updated, and yes my old machine is updated too, I tried running migration assistant again, this time from my time machine.... would run for awhile, about halfway status bar... then jump to the end, then a few minutes later black.... turned it back on... would sit at the main logo and just spin..


Would try internet booting (Command+R) and check disk utility.. said only 47.38 gb would be on the HD (This number appeared frequently when it would stop). I erased the HD, reinstalled OS and Migration Assistant again... Same issue.. Some research lead to try this route then after multiple failed attempts... Would have to reinstall OS, then in MA I would transfer just the network and computer settings... then transfer just the applications... then the data... do each check box one at a time... Worked all fine until I'd transfer the data... again the HD in the new MBP would stop and time out and close... restart in internet recovery and said only 47.38 was being used...


I erased the HD and tried a few more times, each time using disk utility to verify and repair the disk... always sayings its fine... no luck.. I thought maybe lets scrub the whole thing.. did security level one... with all the 0000's... It would run about a 1/3 into the process and then deliver an error message.. said it couldn't finish...


Is it a possibility that the HD in the new MBP is bad, but disk utility won't notice it? I plan on removing the current hard drive in my new MBP 2012 and putting my older faster hybrid drive into it which I have in my 2008 MB... but I want to make sure the data is secure on the new machine first before I do that.


Does anyone have any advice?


I'm currently in the process of cloning my 2008 HD onto a external as a bootable drive and trying to boot the 2012 MBP from that... use it to play around with and see if I can get it to work, but I don't feel it will because the hardware has changed greatly... Maybe try booting off the cloned external, reinstall OS with the new drivers??? and run the computer that way..


If that works maybe then try cloning the HD on the 2012 MBP from the external? Or just remove it and clone the external to my hybrid drive after I put it into the 2012 MBP?


I know it's a lot to read haha just trying to give all the details and get this **** thing to work. It's been 3 days of trying because each step takes an hour to 5


Thanks for the help everyone!

MacBook Pro, OS X Mavericks (10.9.4), also 2008 MB running same OS