7 Replies Latest reply: Aug 6, 2014 6:31 PM by Brave114
Brave114 Level 1 (0 points)

I recently had my iPone 4S (IOS 7.1.2) completely reset at the Apple store, and all my appointments in Calendar were erased from my phone and the Cloud. I am in the process of re-entering them. However, when I do, I can only see them if I click "all gmail" under Calendar. I do not want my reminders to go to my work gmail, or any of my email, for that matter. Does anyone know how I can fix this? Thank you.

iPhone 4S, iOS 7.1.2
  • rockmyplimsoul Level 5 (6,550 points)

    It sounds like your Gmail account has been set up as the default for new Calendar entries, so any new appointments you create are linked to Gmail.  If you don't want that, you can sync your Calendar to another mail account (iCloud, Yahoo, etc.) or to no mail account at all.  If you don't want to sync your Calendar with any email account, just be sure to perform a backup routinely since there is nowhere else to recover your Calendar.  Even then, sometimes backups get corrupted, so it really is best to sync your Calendar (and Contacts) with an email account of some kind.


    If you truly don't want to sync your Calendar with any email account, then do this:

    • On your iPhone go into Settings/ Mail, Contacts, Calendars, then see if you have more than one email account set up.
    • For each email account, select it and then turn the Calendar option OFF.  You will be prompted if you want to keep the existing entries -- say YES unless you want to re-do all those entries.
    • By the sounds of it, your Gmail account was either the only account being used for Calendars, or at least it was the default for new entries.  Once you turn off the Calendar setting for all email accounts, go to each one (probably just Gmail) and you can safely delete the Gmail Calendar entries for the account via a computer.


    If you want to sync your Calendar to a different email account, then do this:

    1. For the email account that you want to sync your Calendar with, make sure the Calendar feature is turned ON in Settings.
    2. For any other email account, probably just your Gmail, turn the Calendar feature OFF and choose to keep the existing Calendar entries on the device.
    3. Depending on the account that you're hoping to sync your Calendar with, the former Gmail entries that you left on the device may sync to the account you left the sync setting ON -- I think an iCloud account handles this pretty well.
    4. Open an existing Calendar entry and check the "Calendar" line -- it should indicate the remaining account that you want to sync your Calendar with.  If it does not, tap "Edit" and see if you can change this selection to the desired account.  If not, then you may want to delete and re-enter the entry (which should put it into the account you designated in step 1).


    As a final note, anytime you add a new email account be sure to check the "Default Calendar" in Settings -- sometimes adding a new account will make that account the default for Calendar, Contacts, Notes, etc.

  • Brave114 Level 1 (0 points)

    Thank you so much for your detailed response. I tried to synch my Calendar to a different email, but when I turn Calendar off in settings under Gmail, it says"Delete from my iPhone" or "Cancel." I don't know if I should delete or not. I have backed everything up on an external hard drive, but I'm just wondering if I should delete. Also, I don't see anywhere to turn Calendar on with my old (very old) AOL account, which is the one I'd like to synch with. Thanks in advance for your reply. I really appreciate it!

  • rockmyplimsoul Level 5 (6,550 points)

    Sorry, I could swear that when you remove a Gmail account you're prompted to keep or delete the calendar entries.  At this point, if you don't want these on your Gmail then your only choice is to delete them from the iPhone and then delete them from your Gmail account from your computer.


    As for AOL, I don't think it offers a calendar option so you're out of luck there.  If you have an iCloud email account set up (not just an iCloud account, but the optional iCloud email address too) then you could use iCloud for your calendar entries (and Contacts, and Notes, etc.)

  • Brave114 Level 1 (0 points)

    Thanks very much. I really appreciate your taking the time to help me. I do have another gmail account that I could sync to. I just have to figure out how. For some reason, I can't access it in Settings. Prior to this, my calendar wasn't synched to any email account, and it synched with my computer. Now it's not even doing that. (I said I backed everything up, but then looked and realized that Calendar didn't sync with my Macbook.) Since I had this reset of my iPhone, everything in Calendar has gone haywire. If you have any other ideas, please let me know. Otherwise, thank you again!

  • Brave114 Level 1 (0 points)

    I think I figured out a solution that will work so that my personal Calendar is not synching with my work email. I went to Settings - Mail, Contacts, Calendars - Shared Calendar Alerts, and turned it off. Now if I could just synch with my Macbook!

  • rockmyplimsoul Level 5 (6,550 points)

    If you're having trouble syncing your Mac's calendar, do you have Mavericks installed on your Mac?  If so, what version?  The early releases of Mavericks removed the ability to sync contacts and calendar from the Mac to the iOS device through iTunes -- forcing users to keep this information in iCloud or some other web-based facility.  There was quite an uproar over this from privacy-sensitive individuals who didn't want their stuff in the cloud, and eventually I think this ability was restored in version 10.9.3 of Mavericks.


    So if you're using Mavericks, maybe update to the latest (10.9.4) if you're still on an early version.


    As for your Gmail syncing, I don't think the "Shared Calendar Alerts" has anything to do with syncing -- that feature is for when you're added to someone else's calendar event and you want to have the same alert that they get as the appointment initiator.  At least, that's what I think it is for.  For you to not sync to a particular Gmail account, you need to turn off the Calendar option for that account, which as you discovered only gives you the option to delete events linked to that account, or cancel.


    If you have more than one Gmail account, the other account's settings should allow you to turn on Calendar syncing (if you want).  You can also set that account to be the default account to sync with.  But if your goal is to only sync with your Mac, check your OS version and turn off all Calendar syncing to email accounts.

  • Brave114 Level 1 (0 points)

    Thank you again. I do have OS 10.9.4, and prior to my phone reset, everything was synching, so I'm not sure what's going on. Everything is turned on in the Cloud settings. I turned the Shared Calendar Alerts off because my appointments were showing on my work Gmail calendar, and my tech person there has access to my account. (Talk about lack of confidentiality!) However, it does seem to have stopped the emails about new appointments as well, unless it's something else I played around with. When I type my personal Gmail account into settings, I lose all my Calendar appointments. Then, when I erase that info and re-enter my work Gmail, my appointments come back. Interesting, huh? Anyway, thanks again for all your help!