4 Replies Latest reply: Aug 11, 2014 7:04 AM by dan800
dan800 Level 1 Level 1 (0 points)

Good day , despite many post on that topic, still problem not resolve.  APP store not working w maverick update. seems unable to connect.  thank you advance for your help

 

Imac intel core I5 mid 2010, 8 g memory

just upgrade from snow leopard (latest version) to maverick 10.9.4

 

app store seems not able to get connected : blanck page w apple logo. same Itunes store : blank page

     try to connect with my ccount : failed connection (not icloud seems fine as I can not create another account)

 

     get invalid certificate with I Tunes store (and said yes to all but did not change anything)

                    « init.itunes.apple.com »

      1. upp.itunes.apple.com

                    p3-buy.itunes.apple.com »

      1. xp.apple.com »

                    « itunes.apple.com »

    

did many reboot, reinstall the whole system               .no firewal activated          delete the plist of appstore and

Caches/com.apple.appstore

Caches/com.apple.storeagent

Caches/storeagent

Cookies/com.apple.appstore.cookies

Preferences/ByHost/com.apple.appstore.plist

Preferences/ByHost/com.apple.storeagent.plist

Preferences/com.apple.storeagent.plist                         witn no effect

 

CONSOL

2014-08-10 23:18:00,304 com.apple.WebKit.WebContent[569]: NSURLConnection/CFURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9813)

2014-08-10 23:18:00,534 storeagent[387]: NSURLConnection/CFURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9813)

2014-08-10 23:18:00,535 storeagent[387]: NSURLConnection/CFURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9813)

2014-08-10 23:18:00,535 storeagent[387]: NSURLConnection/CFURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9813)

2014-08-10 23:18:00,756 storeagent[387]: NSURLConnection/CFURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9813)

 

 

preview is working fine.                 thank you daniel800


iMac (21.5-inch Mid 2010), OS X Mavericks (10.9.4)
  • Linc Davis Level 10 Level 10 (159,945 points)

    This could be a complicated problem to solve, as there are several possible causes for it.

    Back up all data, then take each of the following steps that you haven't already taken. Stop when the problem is resolved.

    Step 1

    From the menu bar, select

               ▹ System Preferences... ▹ Date & Time

    Select the Time Zone tab in the preference pane that opens and check that the time zone matches your location. Then select the Date & Time tab. Check that the data and time shown (including the year) are correct, and correct them if not.

    Check the box marked 

              Set date and time automatically

    if it's not already checked, and select one of the Apple time servers from the menu next to it.

    Step 2

    Triple-click anywhere in the line below on this page to select it:

    /System/Library/Keychains/SystemCACertificates.keychain

     

    Right-click or control-click the highlighted line and select

              Services Show Info

    from the contextual menu.* An Info dialog should open. The dialog should show "You can only read" in the Sharing & Permissions section.

    Repeat with this line:

     

    /System/Library/Keychains/SystemRootCertificates.keychain

     

    If instead of the Info dialog, you get a message that either file can't be found, reinstall OS X.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard by pressing the key combination command-C. Open a TextEdit window and paste into it by pressing command-V. Select the line you just pasted and continue as above.

     

    Step 3

    Launch the Keychain Access application in any of the following ways:

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

    ☞ Open LaunchPad. Click Utilities, then Keychain Access in the icon grid.

    In the upper left corner of the window, you should see a list headed Keychains. If not, click the button in the lower left corner that looks like a triangle inside a square.

    In the Keychains list, there should be items named System and System Roots. If not, select

              File Add Keychain

    from the menu bar and add the following items:

     

    /Library/Keychains/System.keychain
    /System/Library/Keychains/SystemRootCertificates.keychain

     

    From the Category list in the lower left corner of the window, select Certificates. Look carefully at the list of certificates in the right side of the window. If any of them has a a blue-and-white plus sign or a red "X" in the icon, double-click it. An inspection window will open. Click the disclosure triangle labeled Trust to disclose the trust settings for the certificate. From the menu at the top, select

              When using this certificate: Use System Defaults

    Close the inspection window. You'll be prompted for your administrator password to update the settings. Revert all the certificates with non-default trust settings. Never again change any of those settings.

    Step 4

    Select My Certificates from the Category list. From the list of certificates shown, delete any that are marked with a red X as expired or invalid.

     

    Export all remaining certificates, delete them from the keychain, and reimport. For instructions, select

              Help Keychain Access Help

     

    from the menu bar and search for the term "export" in the help window. Export each certificate as an individual file; don't combine them into one big file.

    Step 5

    From the menu bar, select

              Keychain Access Preferences... Certificates

    There are three menus in the window. Change the selection in the top two to Best attempt, and in the bottom one to  CRL.

    Step 6

    Triple-click anywhere in the line of text below on this page to select it:

     

    /var/db/crls

    Copy the selected text to the Clipboard by pressing the key combination command-C. In the Finder, select

     

              Go Go to Folder...

    from the menu bar and paste into the box that opens by pressing command-V. You won't see what you pasted because a line break is included. Press return.

    A folder named "crls" should open. Move all the files in that folder to the Trash. You’ll be prompted for your administrator login password.

    Step 7

    Restart the computer, empty the Trash, and test.

  • dan800 Level 1 Level 1 (0 points)

    thank you for your help. Sadly it did not work

     

    date was fine as dialog bog showed.

     

    When using this certificate: Use System Defaults :  for the blue + they alwas revert to "always approved"

    I had no red one

    I also have no "My Certificates"


    also at the opening, I need to install java but always says " network problem" ... when all connections / browser are fines


    It seems that the app store program is not able to connect for some reason. can not even create  another apple id from it . Other options ? thank you daniel

  • Linc Davis Level 10 Level 10 (159,945 points)

    Please read this whole message before doing anything.

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

    Step 1

    The purpose of this step is to determine whether the problem is localized to your user account.

    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

    While logged in as Guest, you won’t have access to any of your documents or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this behavior; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

    Test while logged in as Guest. Same problem?

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

    Step 2

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, by a peripheral device, by a font conflict, or by corruption of the file system or of certain system caches.

    Please take this step regardless of the results of Step 1.

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards, if applicable. Start up in safe mode and log in to the account with the problem. You must hold down the shift key twice: once when you turn on the computer, and again when you log in.

    Note: If FileVault is enabled, or if a firmware password is set, or if the startup volume is a software RAID, you can’t do this. Ask for further instructions.

    Safe mode is much slower to start up and run than normal, with limited graphics performance, and some things won’t work at all, including sound output and Wi-Fi on certain models. The next normal startup may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

    Test while in safe mode. Same problem?

    After testing, restart as usual (not in safe mode) and verify that you still have the problem. Post the results of Steps 1 and 2.

  • dan800 Level 1 Level 1 (0 points)

    I found another apple thread: http://support.apple.com/kb/TS5202

    1. Open Keychain Access located in /Applications/Utilities/
    2. Select Certificates from the left hand column under Category
    3. Type Class into the search field in the top right corner of the Keychain Access window and press return.
    4. Look through the list of results for any certificates that have a blue + over the icon.
    5. Double-click on a certificate that has the blue + over the icon to ‘Get info’ on the certificate.
    6. Click the disclosure triangle to the left of the word Trust to reveal the certificates permissions.
    7. Change Secure Sockets Layer (SSL): to ‘No Value Specified’ then close the window.
    8. Confirm the Administrator password in the window that will appear.

     

    One of the verisign finally changed after I "changed the secure sockets to no value" and it finally made the trick (Plus all the above in your help comment) the app store is now working (I hope for good !) . Thank you , daniel800