0 Replies Latest reply: Aug 11, 2014 9:34 AM by Agent Elrond
Agent Elrond Level 1 Level 1 (0 points)

I've actually solved this myself (or so I think), but I thought I'd pass along the information for anyone else in the same or similar situation.

 

As far as I can tell, LiveType was introduced in FCS1, updated in FCS2, and dropped from FCS3.  You probably already know that FCS2 can't be "directly" installed on 10.7 or later, as the packages were built for PowerPC, and Rosetta only appeared as a transition method in 10.6.  So what do you do if you no longer have access to 10.6 or a system that will support it?  In my case, I "poked around"; here's what I found - and without using any third party apps.

 

Disc 1 of FCS2 contains the main installer, "Install Final Cut Studio". Right clicking on that to "Show Original" shows the main ".mpkg"; tried to double click install it and got this (not surprised):

Can't install FinalCutStudio.png

Opened the "Packages" folder, and found a large pile of ".pkg" files, including LiveType, LiveTypeSupport, and MotionSeriesLiveFonts.  Tried to double click install the LiveType.pkg file and got this (somewhat* surprised):

LiveType can't be installed.png

Not to be deterred, right clicked on it to "Show Package Contents", opened the "Contents" folder, and found an "Archive.pax.gz" file.  Hmmm.  Copied that to a scratch/temp directory, double clicked to expand/extract it, and found this:

LiveType archive contents.png

Hah! I win. ;-)  Based on the archive structure, copied the app and folders to the corresponding locations.  I then went on to install the "LiveTypeSupport" and "MotionSeriesLiveFonts" packages.  I was then able to open up one of my old ".ipr" files, however it then reported a number of missing resources used by that.  Figuring that there had to be additional content "somewhere", I checked the FCS2 discs... and located the "LiveType Media 1" and "LiveType Media 2" discs.  Followed steps similar to what I'd been doing; got (and ignored) this:

Can't register.png

Managed to get the first disc done, went to the second, and got this:

Can't open package.png

Did a manual extract of the archive, copied the content where it appeared to need to go, and... that seemed to cover everything.  I then checked my FCP project that was reporting missing media from within the ".ipr" file, and... it still reported that, although it appeared to still provide a preview of it (?).  Re-opened the ".ipr" file in LiveType, played a bit of it, did a "Save" just to update the date/time stamp on the file, went back to the FCP project, and it updated itself.

 

It took a few hours, and 11GB+ of disk space, but I *think* I'm now "back in business".  Hopefully someone else will find this useful.

 

P.S. As a side note, after having completed this, I realized I still had an older machine sitting nearby that still had 10.6, a full install of FCS2, and a full upgrade to FCS3.  Oh, well...


Mac mini, Mac OS X (10.7.4), 2GHz Intel Core i7, 8GB RAM, FCS2/3