2 Replies Latest reply: Aug 19, 2014 11:09 PM by mf4j
mf4j Level 1 Level 1 (0 points)

MacBook Air running OS X 10.9.4

 

Had it set up to connect to my main iMac for shared files.  Wife complained that when my iMac wasn't on the MacBook constantly nagged her with a message saying it couldn't connect to the server (my iMac).

 

Removed sharing on my iMac.  Removed recent server list from the MacBook Air.  Removed my iMac from the finder side bar in the MacBook.  Now the MacBook Air constantly naggs us that it can't find the server (name of my iMac).  I just want the @#$@# thing to shut up, quit looking for the iMac and be quiet.

 

Need help as I can't figure this one out.

 

PLEASE!!  

  • Linc Davis Level 10 Level 10 (169,500 points)

    There are many possible causes for this issue, and it may be hard to resolve. Please take each of the following steps that you haven't already tried. Back up all data before making any changes.

    If you get the alert in the login screen before you log in, stop here and ask for instructions.

    Step 1

    If you get the alert as soon as you log in, it's probably caused by one of your login items or by software that otherwise loads at startup or login. Ask if you need help identifying it. A known offender is "AdobeResourceSynchronizer," which is a component of some Adobe products. See also this discussion.

    Step 2

    If there's an icon representing the server in the sidebar of a Finder window, hold down the command key and drag it out.

    Step 3

    In the Finder, press the key combination command-K or select

              Go Go to Server...

    from the menu bar. In the upper right corner of the window that opens is a Recent Servers popup menu represented by a clock icon. From that menu, select

              Clear Recent Servers…

    and confirm. Test.

    Step 4

    Open the Printers & Scanners pane in System Preferences and delete any network devices you no longer use.

    Step 5

    Triple-click anywhere in the line below on this page to select it, then copy the text to the Clipboard by pressing  command-C:

    ~/Library/PDF Services

    In the Finder, select

              Go Go to Folder...

    from the menu bar and paste into the box that opens by pressing command-V. You won't see what you pasted because a line break is included. Press return. A folder may open. If it does, move the contents to the Desktop, or to a new folder on the Desktop. Log out and log back in. Test. If there's no change, put the items you moved back where they were and continue.

    Step 6

    Open the folder

    ~/Library/Preferences

    as in Step 5 and move the file named "loginwindow.plist" items in that folder to the Trash, if it exists (it may not.)

    Log out and back in again, and test.

    Step 7

    Other possible causes are references in the iPhoto, iTunes, or iMovie library pointing to the server, and bookmarks in the Preview application.

    Try rebuilding the iPhoto library.

    Step 8

    Disconnect all wired peripherals except those needed to start up. Start up in safe mode. Test. After testing, restart as usual (not in safe mode) and verify that you still have the problem.

    Note: If FileVault is enabled, or if a firmware password is set, or if the startup volume is a Fusion Drive or a software RAID, you can’t do this. Ask for further instructions.

    Step 9

    Triple-click the line below to select it:

    /System/Library/CoreServices/Directory Utility.app

    Rght-click or control-click the highlighted text and select

              Services Open

    from the contextual menu.* The application Directory Utility will open.

    In the Directory Utility window, select the Directory Editor tool in the toolbar. Select Mounts from the Viewing menu in the toolbar, and/Local/Default from the node menu, if not already selected. On the right is a list of names and values. By default, the list is empty. If it's not empty, post a screenshot of the window and stop here.

    *If you don't see the contextual menu item, copy the selected text to the Clipboard (command-C). Open a TextEdit window and paste into it (command-V). Select the line you just pasted and continue as above.

    Step 10

    Open the following file as you did in the last step:

    /etc/auto_master

    It will open in a TextEdit window. The contents should be exactly this:

    #
    # Automounter master map
    #
    +auto_master          # Use directory service
    /net               -hosts          -nobrowse,hidefromfinder,nosuid
    /home               auto_home     -nobrowse,hidefromfinder
    /Network/Servers     -fstab
    /-               -static

    If there are any other lines in the window, post them. Otherwise, close the window.

  • mf4j Level 1 Level 1 (0 points)

    Linc,

     

    Thanks VERY much for the detailed and helpful reply.  After I logged off for the night I remembered that I had 1Pasword on the MacBook Air set to sync to a file on the iMac.  That was the problem.  Why on earth the nagging error message couldn't tell me there was an App that was requesting the server is beyond me, but I did finally get it solved.

     

    Thanks again for the input.

     

    Gene