12 Replies Latest reply: Oct 9, 2006 9:32 PM by Jim in CA
Yogurtron Level 1 Level 1 (0 points)
So I got the shuffle as a gift, was a bit surprised by it, but hey, its an mp3 player. The data-size of the player is small, the 512MB ones, so I decided, hey, might as well use that converter, it'll save space.

Now, I know converting takes time... however, I get it on one of my 320kbps MP3s, and wait 10 min, and it isn't done, on a 3 Gigahertz machine? I get a little annoyed. I checked the task list, and it said about 9-10% of my cpu was being used for itunes.exe. The other 90% was comparatively idle (except for the normal flashes of 1-2% on random processes).

Why was it only using 10% of my cpu? I know this takes a while, but more than 10 min a track, on this computer? I can do an equivalent encode from 320 kbps mp3 to 128kbps mp3 in LAME myself in about 30sec, a min tops, if it was just going slow that day. I don't have any decent AAC encoding software other than itunes, so coudlnt check that time quckly.

So yeah... how do I actually USE the convert to 128kbps AAC option? In a sane amount of time anyway.

  Windows XP  
  • NZ_Hammer Level 1 Level 1 (0 points)
    Have you been using iTunes 7? I was using iTunes 6 and to add about 2 hours of songs (converting from Apple Lossless to 128kps AAC) would take about 10 minutes.

    Upgraded to iTunes 7 last week and when I tried to add the same playlist it was unbelievably bad. I quit the process after 2 hours, when it was only one quarter done.

    I am running Windows XP on a 3.6 GHz Pentium D Dual Core Processor and 2GB of RAM.

    To add MP3s which don't need to be converted takes seconds, so the problem seems to be with the conversion and was induced in the new version of the software.

    Dell Optiplex with 3.6 GHz Pentium D Processor 960   Windows XP  
  • Michael Morgan1 Level 7 Level 7 (23,825 points)
    If that's what you're seeing, it should be reported via iTunes > Feedback.
  • Ken Romano Level 1 Level 1 (0 points)
    Same issue I am seeing. Terribly slow in iTunes 7....no longer usable. This is REALLY broken.
  • Merkle Level 1 Level 1 (0 points)
    Not sure if this helps everyone, but if you go to the "Settings" tab at the top when you attach your Shuffle, it give you the option to check or uncheck the "Convert to higher bit rate". If you uncheck this option and then re-synch (I did this by right clicking on the Shuffle option under Devices), it synches everything as fast as it used to.

    I have no idea what the advantage is of converting to the other bit rate but I don't really notice any sound quality loss, but that's just me.

    PC   Windows XP Pro  
  • rapman Level 1 Level 1 (0 points)
    I have the same issue. I would like to send apple feedback but they is no itunes > feedback.

    The Itunes web site is only interested in helping you buy songs!
  • crc77 Level 1 Level 1 (0 points)
    I'm having exactly the same issue. Time for down conversion has increased by a couple of orders of magnitude, and is now unusable.

    This has rendered my Shuffle next to useless, as I have encoded everything that matters in my music collection in Apple Lossless, which the Shuffle can't play, so I rely on the conversion option.

    Anybody had any luck? I have sent feedback to Apple but I'm not confident of a reply.
  • Michael Morgan1 Level 7 Level 7 (23,825 points)
    They is so!

    Open iTunes, pull down the iTunes Menu. It's still there, just like it's always been.
  • Chris CA Level 9 Level 9 (77,005 points)
    My understanding is that in Windows iTunes, Feedback simply takes them to Request Songs.

    http://www.apple.com/feedback/itunesapp.html
  • Chris CA Level 9 Level 9 (77,005 points)
    "I'm having exactly the same issue"
    Did you uncheck and then recheck it?

    I have sent feedback to Apple but I'm not confident of a reply.
    I can practically guarantee that you will not get a reply, especially since you are told you will not get a reply.
    "Use the form below to send us your comments. We read all feedback carefully, but please note that we cannot respond to the comments you submit.
  • crc77 Level 1 Level 1 (0 points)
    "I'm having exactly the same issue"
    Did you uncheck and then recheck it?


    Yes, but the conversion time still take hours, not minutes, as it once did.


    I have sent feedback to Apple but I'm not
    confident of a reply.

    I can practically guarantee that you will not get a
    reply, especially since you are told you will not get
    a reply.
    "Use the form below to send us your comments. We read
    all feedback carefully, but please note that we
    cannot respond to the comments you submit
    .


    I read that, so thank you for pointing it out, but does this particular problem classify as a warranty issue? I would think not, which leaves me with little confidence of finding a resolution until an iTunes fix comes out.

    I guess I'm up the creek.
  • mechanizeddeath Level 1 Level 1 (0 points)
    I've been having the same problem. I actually left it running all night, and when I woke up it was only about halfway finished. This is with about 3/4 of my songs needing conversion of some form or another.

    However, I seem to have found a solution! I noticed that with iTunes minimized, CPU usage shot from 10% up to 60-90% - and the conversion/transfer bar began making visible progress. Bringing iTunes into the foreground drops it back into turtle mode though, but by switching back and forth I could see it was working. This seems odd, since as I understand it, Windows prioritizes the foreground application.

    I know most of you are probably using Windows XP if you're on a PC, so this might not work. But there are enough similarities between 2K and XP that it should work. It seems to take around 3 minutes per song, slower than before but still bearable, even on my junkpile computer.

    Hope this helps!

    Spare Parts!   Windows 2000   Work in progress...
  • Jim in CA Level 1 Level 1 (0 points)
    Last night I let iTunes run and only got ~50 songs on my shuffle. Thanks to your tip, I'm converting about one song per minute. This is an odd solution, but it works!!

    I don't get the utilization you're seeing, but it is clearly much faster.