Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: how to get safari to remember login and password after I said do not remember

I went to a website through Safari and logged in and accidentally hit Never remember for this site and now I cannot get safari to remember the login and password. I have gone through preferences/passwords and the site is not listed and it will not allow me to add a site. I would love help with this since I log on to this site just about every day! Any suggestions?

iPhone 5s, iOS 7.0.6

Posted on

Reply
Question marked as Helpful

Jan 17, 2015 11:20 PM in response to christinefromcamden In response to christinefromcamden

Ok guys, I had this same issue, certain sites were not asking whether or not I would like to save the password for auto fill. Here is the NO BS answer on how to fix this.

1. Open "Finder"

2. then open "applications" and open the "utilities" folder

3. Open "keychain access"

4. On the left, under catagory select "passwords"

5. on the bottom of the window there is a small square with a "+" indicating add. Click that and enter the desired website/username/password then click "add"

6. AND BOOM!!! Your credentials are saved!! now open safari and go to the desired website, your username and password will be auto filled.

There’s more to the conversation

Read all replies

Sep 11, 2014 5:50 PM in response to christinefromcamden In response to christinefromcamden

It might be a corrupted keychain ...


Open Keychain Access located in HD > Applications > Utilities


Open Keychain Access then select Passwords on the left.


Right or control click a keychain then click Delete.


Back to Safari. Login to the website you want the password autofilled.


Click Yes when prompted to save that data to a new keychain.

Keep in mind, not all websites espcially financial institutions allow the autofill feature.

Sep 11, 2014 5:50 PM

Reply Helpful

Sep 11, 2014 6:31 PM in response to christinefromcamden In response to christinefromcamden

  1. Launch Keychain Access - it's in your Mac's Utilities folder.
  2. In the column on the left, under Category, select Passwords.
  3. In the filter field at the upper right - the one with the "magnifying glass" icon, type a few characters of the website you wish to use. The relevant Keychain entries will appear, indicating (Passwords not saved) if that was your preference.
  4. Select the Keychain entry, then Edit > Delete. Confirm the dialog by clicking Delete.
  5. In Safari, navigate to the website(s) in question and log in. This time, elect to save the password.

Sep 11, 2014 6:31 PM

Reply Helpful

Sep 11, 2014 8:02 PM in response to John Galt In response to John Galt

I've tried all of the steps listed below and my website is not listed anywhere. I deleted one to see if Carolyn was right about it being corrupted...

still no success. I appreciate everyones help but I'm still at a loss. I can't figure out how to get the save password option to come up when I log in.

Sep 11, 2014 8:02 PM

Reply Helpful (2)

Sep 11, 2014 8:16 PM in response to christinefromcamden In response to christinefromcamden

Certain sites, banking sites for example, request that the browser not save passwords.


Some browsers ignore the site's request or can be configured to do so. Safari used to be one of them, but not any more.

Sep 11, 2014 8:16 PM

Reply Helpful

Jan 8, 2015 11:41 AM in response to christinefromcamden In response to christinefromcamden

I am also having the same problem..I chose not to save a password for my college student service website, and now i regret it because i have to manually log in every time i go on. But i tried the Keychain Link and the website that i am trying to save a password for is not listed. It is also not listed in the preferences page of safari either.


So is there any other way i can get safari to remember my password for this website?

Jan 8, 2015 11:41 AM

Reply Helpful (2)
Question marked as Helpful

Jan 17, 2015 11:20 PM in response to christinefromcamden In response to christinefromcamden

Ok guys, I had this same issue, certain sites were not asking whether or not I would like to save the password for auto fill. Here is the NO BS answer on how to fix this.

1. Open "Finder"

2. then open "applications" and open the "utilities" folder

3. Open "keychain access"

4. On the left, under catagory select "passwords"

5. on the bottom of the window there is a small square with a "+" indicating add. Click that and enter the desired website/username/password then click "add"

6. AND BOOM!!! Your credentials are saved!! now open safari and go to the desired website, your username and password will be auto filled.

Jan 17, 2015 11:20 PM

Reply Helpful (11)

May 10, 2015 7:38 AM in response to JodiZ1 In response to JodiZ1

I had this problem last week and solved it with a Keychain Reset. Note that it does create an all new keychain, so make sure you have your other passwords recorded somewhere.


Keychain Reset


Keychain Issues - Resolve see post by Kappy

May 10, 2015 7:38 AM

Reply Helpful
User profile for user: christinefromcamden

Question: how to get safari to remember login and password after I said do not remember