Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How to stop iPad ringing upon incoming phone call?

After upgrading to iOS 8, my iPads ring when I get an incoming phone call on my iPhone 5. I've scoured the Settings but haven't found a way to disable that annoying feature. Can anyone tell me how to do that (and why Apple thought it was a good idea to have all of my iOS devices notify me that I have an incoming call)?


David

iPad mini (Retina) Wi-Fi

Posted on

Reply
Question marked as Solved
Answer:
Answer:

After a bit of Googling, I stumbled across the answer: It's apparently a "feature" of iOS 8. If your iPhone and other iDevices are on the same WiFi network, you can answer an incoming phone call on any of them, and all of them will alert you noisily to that incoming call. I suppose there could be a scenario where that might come in handy, but I can't imagine one offhand, and it's an annoyance to me. I don't need a cacophony of devices all alerting me to an incoming call. The iPhone will do that by itself quite nicely.


Anyway, here's the solution: On all the devices you want to disconnect from that "feature," go to Settings -> FaceTime -> iPhone Cellular Calls, and switch it to OFF. Problem solved. Just my opinion, but Apple should have left that feature turned off by default.

Posted on

Page content loaded

Question marked as Solved

Sep 17, 2014 7:03 PM in response to brianben1 In response to brianben1

After a bit of Googling, I stumbled across the answer: It's apparently a "feature" of iOS 8. If your iPhone and other iDevices are on the same WiFi network, you can answer an incoming phone call on any of them, and all of them will alert you noisily to that incoming call. I suppose there could be a scenario where that might come in handy, but I can't imagine one offhand, and it's an annoyance to me. I don't need a cacophony of devices all alerting me to an incoming call. The iPhone will do that by itself quite nicely.


Anyway, here's the solution: On all the devices you want to disconnect from that "feature," go to Settings -> FaceTime -> iPhone Cellular Calls, and switch it to OFF. Problem solved. Just my opinion, but Apple should have left that feature turned off by default.

Sep 17, 2014 7:03 PM

Reply Helpful (3)

Sep 22, 2014 9:11 PM in response to brianben1 In response to brianben1

I'm not defending their logic but yes, they do expect you to have one account per person, in the same way you can only have one user account per iDevice.


To fix / workaround your issue, Apple have released the 'Family' feature with iOS 8 (Settings > iCloud > Family), so you can link accounts together to share purchases, all controlled by a single master account. This is actually quite useful and gets around the issue of having to buy multiple copies of apps. I just need to work out how to use it when my family members are using different regional stores before I enable it, but that's a separate issue.


Edit: I just noticed that currently all linked family accounts must all use the credit card linked with the master account for purchases. This may work in your situation as you were previously all sharing the same account, but isn't suitable for me as other family members buy their own media...

Sep 22, 2014 9:11 PM

Reply Helpful (1)

Dec 27, 2014 1:29 PM in response to WoodWorks In response to WoodWorks

I agree with many posters here who point out how un-Apple this feature is. The default position of this feature should have been OFF. Time and time again, I see Apple losing a step in their UX approach. Things that would never happen during Steve Job's reign. I hope Apple gets back to simple, intuitive interfaces that made them great.

Dec 27, 2014 1:29 PM

Reply Helpful (1)

Jan 21, 2016 5:14 AM in response to WoodWorks In response to WoodWorks

WWow I thought it was only me experienced the issue. However, I think my situation is worse. I sent a gift to my parents which is an iPad. I have already set my apple account there, because they didnt know how to make one. The problem is that these days they ve been telling me about strange msg and calls into the iPad with picture and lots of things. Luckily it's not their language which is a best luck for me. It was sharing all my private personal life to them. I didnt know it's the problem with the latest ioS not until they told me ab the things. I hope Apple will improve. It was a bad time to me. I don't think I'm gonna be loyal with Apple if some other problems occur in the future.

Jan 21, 2016 5:14 AM

Reply Helpful
User profile for user: WoodWorks

Question: How to stop iPad ringing upon incoming phone call?