Announcement: Update to iOS 12

Enjoy a faster and more responsive experience as well as fun new features, like Memoji and Camera Effects.
Get iOS 12 > https://support.apple.com/ios/update

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iOS 8 Safari not working with sites using Windows Authentication (again)

A testbed of iPhones and iPads were updated to iOS 8 today. When trying to access intranet sites in our company that use Windows (IIS) Authentication, it challenges for the login and password 2 or 3 times, then nothing - just hangs. These sites work fine on iOS 7 devices - and worked on the same devices that were upgraded.


Windows Authentication was broken in iOS 7.0 also and not fixed until a later update. Why does this keep getting broken?

iPhone 4S, iOS 8

Posted on

Reply

Page content loaded

Sep 17, 2014 7:22 PM in response to mannaggia In response to mannaggia

This was a thread that discussed this when it was broken in iOS 7.0...


https://discussions.apple.com/thread/5327078?start=0&tstart=0


I just tested with Chrome on the iPhone upgraded to iOS 8 and it works fine. It is Safari that is broken again.


Of course, Apple won't give us a way to make Chrome the default browser when links are clicked in emails, so it's not exactly a solution.

Sep 17, 2014 7:22 PM

Reply Helpful

Sep 20, 2014 8:18 AM in response to mannaggia In response to mannaggia

Yep, I have found this too. I have three web apps, all are served by an IIS server using integrated windows authentication.


With ios8, none of them now work.


The work around for me was to disable the authentication on the server, open the web app, let it load, then re enable the authentication. The web app then works. This is fine for the two devices that no longer work, but I know have to stop people upgrading until there is a fix.

Sep 20, 2014 8:18 AM

Reply Helpful

Sep 24, 2014 3:35 PM in response to mannaggia In response to mannaggia

We have the same, the trouble is we have over 600 devices used by students and trying to stop them upgrading is a nightmare, but we use SharePoint as a VLE and now can't access it with Safari. I have logged it with Apple and asked when an update will be released to resolve it and have so far heard nothing back!!

Sep 24, 2014 3:35 PM

Reply Helpful

Sep 24, 2014 10:46 PM in response to DeanTTA In response to DeanTTA

Hi All


We are also facing the same issue. In Chrome , it is working fine. Here we are using SharePoint 2013 with windows authentication.If we enable the anonymous access, sites are working fine. If any one get the update on the issue, please let me know .


With Regards

Suresh

Sep 24, 2014 10:46 PM

Reply Helpful
User profile for user: mannaggia

Question: iOS 8 Safari not working with sites using Windows Authentication (again)