Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iOS8 causes both of my iPhones to ring simultaneously

Since updating to iOS8 my iPhone 5s and my wife's iPhone 5c will ring when someone calls my phone and vice versa when someone calls my wife's phone, the my phone will also ring. The only way to stop this is by turning icloud off on one of our phones. We never had this problem before even thoug we both use the same apple account and iCloud account. This has only happened with the upgrade to iOS8 on both if our phones. I can not find any any other way to turn this weird feature off. My phone was updated first with no problem with my wife's phone ringing when someone called me until I updated hers tonight. It always seems to amaze me that so many people including myself stay so committed to Apple when they release software with so many bugs. It is like they use us as their beta testers. It is poor rolliuts like this that keeps me wondering why I stay with Apple. It is like Apple dies this intentionally to force people to upgrade!!

iPhone 4, iOS 5

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Settings > Facetime > Turn Off iPhone Cellular Calls


Pete

Posted on

Page content loaded

Sep 19, 2014 6:55 PM in response to petermac87 In response to petermac87

Thank you so much. Who would of thought tjis would be a default setting during an upgrade. I am not sure if and when I would of figured this one out. Why in the world would this be a setting in FaceTime and not Phone. Now I can sleep tonight!!!! Thanks again

Sep 19, 2014 6:55 PM

Reply Helpful

Sep 19, 2014 7:02 PM in response to Robert Cantrell In response to Robert Cantrell

No worries, another contributor here told me how to do it as it was driving me mad as well. Just another annoyance in a new iOS release. I also noticed all my Apps were turned on in Settings>Notifications by default as well, and I wondered why my phone battery was discharging more quickly. They will eventually get it right. The second update usually clears a few of these things up after Apple receive userfeedback


Cheers


Pete

Sep 19, 2014 7:02 PM

Reply Helpful

Sep 23, 2014 8:08 PM in response to Robert Cantrell In response to Robert Cantrell

If you have a problem where incoming calls are picked up on multiple devices belonging to different people... On all devices: Go to the settings, Face Time then uncheck the number or email associated with the other persons iPhone, iPad or iPod. This will allow you to answer the phone on your iPhone or iPad but the other person will not receive the call. Hope this helps

Sep 23, 2014 8:08 PM

Reply Helpful

Apr 29, 2015 6:40 PM in response to Robert Cantrell In response to Robert Cantrell

petermac87 - Thank you!


APPLE CREW - These settings should be in the same folder for people using more than one iPhone. CRAZY to have them in two folders.


(imessages) Settings > Messages> Send & Receive > (choose which phones to enable or disable)

(phone calls) Settings > Facetime > Turn Off iPhone Cellular Calls


And turning on the cellular calls was a default setting? I mean, Jesus guys. Where's Steve Jobs? LOL

Apr 29, 2015 6:40 PM

Reply Helpful

May 27, 2015 8:31 AM in response to petermac87 In response to petermac87

Thank you soooo much! This has been happening to me and my husband for quite a while and driving us nuts. No one I had talked to ever had or even heard of this problem so we were baffled. And it didn't even dawn on me that it was only when we were both connected to wifi! I thought it might be some setting, but couldn't figure it out. Thank you again!!

May 27, 2015 8:31 AM

Reply Helpful
User profile for user: Robert Cantrell

Question: iOS8 causes both of my iPhones to ring simultaneously