Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mac does not show UBS as a serial port option for Arduino Uno

Hi,


My Macbook Air with Mavericks will not show a USB connection to Arduino Uno Rev 3. I have tried installing the drivers from: http://www.ftdichip.com/Drivers/VCP.htm but still no luck. Any suggestions appreciated.


Regards,


Alex

MacBook Air, OS X Mavericks (10.9.4)

Posted on

Reply

There’s more to the conversation

Read all replies

Page content loaded

Apr 19, 2015 8:18 AM in response to fenrrir In response to fenrrir

I'm running Yosemite on a Late 2011 MacBook Pro...


I've used Arduino IDE 1.0.5 and have recently upgraded to Arduino IDE 1.6.1


I've never had to install special USB drivers.


I simply connect the Arduino UNO R3 to the USB port.


In Terminal, perform the following command


ls -al /dev/tty.usb*


This command will list the USB port for the Arduino, e.g. /dev/tty.usbmodemfa131


Sure enough, this device appears under Arduino -> Tools -> Port


Make sure the Arduino is connected to the USB port.

Apr 19, 2015 8:18 AM

Reply Helpful

Aug 29, 2015 7:57 PM in response to alpeace89 In response to alpeace89

Stumbled across this. It worked for Mac OS X Yosemite 10.10.5


install the CH340 driver

Run the command in Terminal:

sudo nvram boot-args="kext-dev-mode=1"

Reboot


However, I installed:

MAC system:http://www.wch.cn/downfile/178


so YMMV


a user here:

http://forum.makeblock.cc/t/mac-os-x-yosemite-arduino-1-0-6-doesnt-recognize-mak eblock-orion/728


found the solution, there:

http://forum.arduino.cc/index.php?topic=261375.15


so kudos - to all that sweated out the driver, uninstall, install, and activation...



Ted

Aug 29, 2015 7:57 PM

Reply Helpful (2)
User profile for user: alpeace89

Question: Mac does not show UBS as a serial port option for Arduino Uno