Skip navigation
This discussion is archived

Printer Driver Doesn't Show Up.

841 Views 4 Replies Latest reply: Jan 1, 2007 8:15 PM by Kenny Mitchell RSS
annanic Calculating status...
Currently Being Moderated
Sep 22, 2006 5:57 PM
I have a Canon Pixma MP500 (Multifunction). It's only about two months old.

Up until last weekend, I was still running Jaguar. My printer worked perfectly. I upgraded to Tiger on Saturday and didn't try to print anything until today. When I tried to, I saw my printer was no longer installed. However, it was detected. When I tried to add it, the correct driver was not listed. I put in the install disc that came with the printer, re-installed the software and restarted. The correct driver still didn't show up. I went to Canon's site, downloaded the drivers, installed again and restarted. They're still not listed. I tried to choose some of the drivers that are listed to see if I can print an email, but anything I spool just sits there in the queue.

What do I do next? I know it's plugged in correctly. I haven't touched it since I set it up two months ago and it was working perfectly fine just before I upgraded to Tiger.
Dual 533 G4, Mac OS X (10.4.7)
  • fzennaro Calculating status...
    Currently Being Moderated
    Nov 1, 2006 11:26 AM (in response to annanic)
    I've same problem, same Pb 17'
    the difference is that my printer was working in TIGER till yesterday. Unexpectly yesterdey I lost drivers, MP500 disappeared, I've reinstalled drivers but...nothing.
    Pb find printer, but doesn't find drivers; drivers are installed.
    I think I need help.


    p.s.:Same problem with PIXMA ip1600.

    Pb 17' Mac OS X (10.4.7)
    Pb 17', Mac OS X (10.4.7)
  • Owen Collum Calculating status...
    Currently Being Moderated
    Nov 4, 2006 1:56 AM (in response to fzennaro)
    I have the same problem. I've been using an Epson Stylus Color 880 for years, but now the driver isn't listed and nothing prints. I was hoping to find a solution here.



    G5 iMac 2.0 GB Rev.B   Mac OS X (10.4.6)  
  • mlink77 Calculating status...
    Currently Being Moderated
    Dec 30, 2006 6:47 AM (in response to annanic)
    Hi!

    How did you solve the problem? I've got exactly the same - even though I installed the HP OS X Drivers 3.3 none of the supported printers show up in the list...

    Thanks a lot and happy new year!
    Matthias.
    iMac Core Duo 20", Mac OS X (10.4.8)
  • Kenny Mitchell Calculating status...
    Currently Being Moderated
    Jan 1, 2007 8:15 PM (in response to annanic)
    I am having the exact same thing happen with my Kodak Printer dock series 3. It worked last week, now nothing. I am running Tiger and the computer recoginizes the printer but no drivers show up on list. If anyone knows a solution please share.
    G3 B&W 350 Mhz 768MB, Mac Mini 1.66 GHz Intel Core Duo, Mac OS X (10.4.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.