Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: External Hard Drives not Mounting after Yosemite Upgrade

I've just upgraded to Yosemite, and none of my external (USB) hard drives are mounting (they don't even appear in Disk Utility).


Any ideas?

Posted on Oct 19, 2014 2:53 AM

Reply

There’s more to the conversation

Read all replies

Oct 19, 2014 4:11 AM in response to The_V-Man In response to The_V-Man

Plug in your USB disk and run the following command on the terminal:

diskutil list


You should see something like this:

~ $diskutil list

/dev/disk0

#: TYPE NAME SIZE IDENTIFIER

0: GUID_partition_scheme *250.1 GB disk0

1: EFI EFI 209.7 MB disk0s1

2: Apple_CoreStorage 124.5 GB disk0s2

3: Apple_Boot Recovery HD 650.0 MB disk0s3

4: Apple_HFS SecondOS 124.6 GB disk0s4

/dev/disk1

#: TYPE NAME SIZE IDENTIFIER

0: Apple_HFS MacOS *124.1 GB disk1

Logical Volume on disk0s2

8FC6DFC6-B91D-41F4-9849-7ADFDDBBA048

Unencrypted

/dev/disk2

#: TYPE NAME SIZE IDENTIFIER

0: FDisk_partition_scheme *16.0 GB disk2

1: DOS_FAT_32 16GIG 16.0 GB disk2s1

~ $


You should see *all* your drives. What do you get?

Oct 19, 2014 4:11 AM

Reply Helpful (3)

Oct 22, 2014 3:20 AM in response to The_V-Man In response to The_V-Man

Ok. Can you click on the apple icon on the top left corner of your screen, open "about this mac".

Once here, click on "system report", navigate to the Hardware->USB section and see if you can find your USB drive. I hooked up a 16-gig Cruiser Fit drive and here's what I get.


User uploaded file

If you can't see it here, then I'm out of ideas.

Oct 22, 2014 3:20 AM

Reply Helpful

Oct 25, 2014 1:01 PM in response to The_V-Man In response to The_V-Man

MacBook Pro 2009. 250 SD, HD 8Gb Ram.

I have had this issue for about a year...with no resolve!

Apple and the User community have not been able to solve issue.

I have had to work around it since the Oct 2013 Mavericks upgrade which “killed” (rendered unmountable) both my USB and Optical drives.

Hundreds of replies and remedies have not corrected my issue. Hundreds of replies stating that if there was a global issue it would of been fixed by Apple, not true. And dismissive replies stating that there must be a hardware issue are very discouraging.

So now, hoping to help the voiceless masses, I'm forced to share my experience.

As I stated, I have been having the issue since one of the Mavericks upgrades. The upgrade rendered externally attached drives unmountable...They are all seen in Disk Utility. They are just not mountable. Regardless of the flavor of the disk format, either Mac or PC, they are found, seen and refuse to mount. I can see them using Terminal commands, I can see them in System Report. I can reset all the memory I want...turn it off, reset, sleep, turn on, restart...NOPE...And the optical drive takes in disks but ejects them after an attempted mounting. Keep in mind, there are no physical issues with either USB or optical drives.

So now...I have had enough and need to correct the issue or buy a new equipment - starting to get into software development and need working equipment!!!

For the past month, I have been visiting the Apple store to assist in my issues...Back Story: I'm an IT Field Tech for the largest department store in the country and I have the good fortune of dropping in the Apple store anytime I want...The Geniuses booted the MB with a bootable image of Mavericks, and the USB and Optical drives WORKED fine...So, after I had stumped the Geniuses with my problems, we agreed that we would attempt to format and re-image the MacBook...Fine, do it, it's backed-up, how you ask? - Via my wireless My Book Live 3T drive, which only took 24 hours to backup, AKA Time Machine!

Great news! The re-image of Mavericks proved to work! I WAS able to mount external drives attached! How is that possible? Don't know, don't care! It just worked! So happy!

But wait! I then took the laptop home. Connected to my WiFi, to update Mavericks to the latest version...Good so far! Then it came time for a Time Machine restore, AKA Migration Assistance restore...So, I proceeded to migrate data back to my MB via wireless drive, good so far, booted in Migration Assistant, and I chose to restore everything except the network files, thinking that may be an issue...22 Hours later, the MB migrated without issue...all apps and personal files had migrated! YAY!

BUT NOW THE USB AND OPTICAL DRIVES FAILED TO MOUNT!!!

Great now what? I know, I will just re-image and start again...WAIT, I don't have a Mavericks Install Disk, no problem, I will just create a bootable USB drive with the Mavericks Install Image I downloaded onto my MB this month...NO YOU CANNOT, because you have no use of the USB drives!...And, Apple stopped making OS CDs back in 2009...Oh, and that wouldn't of done me any good, because the optical dive was unusable, anyway!

SO, back to the Apple store with my head hanging! At this point, Yosemite came out the previous Thursday, so no more Mavericks images, great! Perhaps the new OS will alleviate my nightmare!!!!...So, they re-imaged my Mac with Mavericks, drives worked again! SO, I took my MB home and attempted to download the new OS, Yosemite...which only took 2 days due to the amount of traffic on Apple's servers!...Anyway, Yosemite finally installed without out issue! Drives still worked! And so, I shutdown and restarted the system...No issues, USB and optical drives worked beautifully! Yay, Yosemite!...Fixed all my troubles!!!...Not so fast...

And so, I, again, attempted to do a Time Machine restore, via WiFi, this time it took 24 hours to restore...AND it worked! All apps and personal files transferred without issue, So happy! Put the laptop in Sleep and left it home and went to work! Came back from work, tested the system without issues. Rebooted...USB and Optical drive are NOT MOUNTABLE!

So now, what is the file that the restore keeps pushing to my MB that kills the USB and optical drives?

I would just stop restoring from a Time Machine backup, but the only way to get into the TM image is to use Migration Assistant. I cannot view the date in time of the image in TM's Star Wars time line. So, I'm forced to back up everything from the image in Migration Assistance. Not sure that it being an encrypted image has anything to do with it...

...Regardless, what is being “restored” to the MB that continues to configure the OS in such a way that makes all external drives unmountable...keep in mind, my external keyboard, hub and mouse are usable via USB.

Oct 25, 2014 1:01 PM

Reply Helpful (2)

Nov 3, 2014 12:45 AM in response to lunartune In response to lunartune

Unfortunately my drive is NTFS, and running 'Kext Utility' didn't seem to fix the issue.


Just so i'm clear (because there wasn't any instructions with Kext), I d/l & ran the utility, and then restarted my machine. Did I need to do anything else?


BTW thanks very much for trying to help out here - from my ongoing search this appears to be a MacOS related issue (as there were a stack of people having the same problem when Mavericks came out). I've tried everything I can think of - from updating the WD Firmware, to numerous disk tools, to even trying to mount it on my PC laptop (which didn't work either, but i'm thinking thats more NTFS related, than this issue).

Cheers

Nov 3, 2014 12:45 AM

Reply Helpful

Nov 3, 2014 1:47 AM in response to The_V-Man In response to The_V-Man

As far as i know there isn't anything else to do.

I have a 2TB WD passport NTFS and it was recognized by disk utility but it was "unable to activate".

i launched "kext Utility 2.6.1" and when it finished (in the window it says Enjoy), i restarted the machine.

After restarting my USB disk came back to work properly.


Cheers

Nov 3, 2014 1:47 AM

Reply Helpful
User profile for user: The_V-Man

Question: External Hard Drives not Mounting after Yosemite Upgrade