Announcement: Get Ready for macOS Mojave


With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. Prepare for macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: OS X Yosemite - numpad not working in Terminal nano editor

Just updated to OS X 10.10 Yosemite and I'm having issues with the numpad not working when using the nano editor. It works fine in Terminal, but as soon as I call up the nano editor, the numpad only works as directional keys.


Anyone else having this issue or have a solution?


Thanks.

MacBook Pro, OS X Yosemite (10.10)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

I had the same problem. On mine, a preference was changed in Terminal application by the upgrade. No idea why the upgrade changed it.


In the Terminal application:

Click on the "Terminal" menu

Click "Preferences"

Click on the "Profiles" tab.

Click on the "Advanced" tab (right hand side of the window)

Uncheck "Allow VT100 application keypad mode"


Open a new terminal instance and test. Mine has been working just fine since changing this. Tested both nano and vi.


Hope this helps!User uploaded file

Posted on

Page content loaded

Question marked as Solved

Oct 23, 2014 9:52 AM in response to Dak_ In response to Dak_

I had the same problem. On mine, a preference was changed in Terminal application by the upgrade. No idea why the upgrade changed it.


In the Terminal application:

Click on the "Terminal" menu

Click "Preferences"

Click on the "Profiles" tab.

Click on the "Advanced" tab (right hand side of the window)

Uncheck "Allow VT100 application keypad mode"


Open a new terminal instance and test. Mine has been working just fine since changing this. Tested both nano and vi.


Hope this helps!User uploaded file

Oct 23, 2014 9:52 AM

Reply Helpful (22)

Oct 24, 2014 7:22 PM in response to Dak_ In response to Dak_

Yes, you can use the “Allow VT100 application keypad mode" preference to override nano’s behavior. Note that this is a feature of nano. It enables the terminal's “Application Keypad Mode” in which the numeric keypad sends escape sequences that are distinct from the usual digits. Normally it’s up to users to configure programs like nano, vim and emacs to either not enable AKM or to map the input to do what they desire (navigate, enter digits, invoke other commands).

The default value of this preference changed in Yosemite 10.10 so that requests for AKM are supported by default.

Oct 24, 2014 7:22 PM

Reply Helpful (1)
User profile for user: Dak_

Question: OS X Yosemite - numpad not working in Terminal nano editor