1 5 6 7 8 9 Previous Next 151 Replies Latest reply: Nov 11, 2013 6:14 PM by iBlacc Go to original post
  • 90. Re: MBP audio no longer plays from my speakers...Optical light stays on
    Advanced User Level 4 Level 4 (1,090 points)
    I had this problem too. It was very frustrating, especially when I brought my MacBook Pro to my local Apple Store and they fixed with a toothpick! They also said it's a very frequent issue and that it seems to affect every generation of MBP. In my case my soundcard was working fine so I fixed immediately.
    Anyway you're right, it should be a patch or something from Apple, this problem affects a large part of MBP users.
  • 91. Re: MBP audio no longer plays from my speakers...Optical light stays on
    reesd Level 1 Level 1 (0 points)
    I ended up using a Q-Tip which worked great. I pulled some of the cotton of the end so it would fit and then inserted it a few times. I was thinking I might use some rubbing alcohol also, but didn't need it.

    Red light off, internal speakers on!

    Thanks,
    d
  • 92. Re: MBP audio no longer plays from my speakers...Optical light stays on
    Macintosh Lou Level 1 Level 1 (30 points)
    I suffered this issue with my MBP today. After a mini-huff, I took the time to read this thread and a few wiggles with a toothpick (spiky end cut off) with System Preferences > Sound open, it was fixed within 3 minutes.

    Thank you very much to all who have posted their issues and subsequent fixes. Saved me a tedious trip to the busy Apple store.

    Lou.
  • 93. Re: Fixed it!!!!!!!!
    hestro Level 1 Level 1 (0 points)
    ok thanks, it helped
    I used a wooden toothpick and gently push it inside the jack audio output
    at some point I could hear a 'click' and it worked (sound back and red-light off).
  • 94. Re: MBP audio no longer plays from my speakers...Optical light stays on
    EarthBased Level 1 Level 1 (20 points)
    This redlight issue started happening on my 3.5 years old Macbook Core Duo recently. Plugging in headphones and unplugging fixes it for me. But Apple needs to change this component to another supplier with better design. I will not buy a new Macbook until this is fixed!
  • 95. Re: MBP audio no longer plays from my speakers...Optical light stays on
    fatdust Level 1 Level 1 (0 points)
    well

    we love apple, thats why we got it. just had same issue. tiny screw driver and position somwehere between 11-3 clock works for me (macbook)

    but... W T F ! ! ! this problem is nearly 4 years old. even owls in collaboration with mice got sort it out small stupid easy thing. how come that mighty apple with mouth full of perfectionism are not able to do it? this is proof that god doesnt exist otherwise he wont watch this. OMG guys!!!!! are you for real?

    Im producer for ages ( http://soundcloud.com/fatdust ) and i have NEVER used digital out...
    so... guys, be honest, how many of you ever used spdif out? and for what? with all humble in me i would go for working speakers than useless spdif (if not useless, definitely less useable than speakers in about 1:1 000 000 000 000 000 000 000 000 000 000 000 000)

    sorry for speech but such a small thing and how irritating.
    well done apple, well done....
  • 96. Re: MBP audio no longer plays from my speakers...Optical light stays on
    Cory Schaal Level 1 Level 1 (5 points)
    I only wish I was one of you lucky ones that just put something in and wiggled to get it working, unfortunately i've tried every type of object that could fit into the tiny hole and NOTHING has worked... I think one day I was trying for almost 4 hours, and stupid me still tries to get it working on occasion. Its too bad, my Macbook is no longer under warranty and I am SOOOOO not paying for this to be fixed, apple should seriously create a software update to turn off the optical out signal, after all, the port itself doesnt turn on until it starts into OS X, just a way to disable the driver would be nice...

    Why does something like this happen with almost every apple laptop?

    Maybe i'll just sell it on ebay for 200-300$ and use that money to buy a laptop without an optical port just to be safe :P
  • 97. Re: MBP audio no longer plays from my speakers...Optical light stays on
    ryr Level 1 Level 1 (0 points)
    Old thread but problem still occurs. Followed advice. Actually, solved problem by putting in headphone jack and wiggling it.
  • 98. Re: Fixed it!!!!!!!!
    Snowman in Florida Level 1 Level 1 (0 points)
    I had the same problem and found the metal prong at 9 o´clock after searching with magnifying glass now everthing is back to normal. the prong that is used to turn off internal speakers when using headphones just seemed to be stuck.
  • 99. Re: MBP audio no longer plays from my speakers...Optical light stays on
    PollParody_com Level 1 Level 1 (0 points)
    I had the same problem after plugging in a non-Apple headphone set. Initially it was pretty frustrating, but was made even more frustrating to see that this problem has existed for so long.

    I tried multiple suggestions... the toothpick, wiggling a headphone plug in there, etc. I also tried the clock dimensions mentioned in some of these replies (11-3 & 9 o'clock, etc). I looked much closer... that 11-3 & that 9 o'clock reference are actually referring to a metal trigger that's at BOTH 9 o'clock AND 3 o'clock.

    Bottom line: It worked after reinserting the problem headphones & wiggling back & forth at 9 & 3 o'clock. And it has to be done while the red light is on

    The red light comes on after plugging in headphones & adjusting volume with the headphones in. Then remove the headphones & the red light stays on for a period of time before shutting off.

    I hope this helps... but it would be much more helpful to fix the initial problem.
  • 100. Re: MBP audio no longer plays from my speakers...Optical light stays on
    Jon614 Level 1 Level 1 (0 points)
    The "toothpick fix" worked for me. To those struggling with it, you don't just take the toothpick and jam it all the way in. Not even halfway. Get a flashlight or light source so that you can see into the headphone jack and lightly press on different areas in there. Have iTunes playing so that the red light will be constantly on (since it's trying to transmit an audio signal), and it'll shut off the instant you press on the right thing.

    I was pretty irate reading about the problem, you'd think they could make a better component since this has been going on for over 4 years. I also read numerous suggestions to take it to AppleCare... do people just automatically buy that nowadays? When I buy an 1100 dollar laptop, twice the going rate for similar specs, I expect it to work better. I don't expect that I should have to pay hundreds more for a warranty, and that I should have to use it. Yet Apple fanboys act like you're an idiot if you don't pay it. Doesn't make sense to me. If Apple truly believed in their products they'd help you out for longer than 90 days before making you pay another week's salary just to even TALK to you.
  • 101. Re: MBP audio no longer plays from my speakers...Optical light stays on
    Allan Jones Level 7 Level 7 (30,425 points)
    To all who are complaining about the quality MBP Audio jack:

    My testing shows the culprit is not the jack but cheap 1/8" min-pin plugs. The critical dimension is from the tip to the stop-shoulder that prevents the plug from going too deeply. That varies from plug to plug.

    Brand name does not always save you. I have a set of cheapo speakers I picked up at a yard sale and their mini-pin is perfect in the MBP. I also have a pair of name-brand headphones whose plug to tip distance is too long and can jam the port. I put the 'phones on my head and listen for the signal to come through as I slowly insert the plug. When the music starts in the 'phones, I stop pushing. For that plug the "now works" distance is sufficient to support the plug and it stays put, but the stop shoulder is about 1/16 to 1/32 inch from touching the case.

    Try different devices with the 1/8" mini-pin. I suspect you will find they stop at different points. Blaming Apple for third parties who fail to follow standard published dimensions is not going to accomplish anything.
  • 102. Re: MBP audio no longer plays from my speakers...Optical light stays on
    gjgjgj Level 1 Level 1 (0 points)
    Is it possible to describe where in the socket needs to be pushed because it's really not working from me here. Is it a latch or a sweet spot or what indeed has to be nudged...?
  • 103. Re: MBP audio no longer plays from my speakers...Optical light stays on
    kleenscott Level 1 Level 1 (0 points)
    Apple: This happens to me roughly twice per week after using APPLE headphones. (I remove them carefully and everything!). My typical fix for this problem: I take a bobby pin and make small circles with it in my jack. Usually this fixes it, but I'm assuming Apple would have a fit if they knew this was the way most users are fixing their computers.

    So if you're stuck, try this... and then send an email or something to Apple so they are aware of this widespread problem.
  • 104. Re: MBP audio no longer plays from my speakers...Optical light stays on
    andrea_fallas Level 1 Level 1 (0 points)
    Right. I too have been having this problem for some time. I have tried the following:

    - inserting and re-inserting the same headphones that caused the problem
    - inserting and re-inserting a variety of different headphones/speakers/etc.
    - wiggling the inserted headphone cable
    - wiggling a toothpick inside the jack
    - sweeping around the inside of the jack in a circular motion with a toothpick and a metal pin
    - depressing each individual contact with a toothpick and a metal pin
    - compressed air

    http://i952.photobucket.com/albums/ae7/andrea_fallas/headphonejack.png

    FWIW, here is a picture of the jack, showing the position of the connectors that I can press. The ones on the right and left are close to the entrance of the jack, while the top one is a little further back. If you look inside the jack (easy with the glow of the red light) you should be able to see them. There appears to be another connector, just behind the right one, which I cannot depress.

    So far, nothing has yielded positive results. The best I got was when depressing individual contacts, or sweeping around the jack in a circular motion: the red light went off for a moment, before lighting up again. Still no sound, except through headphones or external speakers. It's an old MacBook, so no warranty/AppleCare and I am a poor student, so I can't afford to have it fixed.

    This is an appeal to all the Unix-heads out there... surely there is a clever way to bypass this and force sound out of the internal speakers?
1 5 6 7 8 9 Previous Next