14 Replies Latest reply: Dec 14, 2006 10:37 PM by Dean Garth
etoy Level 1 Level 1 (0 points)
I just bought the Linksys Wireless-G version 6 router WRT54G. I have 3 computers. I wanted to connect my G4 to the router, use my new MacPro laptop, use the wireless for my Gateway downstairs, but it won't configure. I can't access the internet at all. Help please. We have spent a lot of time with their support people, but all they can say is that sometimes, Linksys will not work with Mac and gave up. What now?

Thank you in advance.

G4, Mac OS X (10.3.9)
  • fragmore Level 3 Level 3 (660 points)
    Get the pdf file from Linksys, for your router.
    Get it here. http://www.linksys.com/servlet/Satellite?c=LProductC2&childpagename=US%2FLayout&cid=1149562300349&packedargs=site%3DUS&pagename=Lin ksys%2FCommon%2FVisitorWrapper

    It has very detailed set up instructions.



    Power Mac G4 (AGP Graphics) Dual 500   Mac OS X (10.4.7)   2 GB Ram, Nvidia FX5500 agp card
  • cfi Level 1 Level 1 (0 points)
    Hey... they told me the same thing after 3 hrs on the phone with them... I am sending mine back!
  • lkrupp Level 4 Level 4 (3,435 points)
    For what it's worth I also just purchased a WRT54G version 6 wireless router and it's performing like a champ for my G5 (wired) and my son's brand new Mac Book (wireless). I'm using the WPA2 wireless security and it just works. It was real simple to configure, a piece of cake. Perhaps you just got a defective unit. Or perhaps there's something you're doing, not doing, or understanding.

    When you say it won't configure what exactly do you mean? Can you log into the router from your browser and get to the built-in configuration UI? Is it a browser problem in that you can't the router to take your clicks and commands? Are you connecting to the internet with a cable modem or DSL modem? There's a big difference in how you set the router up based on your internet connection. Cable modems can be particularly infuriating as they sometimes lock onto the first MAC (the ethernet port's unique identifier) address they see.
  • etoy Level 1 Level 1 (0 points)
    Hello. I had a friend come over who is pretty savy with computers. He too is having a tough time trying to get the wireless to work. I am using a cable modem. We got into the setup window. Went through the steps but still won't work. I will just have to return it. Any thoughts on what other wireless router to buy in order to network a mac G4, MacPro, and a Gateway PC?

    Thank you.
  • lkrupp Level 4 Level 4 (3,435 points)
    Most routers are essentially the same and I suspect you will have the exact same trouble with any router you choose to buy. If you can get to the setup screen but cannot surf the internet it's because the router and the cable modem are not communicating with each other. This is a common situation with cable modems.

    Every ethernet device has a built-in address called a MAC address (media access control address). Cable modems typically accept the first MAC address they see when they are first hooked up. The problem is they lock on to that address and won't talk to anything else after that. Your computer ethernet port has its own MAC address and the cable modem is probably looking for that unique address because that's who it was talking to before you connected router which presented the cable modem with an entirely different MAC address of its own.

    Some cable modem providers require you to call them and provide the router's MAC address so they can reset their cable modem to accept the router. Some providers allow the user to reset the cable modem themselves (there's usually a reset button on the back of the cable modem). Failing those two options some routers (the Linksys DOES allow this) can be setup to clone the original device's MAC address so the cable modem see the MAC address it is looking for and start working.

    So to sum up, your problem is probably NOT with the Linksys router but with the cable modem not accepting the router's MAC address.



    Dual 2.5GHz G5 Power Macintosh   Mac OS X (10.4.8)   1.5GB RAM 20" Apple Cinema Display
  • Lawrence Kahan Level 1 Level 1 (35 points)
    It's the Linksys firmware! The new version 1.01.0 causes the problem with Macs (but not Windows PC's) To cure the problem, go to http://www.linksys.com choose downloads from the support pulldown menu. Choose WRT54G V5.0 -- Wireless-G Broadband router, click on Downloads for this product, click firmware and click download firmware. You will download a folder that will contain version 1.00.9 firmware (you must choose the version 5 model, not V6 to get this firmware version). Then connect by ethernet to the router and change the ethernet network settings to manual, 192.168.1.50, subnet 255.255.255.0, router 192.168.1.1 and apply. Then open a browser and enter http://192.168.1.1 to access the router. Go to the admin tab and choose subtab update and the update with the downloaded firmware. When it completes, reset the router, restart the computer, restart the modem, set your ethernet network to DCHP and apply. You may have to reset/restart everything again, but you should eventually get assigned a proper IP number and be able to connect. NOTE: THIS CURE WAS NOT SUGGESTED BY LINKSYS - use at your own risk. (But, I am posting this from the iMac that wouldn't connect an hour ago.) Note also that the release notes for the latest software (the version that doesn't properly set the IP using DHCP) say:
    "Firmware 1.01.0
    - Update Broadcom ethernet driver.
    - Resolves DHCP server issue...."
    Oops - maybe "Creates" would have been a better word than resolves.
  • lkrupp Level 4 Level 4 (3,435 points)
    Again, Mr. Kahan, you are making statements of fact you cannot possibly confirm. First of all the original poster does not mention which firmware version his router is running. Second of all the version you are so inflamed over isn't shipping with new routers as it was released only a couple of weeks ago. Third of all he's saying he can't access the internet.

    I guess if you continue to splatter the forums with your "solutions" that's your business.
  • Lawrence Kahan Level 1 Level 1 (35 points)
    I'll skip the personality war, thanks. The facts are, if you go to they linksys website, you'll find that there is a mandatory firmware update. While it says you must update to 1.00.9, if you have a v.6 router, it takes you to a download page where you are directed to a download of 1.01.0. If you read the version notes, you'll see they changed the DHCP server portion of the firmware. That is exactly the problem reported in the forum by several posters. Going back to 1.00.9 cured my problem instantly and cured the only other poster who has posted since I put these responses up. Yes, that's my advice not to update to 1.01.0 - it's based on 40 years experience with computers (mostly Apples and Macs) that says if you don't have good reason to do a software or firmware update, and you know it causes problems for some people, it is better not to do it. So yes, I'll continue to try to help these folks. Thanks for your permission.
  • Jon T Hutchinson Level 1 Level 1 (5 points)
    I bought one from MacMall because they list the platform as both PC and Mac. I suppose it might work with some versions of OS X, but not Tiger. The latest drivers (preferences) for this router support up to OS 10.2. I called and queried MacMall about stating it will work with both platforms. I was given a return authorization number -- it's going back tomorrow.

    Jon
  • cupang Level 1 Level 1 (0 points)
    I got the same problem as etoy with exactly the same router. It used to work fine as an open wireless network until one day we decided to put an encryption (WEP), which prevented some computers in our house from connecting. When we removed the encryption on the router, it was never the same again for my powerbook. After several e-mails to support@linksys.com, they solved my problem by making me use the static IP address instead of DHCP. So I guess I will try to use the suggestion about going back to firmware version 1.00.9

    powerbook G4 12inch Mac OS X (10.4.7)
  • bigeyesssss Level 1 Level 1 (0 points)
    No matter what the techy blowhards say here, Linksys DOES NOT support useage by Mac users. You're on your own. I know this from personal experience ...

    1. I had to go to the Apple Bar to get a Netopia wireless card programmed with my G4 laptop. Why? Because the titanium models' metal apparently interferes with Airport useage. This from the Apple tech, who was a dream in getting me started wirelessly.

    2. I purchased a Linksys router, which SAYS "MAC" on the box, which is supposed to mean that it's for Macs AND PCs. Lo and behold, the CompUsa staff knew nothing about this (tired of no one knowing about Macs ... grrrr) and I had to take it home and program it myself. Which I did. And immediately was given .exe files to download from a CD to start. (of course, this is only for PC users!!!) I promptly called Linksys, where I was told, "oh, we don't know how to troubleshoot for Macs." I laughed and told them they shouldn't be selling equipment to Mac users and claiming that it works for Mac users when they couldn't provide the tech support or software for it! I was bumped up to "second tier support" (this is also typical, no one is trained on Mac issues ... anywhere.) where I was given the link to a site that had a driver I could use. Which I did. And it worked. HOWEVER ... I have had several instances where my card just stops working all of a sudden, usually for a minute or two (and yes, it's a PC card, as well ... should work SEAMLESSLY with a Linksys router), only the other day the "outage" lasted about 25 minutes. No, it wasn't my DSL line (which is crappy, given that service up here in the hills of SF stinks, no fiber optic upgrade for us ... in supposedly the "wireless capital" of the world. lol But that's another story -) ... that worked perfectly fine when hardwired into my laptop. It was the router. And once again, I called and was told, "well, you need the firmware update." (which someone else has mentioned here, fine, but ...) Of course, I was never sent an email notifying me of this (even though it took scads of info, including email addy, to register for this thing, as with other hardware/software) ... nonethless, once again I was bumped up to "second tier tech" whereby someone directed me to a linksys addy, to get the firmware. Lo and behold, I download it, and it's an .exe file. lol Bozos, all of 'em.

    Linksys is NOT made for Macs. I can get mine to work, but it's really not worth the hassle. I should have found a way to use AirPort. Now, I'm going to make my daughter's desktop G4 wireless (my old 'puter) and I'm sure it'll be another huge hassle to do that with the same card I have in my laptop.

    Bottom line is ... even though Apple stuff is more pricey, stick to Airport technology when you can. Unless you're prepared to pull your hair out getting PC-oriented stuff to work. And DON'T believe the hype. Most likely, if a PC-oriented piece of hardware says it works on a Mac, it's for the most part, B.S.

    B. Occhiogrosso

    Mac fan, designer, et al.

    G4 laptop and desktop   Mac OS X (10.3)  
  • Lawrence Kahan Level 1 Level 1 (35 points)
    In case anyone wants more information on the problems with current linksys firmware versions 1.01.0 for wrt54g or firmare 1.50.9 for wrt54gs, the following thread has infomation about the problem, the cure and where to find the older firmware.:
    http://forums.linksys.com/linksys/board/message?board.id=Wireless_Routers&messag e.id=10007
  • Mike Braun Level 1 Level 1 (0 points)
    Wow. Much angst and irkedness over Linksys. Let me add mine. I have an older Linksys router, hardwi8red to my G5 and wireless for my son's G4 (my old mac). YEsterday the G4 stopoped connecting to the Web. It SEEES the Linksys, but it will not connect. I have tried everything from rebooting to reconfiguring. NOothing was done to the machine before it stopped connecting, no firmware update, nothing.
  • Dean Garth Level 1 Level 1 (0 points)
    I have run into four or more G4 AGP Macs that will not talk to some routers, notably to a switch. The fix I've had to use is to go into an older analog router and let it talk to the Wireless router or the switch. There is some inccompatiablity with apples ethernet cciruityr orr software that creates this problem. I'm hoping that someone else has found a solution to this sticky problem because half of our Macs will not talk to the swich and must go through the older router. They are all AGP amchines of the 400 mHz variety.
    This is not a setting problem in the network preferences panel nor do I believe it is a switch or router firmware issue but if it is please let me know how to fix it.