Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't disable FileVault

I recently upgraded to Yosemite and now have to enter my password every time I boot up with I find annoying. It seems I need to disable FileVault to solve this problem but when I try I get a message ' FileVault is encrypting the data on your disk. Wait until your disk is fully encrypted before turning off fileVault' Any suggestions?

MacBook Pro with Retina display, OS X Yosemite (10.10.1)

Posted on Dec 11, 2014 6:17 AM

Reply
Question marked as Helpful

Dec 11, 2014 8:22 AM in response to djdett In response to djdett

It's a bug.

Back up all data before proceeding. There are ways to back up a computer that isn't fully functional. Ask if you need guidance.

Start up in Recovery mode. When the OS X Utilities screen appears, select Disk Utility.

In the Disk Utility window, select the icon of the startup volume from the list on the left. It will be nested below another disk icon, usually with the same name. Click the Unlock button in the toolbar. When prompted, enter the login password of a user authorized to unlock the volume, or the alternate decryption key that was generated when you activated FileVault.

Then, from the menu bar, select

File ▹ Turn Off Encryption

Enter the password again.

You can then restart as usual, if the system is working. Decryption will be completed in the background. It may take several hours, and during that time performance will be reduced.

Dec 11, 2014 8:22 AM

There’s more to the conversation

Read all replies

Dec 11, 2014 6:28 AM in response to djdett In response to djdett

In the FileVault system preferences, do you see an encryption progress indicator? If so, then monitor this to see when encryption will be finished, and keep your Mac booted and awake for this process to proceed. It may take a number of hours to do, but when done you should be able to disable it.

Dec 11, 2014 6:28 AM

Reply Helpful
Question marked as Helpful

Dec 11, 2014 8:22 AM in response to djdett In response to djdett

It's a bug.

Back up all data before proceeding. There are ways to back up a computer that isn't fully functional. Ask if you need guidance.

Start up in Recovery mode. When the OS X Utilities screen appears, select Disk Utility.

In the Disk Utility window, select the icon of the startup volume from the list on the left. It will be nested below another disk icon, usually with the same name. Click the Unlock button in the toolbar. When prompted, enter the login password of a user authorized to unlock the volume, or the alternate decryption key that was generated when you activated FileVault.

Then, from the menu bar, select

File ▹ Turn Off Encryption

Enter the password again.

You can then restart as usual, if the system is working. Decryption will be completed in the background. It may take several hours, and during that time performance will be reduced.

Dec 11, 2014 8:22 AM

Reply Helpful (6)

Dec 11, 2014 9:11 AM in response to djdett In response to djdett

This is a really crappy bug, and I don't know of an easy way to recover. If you don't feel able to carry out these instructions, get someone more experienced to help you. One option is to make a "Genius" appointment at an Apple Store.

You need at least two complete, independent backups of all data before proceeding. There are ways to back up a computer that isn't fully functional. Ask if you need guidance.

Start up in Recovery mode by holding down the key combination command-R at the startup chime. Release the keys when you see a spinning globe.

When the OS X Utilities window appears, select

Utilities Terminal

from the menu bar at the top of the screen—not from any of the items in the OS X Utilities window.

Follow the procedure in this thread to erase the FileVault volume. The long string of letters, numbers, and dashes that you will have to enter will be different in your case. Copy and paste it from the Terminal window into the command.

This operation will remove all data from the volume, so you had better be sure of your backups.

Quit Disk Utility. You should then be able to restore the data from a backup in the main screen.

Dec 11, 2014 9:11 AM

Reply Helpful (1)

Apr 17, 2015 6:00 AM in response to Linc Davis In response to Linc Davis

I had a fresh Yosemite install and FileVault is turned on by default. I had to wait 3 days until it was completed, during those 3 days everything on my mbPro was slow, dragging a window was laggy, typing was always 1-2 characters behind, saving a simple text file took 15 seconds. Once the encryption was completed, my MBPro went back to normal, nothing was laggy. I then turned off FileVault. A month later had to do a hard reboot and surprise surprise, FileVault was turned back on and now I had to sit through another 3 days of lag. This has been going on for about 8 months and happens each time I reboot my computer.


Why can I not permanently turn this feature off?


Seems Apple has all sorts of bugs, only there are hardly any crash alerts or equivalent of the blue screen of death... the user just never know anything is really wrong unless they describe the issue to Google.


I need to have FailVault turned off permanently.

Apr 17, 2015 6:00 AM

Reply Helpful
User profile for user: djdett

Question: Can't disable FileVault