1 2 Previous Next 16 Replies Latest reply: Nov 21, 2006 10:06 PM by RonaTD
drewster5 Level 1 Level 1 (0 points)
I have an original Titanium Powerbook. I have iTunes 7 on it. I am having a very difficult getting CDs to import or play, lately.
The CD says it is importing, but never advances.
The last CD that I tried to import, I dbl-clicked on another song that was already in my library, and then clicked on one of the songs on the CD. For some reason, this worked. It has not worked for this latest CD. I click the 'play' button and then the spinning beachball of death starts to run and I have to force-quit.
Any ideas?
PLEASE HELP!
Drew

Powerbook G4, Mac OS X (10.4.5)
  • 1. Re: iTunes will not import CDs, or play them
    scapesuiter Level 7 Level 7 (27,660 points)
    Drew, is it a copy-protected CD? What format are you using to import songs? Does the CD-ROM or DVD drive work for other applications?
  • 2. Re: iTunes will not import CDs, or play them
    Ricktoronto Level 6 Level 6 (11,550 points)
    Sounds more like a CD drive failure than an iTunes issue. It happens. I have a LaCie D2 external , loves DVD's , loves to burn CD and DVD, dead as a mackeral if I put in a CD.
  • 3. Re: iTunes will not import CDs, or play them
    akroma Level 1 Level 1 (0 points)
    I have this same problem. It is b/c the music is protected by another music player, I don't know how to turn it off in whatever music player it is refering to but I used windows media center to burn all of my other cd's. Also I cannot play cd's in my car I guess from a previous post it says that the cd's aren't being recognized because the files are "a." something. This stinks, I also can't play the music I have purchased through itunes in anything but itunes. It's my music I should be able to play it in whatever I want right? HELP!!!!
  • 4. Re: iTunes will not import CDs, or play them
    akroma Level 1 Level 1 (0 points)
    I don't think thats it, I really think its something to do with the itunes not his/her computer. Also when I burned some cd's into itunes last night (I had no internet connection last night) none of the album info came up and now I am entering 100 + songs manually, needless to say, I'm not happy.
  • 5. Re: iTunes will not import CDs, or play them
    scapesuiter Level 7 Level 7 (27,660 points)
    If you have a problem with iTunes for Windows, please don't post in the iTunes for Mac discussions. Thank you.
  • 6. Re: iTunes will not import CDs, or play them
    drewster5 Level 1 Level 1 (0 points)
    Sorry it took me so long to get back.

    I have iTunes 7 and these are just normal CDs.

    I messed around and was able to import the CD by actually dragging it onto the iTunes icon. BUt if I just put in a CD, it will mount, open, crank and click and make all sorts of noises, start to import, but the import never progresses. The import progress bar never moves and the CD will not play.

    Like I said, if I open the Apps folder and drag the CD onto the iTunes icon, it works.
    Still, it is a bit frustrating.
  • 7. Re: iTunes will not import CDs, or play them
    scapesuiter Level 7 Level 7 (27,660 points)
    Are the settings correct in the CDs & DVDs System Preferences?
  • 8. Re: iTunes will not import CDs, or play them
    Tim Lorenzen Level 4 Level 4 (1,895 points)
    Next time, just select the songs you imported previously and choose "Get CD Track Names" from the Advanced menu.
  • 9. Re: iTunes will not import CDs, or play them
    Klaus Hochkogler Level 1 Level 1 (0 points)
    I've got the same problem: some CDs I simply can't add to my library, others I still can (mostly older ones from my CD-collection). I assume that there must be a copy-protection but the annoying thing is that apple can't deliver software to cope with that problem. Sadly enough as far as I know under bloody windows I can copy CDs with copying protection. IS apple doing something about this? Or is apple just looking forwad to become part of Micros... :-(((
  • 10. Re: iTunes will not import CDs, or play them
    akroma Level 1 Level 1 (0 points)
    Sorry I did not realize that it was for Mac.
  • 11. Re: iTunes will not import CDs, or play them
    drewster5 Level 1 Level 1 (0 points)
    I have always been able to import CDs befor. I ahve not changed prefs or anything. The problem just started.
    I think my drive may just be getting old.
    Since I posted the original problem, I tried to import another CD (just a store-bought music CD). Again, it cranked and whirled and said that it was importing, but the import bar never progressed. I decided to leave it overnight. In the morning, it finally decided to start working.
    Who knows?

    Drew
  • 12. Re: iTunes will not import CDs, or play them
    JGaff Level 1 Level 1 (5 points)
    I'd like to add solidarity to this issue. Like Drew, I too am a TiBook G4 owner who is having problems importing CDs. After reading all these posts, I don't think it's a drive problem. I don't think it's a question of copy protection. I clearly think it's an issue that's come with the new iTunes 7.

    This is the first time that I've tried importing anything into iTunes since the upgrade. I thought it was about time to put the Beatles "Anthology" onto my iPod, so I needed to bring them to iTunes. I experienced problems throughout importing all 6 CDs, but by coaxing I was able to get them all. Force quitting, opening with a CD in the drive, opening without, using the Import CD button, using the menu, etc. It took way too long, with way too much hassle ... but both my drive and Apple Records music made in to my iTunes.

    I hope this is addressed in the next upgrade.

    peace.
    Jim.

    TiBook G4   Mac OS X (10.4.8)  

    TiBook G4   Mac OS X (10.4.8)   iTunes 7.0.1
  • 13. Re: iTunes will not import CDs, or play them
    drewster5 Level 1 Level 1 (0 points)
    I was able to figure out a workaround. Thanks to all who helped.
    drewster5
  • 14. Re: iTunes will not import CDs, or play them
    Aaron Norlund Level 1 Level 1 (65 points)
    What is the work around!? I have a very similar issue with an iMac G5.

    Thanks for your time,
    Aaron N.
1 2 Previous Next