4 Replies Latest reply: Oct 4, 2006 10:03 AM by HD
HD Level 4 (3,585 points)
Dear all

Has anyone else experienced a G4 QuickSilver gradually failing? A friend complained about hers not booting, partially booting or getting past login and then hanging.

I took a look at it last night, and the only useful info I could gather was while running fsck in single-user mode: the repeated error "ioata controller blocking bus".

Over the course of two hours we tried 15 or 20 restarts and/or resets. On most occasions we only got as far as the grey sunshine screen. On the two times we got to login, there were disturbing squeaks/grating noises from the hard drive. After logging in, we got a SBOD within 10 minutes.

The box wouldn't boot from an authorised Tiger install CD (yes, CD) in either the internal or an external drive. It wouldn't boot from a bootable FireWire drive. Starting up with alt held down got us to the blue "select startup disk" screen, but no disks were shown as being available.

I tried all I could think of - repaired permissions one one of the occasions we did get logged in, reset PRAM, reseated RAM. The original hardware test CD reported no errors. Eventually I gave up.

Having Googled the "ioata controller" error, I'm pretty sure that the hard drive is failing. My friend is going to take her G4 to the local Mac authorised dealer, but she's concerned about losing photos and music (whoops, no backup...).

Just wondered if anyone has been here before and managed to get their data back, or had any other ideas?

Thanks,

H

 iMac G5 20 1st Gen 1.8 GHz. iPod 3rd Gen 20 Gb. Airport Exp. Oodles of things., Mac OS X (10.4.7),  iMac G3 Snow 600 MHz
  • Malcolm Rayfield Level 7 (28,075 points)
    Did you run the Extended hardware tests? If you have time, you can type Ctrl-L to make the tests loop, and run them overnight. The quick tests will sometime miss things. Was anything changed (such as new RAM) on the system between the time it was working, and when it started failing? If you have sufficient RAM, try running with one module removed. Repeat for each module.
  • Don Archibald Level 10 (101,340 points)
    Hi, HD -

    The original drive on my G4/733 died in such a manner that the Mac would not boot to anything - not to another internal drive, nor a CD, nor an external drive, nor even to an emergency boot Zip disk. Once I disconnected that drive the machine would boot to anything.

    That's one test to see if the fault lies with a hard drive itself - disconnect the hard drive and try booting to a CD. A G4 should be able to boot to a CD even if there is no hard drive present.

    In my case, I suspect the board in the drive failed in such a way that it killed the ATA bus, which in turn blocked everything. Lacking the technology, skills, and parts to try replacing that board, I tossed the drive. Fortunately I had made a 100% backup of that drive onto a partition on the other drive in the machine less that a week before, so lost nothing major.

    There are utilities available which can be used to recover data from a drive that is mechanically sound but just won't mount for some reason. Here's a couple of those -
    Data Rescue
    Virtual Lab

    However, if the drive is damaged in such a way that it is no longer mechanically sound - it won't run, or it blocks or won't make the ATA connection - then in order to recover the data you would need to use the services of a commercial data recovery company. Unfortunately, their services are not inexpensive. Here's one such firm -
    DriveSavers
  • Majordadusma Level 6 (9,425 points)
    Hi, HD!

    You might try disconnecting the hard drive, doing a PRAM reset to refresh your startup settings, and then attempting to boot from an external drive or an install disc. If it boots, the issue concerns the drive, or less likely, the drive bus.

    The "ioata controller blocking bus" message is pretty vague when it comes to tracing a specific issue. I'm no developer by any stretch of the imagination, but my plebian interpretation is that it simply means that some process/instruction is hanging and tying up the controller, keeping other processes/instructions from being able to use it. It's a rather common message with OS problems like freezes, etc.

    There is hope for the drive data if you can see the drive in the System Profiler, on this Mac or another one, whether it actually mounts or not.

    Gary
  • HD Level 4 (3,585 points)
    Thanks, Malcolm, Don and Dadusma for the insights and advice. At least there seems to be some hope that my friend can recover her data.

    Malcolm, for the record, I ran one Extended hardware test (from the original CD that shipped with the G4). It found nothing. I didn’t know about the Ctrl-L option, I’ll keep that up my sleeve. I should have tried running with one RAM module - didn’t occur to me at the time.

    Nothing was changed on the machine AFAIK - it started this behaviour on Sunday night and has got progressively worse since. The noises I described in my original post started then too, apparently.

    Don and Majordadusma, thanks for the tip about disconnecting the hard drive. If she asks me to do any more on the machine (and as I said, she’s taking it shop-wards) then I’ll definitely try that one, at least to eliminate some of the possibilities. I’ll leave data recovery to the professionals, I think.

    I’ll mark this post as answered, as I think I’ve got enough answers to be going on with and the machine is going to the techies. Thanks again, guys.

    H

    edit: All replies were equally helpful, so the 5 bonus points were awarded at random