Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How do I setup shared Exchange mailbox with Mail (Yosemite)?

Hello,


we use Office 365 hosting for our mails. Setting up my default Exchange account is no problem at all, just provide e-Mail address, password and let auto discover finish the rest through System Preferences -> Internet accounts.


But I also need to setup two shared Exchange mailboxes. If I setup the e-mail address of the shared mailbox. I tried to set it up as follows:

System Preferences -> Internet Accounts -> Add Exchange Account

Name: Shared Mailbox

Email Address: shared.mailbox@domain.com

Password <own AD password>


As expected: Internet Accounts couldn't log in to the Exchange server "autodiscover-s.outlook.com". Make sure the email address and password you entered are correct. Then, enter your user name and click Continue.


<Continue>

Account Settings

Account Type: Exchange

Description: Shared Mailbox

User Name: <own smtp mail address>

Password: <own AD password>

Server Address: outlook.office365.com

<Continue>

Account Summary

Account type: Exchange

Full name: Shared Mailbox

Email address: shared.mailbox@domain.com

Server address: outlook.office365.com

<Continue>

Select the apps to use with "shared.mailbox@domain.com": Mail


=> There was a problem setting up the Mail account: an unknown error occurred.

05/01/15 13:02:10,706 com.apple.internetaccounts[313]: Already have account E2E3FF00-2B0E-4F75-ADD9-FB********** configured for user: <first.last@domain.com> host: outlook.office365.com


So to add an additional account to access a different mailbox on the Exchange sever with the same credentials as the personal mailbox is apparently no option any more. On the other hand I haven't found any option to add according folders from other mail address inboxes to my personal account in any of the Preferences from Mail (Yosemite, 8.1) or any menu item, that would allow me to add the inboxes of other shared Exchange server mail boxes I have access to.


The same is true for Mail (iOS 8.1.2), thus I have not found a solution to configure the shared mailboxes on my iOS devices either.


Trying to setup an "Add Other Account" using IMAP did not succeed either. It always uses my personal mailbox, because I only have my personal user to access the shared mailbox and downloads my personal inbox instead of the one of the shared mailbox.


Do I really have to fall back to Outlook 2011 Mac to be able to use this feature and miss out on all the hands off features from Yosemite?

MacBook Pro, OS X Yosemite (10.10.1)

Posted on

Reply
Question marked as Helpful

Feb 3, 2016 7:57 AM in response to iRandall! In response to iRandall!

I just want to mention that in El Capitan 10.11.3 with Apple Mail 9.2 (3112) the shared mailbox from Exchange Online or Office 365 online can be added again without any error.🙂 Same strategy than with iOS (9.2.1 tested).

Just use other Mail Account with the standard IMAP and SMTP settings (not the predefined Exchange Setting) and the syntax as described above:

IMAP:

server: outlook.office365.com

username: my-personal-mailbox@my-domain.com/shared-folder-alias-name

password: personal-password

(if necessary: Port 993, SSL = ON and Password authentication)

SMTP:

server: smtp.office365.com

username: my-personal-mailbox@my-domain.com

password: personal-password

(if necessary: Port 587, SSL = ON and Password authentication)


Is there anybody how got a working setup for shared mailboxes running under

A) Mavericks 10.9.5 with Apple Mail 7.3 (1878.6) or

B) Yosemite 10.10.5 with the corresponding Apple Mail Version?

There’s more to the conversation

Read all replies

Page content loaded

Mar 6, 2015 10:23 AM in response to malenze In response to malenze

Hello Malenze. Did you ever find a solution to this issue? I'm really giving it my best to be able to utilize our office365 shared mailbox on native Apple device apps (Apple Mail on OS X Yosemite & iOS Mail on iPhone/iPad) but I'm just not having any luck. I've tried countless different configurations mentioned on many forum threads with no success. If I can't get this to work I'll be forced to delete the shared mailbox and just create the account as a new/additional user with that email address.


If you found some type of solution would you please be so kind as to respond and let me know. If you didn't find a solution, what did you finally decide to do for your team?


Thanks, Randall

Mar 6, 2015 10:23 AM

Reply Helpful

Mar 31, 2015 6:44 AM in response to lindsay271 In response to lindsay271

i too use office 365 shared mailboxes and it took me a long time to work out to add them to my ios mail app , this worked for me :


start setting up a normal exchange account , put your shared email address in the username and you main email account password.


it will fail to do the auto-discover thing , but when you click on continue it eil allow you to manually enter the details :


Name : < whatever>

email : <your shared email a/c address i.e myshared@myemail.com >

description : <whatever>


incoming mail

Host name : outlook.office365.com

username : <your main email address / shared i.e mymain@myemail.com/myshared >

password : < your main account password >


outgoing mail server:

SMTP : smtp.office365.com



username : <your mail email i.e. mymain@myemail.com >

password < your main account password >

use ssl <YES>

authentication : Password

server port 587




this worked fine on every IOS device i own, but somehow it doesn't work with my Yosemite mail 😟, so if anybody can help with Yosemite mail it would be much appreciated.


Cheers;

RP

Mar 31, 2015 6:44 AM

Reply Helpful (4)

Apr 1, 2015 7:08 AM in response to RP_99 In response to RP_99

Thanks RP_99. This setup worked for me on my iPhone. I wasn't optimistic because I thought I had tried this approach previously but sure enough it worked. Note though that it wouldn't work when selecting "exchange" for the new account type. I had to select "other" at the bottom and enter everything manually. Now we just need to figure this out on the native apple mail app on Yosemite and we'll be set.

Apr 1, 2015 7:08 AM

Reply Helpful (1)

May 1, 2015 10:57 AM in response to RP_99 In response to RP_99

So..i just tried the approach above but adding as other email and it created a full duplicate of my exchange account. I need to add a couple of shared email accounts. Any thoughts?


Regarding adding them to the email on your MAC, you can use the delegate function on Office365 for MAC.

May 1, 2015 10:57 AM

Reply Helpful
Question marked as Helpful

Feb 3, 2016 7:57 AM in response to iRandall! In response to iRandall!

I just want to mention that in El Capitan 10.11.3 with Apple Mail 9.2 (3112) the shared mailbox from Exchange Online or Office 365 online can be added again without any error.🙂 Same strategy than with iOS (9.2.1 tested).

Just use other Mail Account with the standard IMAP and SMTP settings (not the predefined Exchange Setting) and the syntax as described above:

IMAP:

server: outlook.office365.com

username: my-personal-mailbox@my-domain.com/shared-folder-alias-name

password: personal-password

(if necessary: Port 993, SSL = ON and Password authentication)

SMTP:

server: smtp.office365.com

username: my-personal-mailbox@my-domain.com

password: personal-password

(if necessary: Port 587, SSL = ON and Password authentication)


Is there anybody how got a working setup for shared mailboxes running under

A) Mavericks 10.9.5 with Apple Mail 7.3 (1878.6) or

B) Yosemite 10.10.5 with the corresponding Apple Mail Version?

Feb 3, 2016 7:57 AM

Reply Helpful (5)

Feb 3, 2016 10:51 AM in response to zooom it guru In response to zooom it guru

Just found this post, and it was just what I've been looking for!

Finally can get shared mail on Mail!


Unfortunately, I still can't send. SMTP sending still fails. I'm using me@mydomain.com for username, password is my password, 587 is on and PASSWORD is auth type.


"Sending the message content to the server failed.

The server response was: SMTP; Client does not have permissions to send as this sender"


Do I need to have TLS set to a certificate or something?


Also, does this work for Calendar, too?


btw, i've never been able to get A) or B) to work.


Great post! Thanks for the help!

Feb 3, 2016 10:51 AM

Reply Helpful (1)

Feb 3, 2016 11:11 PM in response to 808hays In response to 808hays

"Sending the message content to the server failed.

The server response was: SMTP; Client does not have permissions to send as this sender"

Maybe the setting of the shared mailbox is not correct? This is how i have set that up in the office admin console. where Hannes Maier and COOPH hardsoft, both have access to that shared mailbox.

I don´t know if it works for calendars, too. I think it should since there are also shared folders in office365 to share meeting rooms or other resources and this is organized with calendar entries.

here the screenshot of my shared mailbox setting in Office365:

User uploaded file

Feb 3, 2016 11:11 PM

Reply Helpful

Jun 7, 2017 2:09 AM in response to malenze In response to malenze

I followed the settings on this thread and the work.

BUT

You must have POP/IMAP enabled on the Shared Mailbox in 365. To do this: Log into the admin 365 account -> Go to Admin -> Groups/Shared Mailboxes -> Select the mailbox -> Click Edit Exchange settings (new window) -> Click Mailbox Features -> Enable IMAP.

Jun 7, 2017 2:09 AM

Reply Helpful

Oct 10, 2017 2:48 PM in response to zooom it guru In response to zooom it guru

Thanks for the helpful post.


In my case, I was attempting to connect to a shared mailbox on an on-premise Exchange 2010 server, using macOS Sierra. The key to getting this to work for me was:

a) From Accounts... choosing Add Other Account..., then Mail account (instead of selecting Exchange)


b) From Add a Mail account, entering the shared mailbox's email address in Email Address, and my personal password in Password


c) Important! From the next window, entering my personal domain-userid@domain.com/sharedmailboxname. The key here is that in my case, my domain-userid is different from domain-userid's email address (jd1@company.com/sharedmailboxname instead of john.doe@company.com/sharedmailboxname).


d) After setting the Account Type to IMAP, I had to enter my company's activesync fully-qualified domain name, instead of the internal server's fully-qualified domain name (e.g. getmail.company.com vs. exchange-server-01.company.com). I can see how this can depend on how your shared mailboxes and access to them are setup - talk to your Exchange admin like I did)


e) At this point I knew it was working because I was prompted to select which apps to use with the account (Mail and Notes were my options)


f) After clicking Done, I was finally presented with the option to edit the Description of the shared mailbox so that it could named something more meaningful

Oct 10, 2017 2:48 PM

Reply Helpful (2)
User profile for user: malenze

Question: How do I setup shared Exchange mailbox with Mail (Yosemite)?