8 Replies Latest reply: Oct 24, 2006 12:20 AM by Lars Gislén
Lars Gislén Level 1 Level 1 (0 points)
I updated to 10.4.8. Suddenly all my settings for Netscape and Mail were gone and the files on the desktop were gone. I found them in a newly created folder with the same name as my administrators previous home folder. I dragged the files over and the settings were OK again. But one problem remains, I cannot drag any file or folder to the desktop. When I try a prohibition mark appears. It works fine for the other acconts but not for my main (administrator) account. What to do?

iMac, Mac OS X (10.4.8)
  • Niel Level 10 Level 10 (271,650 points)
    Click on the desktop and choose Get Info from the File menu. Under Ownership & Permissions, change the settings so that your account has Read & Write access to this folder and is the owner of it. Close the Get Info window.

    (17178)
  • Lars Gislén Level 1 Level 1 (0 points)
    I have tried that, but is just grayed and says: You have no access. No alternatives where I can set options. Also I cannot move the hard disk ikon, if I try it moves back to the top right location and a get a "prohibited" sign. I have used the installation DVD to reset my accout password. I don't use Firevault. Please help!!
  • Niel Level 10 Level 10 (271,650 points)
    There should be a gray triangle to the left of the No Access item. Click it to reveal the details. In the Owner menu, click the padlock and then change the owner to yourself; you will be asked to provide your password at some point. Once you've changed the owner to yourself, change the permissions if needed.

    (17189)
  • Lars Gislén Level 1 Level 1 (0 points)
    The Finder info window shows from the top (I translate from Swedish)
    Changed --
    ––––––––––––––––––
    [Gray arrow on left side pointing down] General
    Size: 0 k on disk (0 byte)
    Created:--
    Changed:--
    Colour marking: x Coloured dots
    –––––––––––––––––––––––––––––––––
    [Gray arrow on left side pointing down] More info:
    --
    –––––––––––––––––––––––––––––
    [Gray arrow on left side pointing down] Survey (Overview):

    –––––––––––––––––––––––––––––
    [Gray arrow on left side pointing down] Owners and authorities/permissions
    You have no access

    The last item is hidden when I make the arrow point to the right.More in detail what happened is this. Nothing else appears when I manipulate the arrows.

    This is in detail what happened. Suddenly the desktop went emty of the file and folders I had there. Then all my seetings in mail and other applications were gone. My "home" (the house) has the name "svullo" and remained in the accounts folder. I found a new folder named "svullo" (however, not appearing in the accounts folder) where all my previous "svullo" stuff was located. The files and folders that I had had on the desktop were stuffed away in a hidden folder that I later found. I copied the contents of the new "svullo" folder to the "home" "svullo" folder and my mail and other application settings were restored. But still the desktop appears locked. I cannot move files or folders to the desktop and not drag around the hard disk icon. When I log on to the other accounts everything is OK.
  • Lars Gislén Level 1 Level 1 (0 points)
    Sorry, there is no gray arrow to the left of the message "You have no access"
  • Niel Level 10 Level 10 (271,650 points)
    Open the Terminal application in the /Applications/Utilities/ folder and run the following:

    sudo chown $USER ~/Desktop

    When prompted, type in your administrator password; nothing will appear on the screen while it is being typed. If the issue persists, enter 'chmod u+rwX ~/Desktop' into the Terminal without the quote marks.

    (17193)
  • Lars Gislén Level 1 Level 1 (0 points)
    I tried the terminal stuff. And a restart. No change. The desktop is still locked. To me it seems that the computer in some way changed my account.
  • Lars Gislén Level 1 Level 1 (0 points)
    I solved the problem partially. I created a new administrative account and copied all the files in the problematic account folder to the new administrator's folder. Switching to the new account (after restart) it turns out that after minor adjustments the new account seems to work properly with all my personal settings, mail, desktop etc. However, this took about 16 GB of memory.

    My question is now: Can I delete the old administrative account now or do I then lose data, for instance serial numbers to applications?