Previous 1 2 3 Next 30 Replies Latest reply: Jun 30, 2007 10:46 AM by JT Harvey Jr.
Austin Sloat Level 2 (195 points)
We are trying to set up link aggregation between 2 ethernet interfaces on our MacPro Tiger Server and our Netgear GS748T switch. We successfully created the link but under status we get "no partner" for each of the bonded interfaces...

the switch is supposed to support 802.3ad "Manual" So I have enabled trunking on the two ports that the server is plugged into per netgear's instructions. Both ports show up with full 1000 connections so they are getting good connections presumably...

does anyone have any experience doing a link with this switch or family of switches? any tips?


  Mac OS X (10.4.8)  
  • Michael Ojaste Level 3 (530 points)
    Did you ever get this working?
    I am also having problems with Link Aggregation on a Mac Pro running 10.4.8 OS X Server. I'm connecting to a D-Link DGS-3224TGR. The Switch has the LACP active on both ports of the trunk and the Ports are grouped, enabled and LACP. When both en0 & en1 are connected they show green in the network status but i have no real connectivity beyond the switch. I can connect to the web-GUI of the switch. I'm going to post my own topic but wanted to hear if this one was resolved.
  • RadUS Level 1 (5 points)
    we have the same problem:
    - Link Aggregation works on the XServe with a D-Link DGS 1224T Switch
    - it doens´t work on the MacPro green lights but no real connection (it is impossible to connect the MacPro and the XServe both using Link Aggregation - even with cross over cables
    - the Mac adress is the same on en0, en1 and bond0 on the XServe ( sign of working link aggregation )
    - the Mac adresses are different on the MacPro -enabled and configured Link Aggregation but not working

    is ther anybody who knows how to solve this issue ?

    thanks ullrich
  • Leif Carlsson Level 5 (4,950 points)
    You never use crossover cables with gigabit (not with macs anyway).
    You need all 4-pairs of cables for gigabit - with a straight cable.

    Do you mean if you replace the Xserve (G5?) with the Mac Pro you don't get a LACP connection?
  • RadUS Level 1 (5 points)
    what I saw was that the XServer (Intel) could establish the link aggregation and the MacPro couldn´t - and I don´t know why ... ?tomorrow I will test it with straight cables
    thanks for that

  • Michael Ojaste Level 3 (530 points)
    Leif i think he just ment he tried X-overs but he made one point which we need to explore. The MAC address i believe he is trying to say on a Mac Pro of en0 & en1 are different. I have the same thing. He seem to claim that on an XServer en0 & en1 have the same IP of course but ALSO the Same MAC address. This could be the key we are looking for.

    Does anyone know how to spoof the en1 MAC address to the same as en0?
    Any experts on netstat and route CLI's?

    Also maybe we can move this to my new topic.
  • NeuroCog Level 1 (0 points)

    In response to the inital question about the Netgear GS748T - I had the same problem with the 24-port version (GS724T). I came to the (unfortunate) conclusion that this switch does NOT support the 802.3ad protocol - this protocol isn't listed on the Specifications page on Netgear's website. Austin, where did you find the bit about it supporting "manual" 802.3ad?

    I tried everything I could (including variously activating or not activating the trunking on the switch - one web page indicated to keep trunking off on the switch). This is a bummer since the next step up is a Layer 2 switch which is twice as expensive...
  • Michael Ojaste Level 3 (530 points)
    Ok Apple Engineers have confirmed the problem and it will hopefully "be fixed in a future update" we hope.
    It is an Intel based system problem they did not say if it's hardware/firmware issue or software. I would think hardware/firmware fix needed since they offered no way to do a CLI fix but we will see.
    So those ethernet interfaces on Intel Xserve or Mac Pro can not be aggregated, "it not my fault" as Apple speech would say, Argh.
  • RadUS Level 1 (5 points)
    Link Aggregation does work on the Intel XServe ( but LOM doesn´t work in that case ...- on my Xserve Intel) - link aggregation doesn´t work an the MacPro -
  • Michael Ojaste Level 3 (530 points)
    RadUS, just to let you know Apple told me this issue is effecting both lines of Intel hardware not just the MacPro so in your case I'm not sure how you got it to work. The Intel chip-set for the ethernet controller does not seem to configure the MAC address correctly. This was all confirmed by Apple. If you Appear to have a Working link aggregation on an Intel Xserve I would ask you to unplug en0 from the switch and see if en1 still functions as it should if it is truly setup right as link aggregation.
  • RadUS Level 1 (5 points)
    Hello Michael,
    one ethernet unpluged - and it works like it should - without any problem (ping and DICOM Connectivity).
    There is also the same Ethernet "adress" 00:00:00:00:00:00 for en0 and en1 in $ ifconfig.

    I could not get it to on a MacPro but it works in a production environment on the XServe Intel (MacOS 10.4.8 and 10.4.9 developer).

  • Michael Ojaste Level 3 (530 points)
    Ok Thanks for the Info Rad. That is bad cause It would have been fixed faster if it was on both as the Apple Rep Believed.
  • Jomel1 Level 1 (45 points)
    Same issue here. No link aggregation works when connecting both ethernet ports to a Netgear GS748T. Part of ifconfig's output shows that line:

    partner system: 0x0000,00:00:00:00:00:00 key: 0x0000 port: 0x0000 priority: 0x0000 state: 0x00

    All these "0" in that line bode ill. I think that behind partner system there should be a valid ethernet address?
  • Michael Ojaste Level 3 (530 points)
    Same issue here. No link aggregation works when
    connecting both ethernet ports to a Netgear GS748T.
    Part of ifconfig's output shows that line:

    partner system: 0x0000,00:00:00:00:00:00 key: 0x0000
    port: 0x0000 priority: 0x0000 state: 0x00

    All these "0" in that line bode ill. I think that
    behind partner system there should be a valid
    ethernet address?

    Jomel I really tend to believe your problem is how you switch is setup. RadUS posted that he was able to get it working on an Xserve and in the other post you made you said that System Pref:Network showed switch problem. The problem we have is with the Mac Pro Intel and it "says the switch is fine". The thing is it does not set the en0 & en1 MAC addresses correctly.
    On the NetGear I would look at a few things.
    1. Make sure LACP is set On and to "Passive" on the Ports for link aggregation.
    2. DO NOT have any "Trunking" active. Apple does not do trunks.
    3. The Switch should not really have any defined trunk or Link aggregation because LACP should handle it automatically. I have heard 2 sides to this and some switches need some defined setup for aggregation to work with Apple OS. According to Apple, aggregation should be controlled wholly by the OS through LACP.
    4. Maybe the NetGear is incompatable with Apple link aggregation. Look to see if the firmware is up-to-date on the Netgear switch.

    RadUS might be able to help you since he got this working on an Xserve.
  • Jomel1 Level 1 (45 points)
    The configuration of the switch cannot be the problem. In the technical papers there is noted that the switch supports link aggregation by using 802.3ad (using manual mode). The only option is to activate a trunk for specific groups of ports. There is no other place to configure or alter that behaviour. The firmware of the switch is the most recent version.

    I tried both to create a link aggregation by activating the trunk on the switch and by leaving that option off. Both ways had the same result that the status of the network panel displayed an amber condition and "problem with partner" message.
    Also that netgear uses the term "trunk" netgear support said that they use it as an equivalent to link aggregation so this should be correct.
Previous 1 2 3 Next