Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Yosemite 10.10.5 Update Disabled Apache

I've just updated Yosemite on a MacBook Pro (17-inch, Mid 2010) from v 10.10.4 to 10.10.5 and now my local development environment is disabled.


Some sites I've researched and changes I've adopted:


Self-signed SSL Certificate on Mac Yosemite

http://brianflove.com/2014/12/01/self-signed-ssl-certificate-on-mac-yosemite/

- created working SSL Certificates and configured Apache to use them


Local SSL websites on Mac OSX

https://gist.github.com/jonathantneal/774e4b0b3d4d739cbc53

- made changes to httpd-vhosts.conf


Fix broken Apache config after Upgrading to OS X Yosemite

http://www.thermalexposure.com/2014/11/14/fix-broken-apache-config-after-upgradi ng-to-os-x-yosemite/

- made changes to httpd-vhosts.conf


Apache issues after upgrade to Mac OS X Yosemite (see comments by 'nicholos')

http://enzolutions.com/articles/2014/10/19/apache-issues-after-upgrade-to-mac-os -x-yosemite/

- made changes to httpd-vhosts.conf


After any change, I did a '$ sudo apachectl configtest', and confirmed a 'Syntax OK' before moving on, then a '$ sudo apachectl -k restart'.


After checking both the Apache error_log and the local development site error_log multiple times and resolving any errors after changes, I do not see any errors.


Now I stuck with, "Firefox has detected that the server is redirecting the request for this address in a way that will never complete," even though this was not a problem before the Yosemite v10.10.5 Update.


Does anyone have a working solution? Thanks

---

Kim

MacBook Pro, OS X Yosemite (10.10.5)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Upon closer inspection, turns out I made a careless error...


In the Apache error_log:

(500)Unknown error: 500: [client 127.0.0.1:59686] No matching instance host name: www.WEBSITE.dev


And my httpd.vhosts.conf included:

<VirtualHost *:80>

DocumentRoot "/Library/WebServer/Documents/WEBSITE/webroot"

ServerName WEBSITE.dev

ServerAlias www.WEBSITE.dev

RewriteEngine On

SSLEngine on

SSLCertificateFile "/private/etc/apache2/ssl/WEBSITE.dev.crt"

SSLCertificateKeyFile "/private/etc/apache2/ssl/WEBSITE.dev.key"

ErrorLog "/private/var/log/apache2/WEBSITE.dev-error_log"

DirectoryIndex index.lasso index.html

</VirtualHost>


The problem was solved by deleting the following from the config:

#ServerAlias www.WEBSITE.dev

#SSLEngine on

#SSLCertificateFile "/private/etc/apache2/ssl/WEBSITE.dev.crt"

#SSLCertificateKeyFile "/private/etc/apache2/ssl/WEBSITE.dev.key"


Thanks Tim for you help...

Posted on

Page content loaded

Aug 16, 2015 11:22 AM in response to kimvan In response to kimvan

Hi.


I had a similar issue; it was due to the location of the server.crt file changing in this 10.10.5 update.


To fix I edited the /private/etc/apache2/extra/httpd-ssl.conf file and changed the line from


SSLCertificateFile "/private/etc/apache2/server.crt"

to

SSLCertificateFile "/private/etc/apache2/ssl/server.crt"

Then restarted Apache via apachectl and everything was fine.

Good luck!

Aug 16, 2015 11:22 AM

Reply Helpful (4)

Aug 18, 2015 9:55 AM in response to stamps-uk In response to stamps-uk

I followed your suggestion stamps-uk, and moved not only server.crt, but also server.csr, server.key and server.key.pub into the /etc/apache2/ssl/ directory.


Then in /etc/apache2/etc/httpd-ssl.conf under the ## SSL Virtual Host Context heading, I not only changed

SSLCertificateFile "/private/etc/apache2/server.crt"

to

SSLCertificateFile "/private/etc/apache2/ssl/server.crt"

but also,

SSLCertificateKeyFile "/private/etc/apache2/server.key"

to

SSLCertificateKeyFile "/private/etc/apache2/ssl/server.key"


I also confirmed that server.crt contained 'CN=localhost' since SSL Virtual Host Context in httpd-ssl.conf is for localhost and contains:


<VirtualHost _default_:443>


# General setup for the virtual host

DocumentRoot "/Library/WebServer/Documents"

ServerName localhost:443

ServerAdmin kimrvan@****.ca

ErrorLog "/private/var/log/apache2/error_log"

TransferLog "/private/var/log/apache2/access_log"


The Apache 'error_log' confirmed these changes worked because now I was seeing:

ssl_util_ssl.c(404): AH02412: [localhost:443] Cert matches for name 'localhost'


But alas, I was still seeing this in my /private/var/log/apache2/WEBSITE-error_log

[client 127.0.0.1:56263] AH01797: client denied by server configuration: /Library/WebServer/Documents/WEBSITE/

Aug 18, 2015 9:55 AM

Reply Helpful (1)

Aug 18, 2015 10:19 AM in response to kimvan In response to kimvan

Here's where I'm at now...


After seeing the line below in /private/var/log/apache2/WEBSITE-error.log

[client 127.0.0.1:56263] AH01797: client denied by server configuration: /Library/WebServer/Documents/sutp/webroot/

research at

http://www.thermalexposure.com/2014/11/14/fix-broken-apache-config-after-upgradi ng-to-os-x-yosemite/

http://stackoverflow.com/questions/18392741/apache2-ah01630-client-denied-by-ser ver-configuration

suggested I replace all occurrences of

Allow from all

Order allow,deny

with

Require all granted


Which I did in

/etc/apache2/extra/httpd-manual.conf

/etc/apache2/extra/httpd-vhosts.conf

/etc/apache2/other/mod_lasso9.conf

/etc/apache2/users/Guest.conf

/etc/apache2/users/USER.conf


And following comments by nicholos in

http://enzolutions.com/articles/2014/10/19/apache-issues-after-upgrade-to-mac-os -x-yosemite/

I moved the <Directory> section from /etc/apache2/httpd-vhosts.conf to /etc/apache2/users/USER.conf


The 'Require all granted' solution eradicated the 'client denied by server configuration' error, however now I'm stuck with,

The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

Aug 18, 2015 10:19 AM

Reply Helpful
Question marked as Solved

Aug 18, 2015 6:09 PM in response to kimvan In response to kimvan

Upon closer inspection, turns out I made a careless error...


In the Apache error_log:

(500)Unknown error: 500: [client 127.0.0.1:59686] No matching instance host name: www.WEBSITE.dev


And my httpd.vhosts.conf included:

<VirtualHost *:80>

DocumentRoot "/Library/WebServer/Documents/WEBSITE/webroot"

ServerName WEBSITE.dev

ServerAlias www.WEBSITE.dev

RewriteEngine On

SSLEngine on

SSLCertificateFile "/private/etc/apache2/ssl/WEBSITE.dev.crt"

SSLCertificateKeyFile "/private/etc/apache2/ssl/WEBSITE.dev.key"

ErrorLog "/private/var/log/apache2/WEBSITE.dev-error_log"

DirectoryIndex index.lasso index.html

</VirtualHost>


The problem was solved by deleting the following from the config:

#ServerAlias www.WEBSITE.dev

#SSLEngine on

#SSLCertificateFile "/private/etc/apache2/ssl/WEBSITE.dev.crt"

#SSLCertificateKeyFile "/private/etc/apache2/ssl/WEBSITE.dev.key"


Thanks Tim for you help...

Aug 18, 2015 6:09 PM

Reply Helpful (2)
User profile for user: kimvan

Question: Yosemite 10.10.5 Update Disabled Apache